Cat: /dev/video0: No such device


#1

Ca faisait longtemps que j’avais pas eu a poster sur ce forum ca me manquait!

J’ai installe camorama pr ma tite webcam etpas de bol qd je lance camorama, j’ai droit a un super message d’erreur:

could not connect to video device (/dev/video0)
Please check connection

Alors j’ai change de prise USB…
Il y a bien un fichier /dev/video0…
j’ai active tous les modules USB webcam dans mon kernel…
J’ai egalement rajoute la ligne suivante ds /etc/fstab

/dev/video0     /media/video0   auto    rw,user,noauto    0    0

mais tjrs le meme message d’erreur au final
:angry:

relou!


#2

si tu n’as pas posté depuis longtemps, c’est parceque tu ne t’interresses peut etre pas assez aux problemes des autres :slightly_smiling:
sinon, rappelles moi, tu es en sarge ? tu utilises hotplug ? hal ? udev ? tu es en noyau 2.6 ?
est ce que “video0” est la quand ta camèra n’est pas branchée ?
quels sont les droits sur “video0” ? Est ce que ca marche en temps que root ?
as tu un autre dispositif v4l, genre une carte TV, ou une entrée VDO sur ta carte graphique (ta cam etant alors peut etre la “video1”) ?


#3

Je reponds a ceux que je peux…
Je ne suis encore qu’un novice de debian et de ses pti pb d’install, etc.

oui

gne??? Connait pas tout ca…
je vais me faire une ptite recherche la dessus! : )

oui: 2.6.9

oui

[quote=“MattOTop”]
quels sont les droits sur “video0” ?

[quote]

video0 en 660

root@B406:/dev# ls -ls video*
0 lrwxrwxrwx 1 root root 6 2005-01-11 02:13 video -> video0
0 crw-rw---- 1 root video 81, 0 2004-09-18 13:53 video0

[quote=“MattOTop”]
Est ce que ca marche en temps que root ?

[quote]

non: idem.

[quote=“MattOTop”]
as tu un autre dispositif v4l, genre une carte TV, ou une entrée VDO sur ta carte graphique (ta cam etant alors peut etre la “video1”) ?
[/quote][/quote][/quote][/quote][/quote]
je n’ai rien de plus et camorama demarre sur le device video0…


#4

installes les si ce n’est pas déja fait. C’est le coeur d’un plug’n play réussi sous debian.

alors qu’est ce qui te prouve que ta cam est en “video0” ?

[quote=“Echo”]

video0 en 660
root@B406:/dev# ls -ls video*
0 lrwxrwxrwx 1 root root 6 2005-01-11 02:13 video -> video0
0 crw-rw---- 1 root video 81, 0 2004-09-18 13:53 video0

non: idem.

je n’ai rien de plus et camorama demarre sur le device video0…[/quote]
C’est bizarre que tu ne puisse pas choisir.
Sinon, changes de visualisateur: le développeur le dit lui même, il a créé ca pour apprendre gtk et v4l, et le prog est balbutiant.
As tu essayé d’autres outils, ne serait ce que pour déboguer ?

emeraude:/home/console# apt-cache search webcam
webcam - capture and upload images
came - Rewrite of the xawtv webcam app using imlib2
camstream - Collection of tools for webcams and other video-devices
camstream-doc - Documentation for camstream
dacode - Powerful and full-featured news engine written in PHP
gkrellkam - GKrellM plugin that displays a periodically updating image
motion - V4L capture program supporting motion detection
ov511-source - Driver source for the OV511, a USB-only chip used in many webcams.
qc-usb-source - source code for QuickCam Express kernel module
qc-usb-utils - Utility programs for the qc-usb kernel module
qce-source - source code for QuickCam Express kernel module
vgrabbj - grabs a image from a camera and puts it in jpg/png format
video4linux-nw802-source - Source for the nw802 driver
webcamd - Capture images from video devices
cqcam - Color QuickCam (PC/Parallel) control program
imgstamp - A timestamping utility for webcam images
camorama - gnome2 tool to view, alter and save images from a webcam
feh - imlib2 based image viewer
gqcam - GTK Webcam control

PS: au fait video0 n’a rien à voir avec un filesystem, supprimes vite ce que tu as mis dans fstab.


#5

au fait sinon, indépendament du soft que tu utilises, c’est quoi ta camera ?
as tu bien verifié avec lsmod que le module correspondant se montait bien quand tu la branche ta camera ?
J’ai oublié de te demander ca, mais c’est quand même élémentaire comme question à se poser :slightly_smiling:


#6

oki mis a part hotplug G tout installe…

mais strictement rien!
camorama je l’utilisais sous Mandrake et il marchait tres bien… et ca passait sur video0 d’ailleurs

non meme pas j’en avais teste plusieurs sous Mandrake etCamorama etait celui ki me plaisait le plus de tous…
Je me suis donc directement oriente vers ce prog.

[edit]
Je viens d’en tester 3 autres…
Le message d’erreur est identique a camorama: ils demarrent tous sur video0.
Je crois qu’on a une preuve que les webcam se lisent sur le device video0.
[/edit]

oui je m’en suis doute apres, c’est deja fait :wink:


#7

[size=200]UP![/size]