Catastrophe après installation carte graphique Nvidia ![RESOLU] :)

optimus
carte-graphique
nvidia
Tags: #<Tag:0x00007f09456d5fd8> #<Tag:0x00007f09456d5c68> #<Tag:0x00007f09456d5998>

#1

Un grand appel au secour, en ce qui me concerne ce matin:

Ma carte graphique n’étant pas installée je décide de le faire en suivant la procedure suivante:

https://wiki.debian.org/fr/NvidiaGraphicsDrivers

Je possède cette carte graphique

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1)

(je vous aurais bien mis la commande que j’ai fait pour afficher cela, mais je ne me souviens plus car je suis sur un autre pc sous fenetres 8)

Dans le tuto, j’ai selectionné la bonne version, j’ai suivi la procedure à la lettre.

vers la fin de l’installation ce message est apparu:

Conflit avec le module "nouveau"
Le pilote graphique est le module libre "nouveau". Il rentre en conflit avec le module non libre "nvidia".
La manière la plus simple pour corriger cela est de redémarrer la machine une fois l'operation terminée.

(j’ai tout recopié j’avais pris une photo avec mon téléphone).

toujours en mode console, la barre de progression arrive au bout.
puis 3 warning apparaissent:
(je recopie encore une photo)

Traitement des actions différées ("triggers") pour initramfs-tools (0.130) ...
update-initramfs : Generating /boot/initrd.img-4.9.0-8-amd64
W: Possible missing firmware /lib/firmware/tigon/tg3_tso5.bin for module tg3
W: Possible missing firmware /lib/firmware/tigon/tg3_tso.bin for module tg3
W: Possible missing firmware /lib/firmware/tigon/tg3.bin for module tg3

je redemarre… et catastrophe:
X ne boot plus

j’ai juste un message d’erreur:

Oh mince Quelque chose s'est mal passé.
Un problème est survenu et le système ne peut pas se récupérer.
Déconnectez-vou et essayez à nouveau...

Ma seul option qui s’offre à moi est le mode console sans échecs a partir du grub!
et la gros desespoir!

Voilà les amis… svp aidez moi… je suis désespéré…
Peut etre meme , ne pas resoudre l’histoire des pilotes tout de suite, mais au moin revenir en arrière dans un premier temps.

un excelllent dimanche à vous tous


#2

Bonjour @andrea

https://wiki.debian.org/fr/NvidiaGraphicsDrivers#Identification mentionne :

La série ou le nom de code du processeur graphique NVIDIA d’une carte graphique peut être identifié habituellement avec la commande lspci.

Note : si cette commande lspci renvoie en sortie plus d’une ligne, vous avez une puce graphique Optimus (hybrid), et les instructions sur cette page ne s’appliquent pas à vous. Veuillez plutôt consulter la page fr/Bumblebee.

Tu as effectivement deux composants graphiques hybrides et le pilote propriétaire nVidia ne s’applique pas à ton système. Il faudra utiliser Optimus, plus tard.

Maintenant il faut réparer…
Ça ne doit pas être si compliqué :wink:

Je laisse la communauté t’aider
Je ne suis pas équipé pour le faire.

Bon dimanche !


#3

merci pour ta breve, mais si précieuse intervention!

avec mes maigres connaissance j’ai fait un remove des paquets installés…
bien entendu ca ne pouvait pas etre aussi simple…
je pense qu’il faudrait modifier les options de x au demarrage, mais la j’avoue que je ne sais pas comment m’y prendre! je préfère etre sur avant de farfouiller… en tout cas… rien d’irréparable n’est ce pas? rassurez moi…


#4

Je suppose que tu as installé le paquet nvidia-driver pour ta carte graphique. Après avoir démarré ta machine passe en mode console en utilisant les touches combinées Ctrl+Alt+F1 et là tu reprends la main sur ta debian; tu passes en root et tu supprimes TOUS les paquets nvidia que tu as installés en utilisant la commande:

apt --purge remove nvidia-driver
apt --purge remove xserver-xorg-video-nvidia

et ensuite tu installe le paquet bumblebee comme indiqué dans le wiki.


#5

Succès total,
merci infiment pour votre aide précieuse!

J’ai fait:

apt --purge remove nvidia-driver
apt --purge remove xserver-xorg-video-nvidia

et apres j’ai suivi ceci à la lettre:
https://debian-facile.org/doc:materiel: … ia:optimus

et du coup la preuve par neuf que ca fonctionne:

sans nvidia:

andrea@debian:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
368 frames in 5.0 seconds = 73.479 FPS
300 frames in 5.0 seconds = 59.856 FPS
300 frames in 5.0 seconds = 59.855 FPS
300 frames in 5.0 seconds = 59.858 FPS
300 frames in 5.0 seconds = 59.860 FPS
300 frames in 5.0 seconds = 59.852 FPS

Avec Nvidia :

andrea@debian:~$ optirun glxgears

7216 frames in 5.0 seconds = 1443.096 FPS
7224 frames in 5.0 seconds = 1444.632 FPS
7068 frames in 5.0 seconds = 1413.508 FPS
7361 frames in 5.0 seconds = 1472.058 FPS
7239 frames in 5.0 seconds = 1447.689 FPS
7132 frames in 5.0 seconds = 1426.394 FPS
[VGL]    269: Window has been deleted by window manager

donc un veritable grand merci à tous!:):):):):):):):):):slight_smile: