[CDROM] Problème graveur et CDROM


#1

Bonsoir

Je sous sous Debian sid.

J’ai activé l’émulation SCSI pour mon graveur dans lilo :
append=“hdd=ide-scsi”

Mais maintenant je ne peux plus monter mon disque hdd ??? (/dev/cdwriter is not a valid block device)

/dev/cdwiter est un lien vers /dev/hdd

J’ai lu dans un Howto que les lecteurs CD-ROM hdc et hdd deviennent scd0 et scd1 avec l’émulation, mais le montage de scd0 et scd1 ne marche pas plus. En revanche le montage de mon premier CD-ROM sur hdc marche toujours.

Et k3b me met d’autres erreurs au démarrage comme :

K3b uses cdrecord to actually write cds. Without cdrecord K3b won’t be able to properly initialize the writing devices.
Solution: Install the cdrtools package which contains cdrecord.

Or cdrecord est déjà installé, le paquet cdrtools n’existe pas.


#2

Maintenant ça marche mais j’ai toujours des erreurs au démarrage de k3b (cdrecord n’est pas trouvé)


#3

en vrac :
l’utilisateur est dans le groupe cdrom ?
as tu le module emulation scsi cdrom (sg machin) si <2.6
est ce bien hdc > dmesg |grep ROM
le lien /dev/cdwriter pointe il correctement (cat /dev/… répond ?)
en root, cela marche ?
en ligne de commande cdrecord il te dit quoi comme erreur
as tu fais un lilo après ton vi /etc/lilo.conf, sinon est ce grub ?

euh pour l’instant j’ai rien d’autre…


#4

[quote=“ginkyo”]en vrac :
l’utilisateur est dans le groupe cdrom ?
as tu le module emulation scsi cdrom (sg machin) si <2.6
est ce bien hdc > dmesg |grep ROM
le lien /dev/cdwriter pointe il correctement (cat /dev/… répond ?)
en root, cela marche ?
en ligne de commande cdrecord il te dit quoi comme erreur
as tu fais un lilo après ton vi /etc/lilo.conf, sinon est ce grub ?

euh pour l’instant j’ai rien d’autre…[/quote]

as tu le module emulation scsi cdrom (sg machin) si <2.6
Oui

le lien /dev/cdwriter pointe il correctement (cat /dev/… répond ?)
Oui

as tu fais un lilo après ton vi /etc/lilo.conf, sinon est ce grub ?
Oui

En ligne de commande, cdrecord donne :
/usr/bin/cdrecord: line 8: /usr/bin/cdrecord.mmap: Permission denied
/usr/bin/cdrecord: line 8: exec: /usr/bin/cdrecord.mmap: cannot execute: Success

En root ça marche…


#5

J’oubliais, l’utilisateur est dans le groupe cdrom.


#6

Bonjour,

le groupe cdrom.
reset ensuite
les droit complet sur le vrai périphérique, c quoi ?
(pas sur le lien)

en ligne de commande cdrecord il te dit quoi comme erreur ???

Au fait la politesse c’est en option chez toi ?


#7

Bonjour

[quote]>le groupe cdrom.
reset ensuite[/quote]

C’était peut-être ça, maintenant ça a l’air de marcher. En tous cas je n’ai plus d’erreur au démarrage de k3b et je vois les lecteurs.

Merci :smiley:


#8

Salut,
j’aurrais quelques question car j’ai la même erreur (celle pour cdrecord) avec ma Sid et k3b.
le groupe “cdrom”, c’est comme le groupe “audio” ou “video”? comment peut on savoir si on a un groupe cdrom?
voila, c’est tout, mrci :wink:


#9

c’est dans le fichier /etc/group