Chargement de modules automatique


#1

Bonjour à tous,

Mon ordinateur portable, aciennement sur mandrake vient de passé sous debian. Tout s’est bien passé sauf pour le wifi. En ffait j’utilise le module acerhk permettant d’utiliser la l’allumage du wifi et le probleme c’est que je n’arrive pas à charger ce module au demarrage. Sous mandrake il me suffisait de mettre les ligne suivantes dans le fichier rc.sysinit :

action “Chargement acerhk” /sbin/modprobe acerhk force_series=290 usedritek=1 verbose=1
echo 1 > /proc/drivers/acerhk/wirelessled

J’ai avoulu faire la meme chose sur ma debian mais ce ficher n’existe pas.
J’aurai donc aimé savoir quel est le ficher équivalent au rc.sysinit sous ma nouvelle distrib ?


#2

Je ne sais pas l’equivalent sous debian mais tu peux rajouter le nom de ton module dans /etc/modules et normalement il devrais etre chargé au démarrage :slightly_smiling:


#3

effectivement ça marche !!! cool !!
Le module est chargé mais il ne fait pas ce que j elui demande c’est étrange. Je vais continuer à chercher.

Merci pour cette lumiere sur une chose qui était si obscure pour moi :slightly_smiling:


#4

[quote=“LeDoc”]effectivement ça marche !!! cool !!
Le module est chargé mais il ne fait pas ce que j elui demande c’est étrange. Je vais continuer à chercher.

Merci pour cette lumiere sur une chose qui était si obscure pour moi :slightly_smiling:[/quote]
Tes options, il faut les rajouter dans le fichier /etc/modules.conf ou encore dans le repertoire modutils:
Exemple:

jeannot@teloche:/etc/modutils$ cat ivtv
# ivtv settings
alias char-major-61 lirc_i2c
alias char-major-81 videodev
alias char-major-81-0 ivtv
alias char-major-81-1 ivtv
options ivtv ivtv_debug=2
jeannot@teloche:/etc/modutils$       

#5

hum alors si je comprend bien il faut que je crée un fichier acerhk dans modutils comme suit :

acerhk setting

alias force_series=290
alias usedritek=1
alias verbose=1
alias echo 1 > /proc/drivers/acerhk/wirelessled

je me trompe ?

Sinon j’ai regarder le fichier modules.conf mais apparement ce ficheir doit être exclusivement modifié de manière automatique?

Une autre question comment le system fait il la liaison entre un module et les bons parametres qui lui correspondent ?


#6

[quote=“jabba”][quote=“LeDoc”]effectivement ça marche !!! cool !!
Le module est chargé mais il ne fait pas ce que j elui demande c’est étrange. Je vais continuer à chercher.

Merci pour cette lumiere sur une chose qui était si obscure pour moi :slightly_smiling:[/quote]
Tes options, il faut les rajouter dans le fichier /etc/modules.conf ou encore dans le repertoire modutils:
Exemple:

[code]
jeannot@teloche:/etc/modutils$ cat ivtv

ivtv settings

alias char-major-61 lirc_i2c
alias char-major-81 videodev
alias char-major-81-0 ivtv
alias char-major-81-1 ivtv
options ivtv ivtv_debug=2
jeannot@teloche:/etc/modutils$
[/code][/quote]
Et non…
Jabba, il faut mettre tes connaissances à jour: elles concernent les noyaux 2.4.
LeDoc: tu as raison pour ton fichier acerhk, sauf qu’il faut le mettre dans /etc/modprobe.d, si tu as bien un noyau 2.6…
Jabba, tu fais presque autant d’erreurs que moi en ce moment… Il faut rajouter des vitamines à ton alimentation.


#7

:cry: :cry: :cry:
Je pense que j’ai plus besoin de vacances que de vitamines …
Je vais me mettre “au vert un moment” 8)
:arrow_right:


#8

Au vert ou au verre? :laughing: :laughing: :laughing:


#9

En cette periode, je vais bien sur commencer par la 2eme option … :stuck_out_tongue:


#10

Bon apres avoir essayé le fichier acerhk placé dans modutils mais le resultat espérant continu de se faire attendre.

Du coup je me suis mis à la meme chose que jabba le vert mais ça ne m’a pas aidé non plus.

De nouveles recherches mon permises de découvrir que je pouvait ajouter les lignes suivantes au fichier modprobe.conf:

[code]# module parameters for acerhk
options acerhk force_series=290 usedritek=1 verbose=1

reset transceiver on load

install acerhk /sbin/modprobe --ignore-install acerhk && /bin/echo 1 > /proc/driver/acerhk/wirelessled && echo 0 > /proc/driver/acerhk/wirelessled && /bin/echo 1 > /proc/driver/acerhk/wirelessled[/code]

Le probleme ?? j’ai pas ce fichier qui normalement est dans /etc/
comment puis faire en sorte d’avoir ce fichier dans ma configuration ou tout simmlement comment faire marcher mes options dans le fichier crée (“acerhk”) dans modutils.

Mon noyau est un 2.6.10 si ça eut aider…


#11

La config des modules se trouve dans /etc/modprobe.d/ maintenant, si je ne me trompe pas. Après y avoir placé un fichier de configuration, tu dois faire update-modules pour écrire le fichier de config global des modules… mais où est ce fichier global, je l’ignore ?? Avant c’était modprobe.conf …

Ceci dit avec apt c’est la même chose et je ne souviens pas qu’il y est une commande à exécuter. Je n’ai même pas de apt.conf ! Seulement /etc/apt/apt.conf.d/ donc … et ça marche tout seul :wink:


#12

Vivent les Ardennes libres !


#13

AU verres maintenant !!! 8)


#14

je confirme:
à partir du 2.5.18, le noyau cherche sa configuration dans modprobe.d et /etc/modutils, /etc/modules.conf et update-modules n’ont plus de rôle à jouer.
On peut éventuellement utiliser un modprobe.conf, mais comme ca court circuite l’utilisation de modprobe.d, il faut penser à mettre une ligne “include /etc/modprobe.d” si l’on tient absolument à utiliser un modprobe.conf compatible avec debian…


#15

Bon ça yest c’est la fête la config fonctionne de cette maniere

dans le fichier modules j’ai mis acerhk
puis dans modprobe.d j’ai crée un fichier acerhk contenant les ligne suivantes

[code]# module parameters for acerhk
options acerhk force_series=290 usedritek=1 verbose=1

reset transceiver on load

install acerhk /sbin/modprobe --ignore-install acerhk && /bin/echo 1 > /proc/driver/acerhk/wirelessled && echo 0 > /proc/driver/acerhk/wirelessled && /bin/echo 1 > /proc/driver/acerhk/wirelessled[/code]

Et le tout fonctionne merci à toute l’équipe pour l’accueil et l’aide !! grace à vous je comprend un peu mieux le fonctionement de debian