Chargeur de boot win xp


#1

Bonsoir tout le monde,
J’ai installé lilo sur ma sarge en MBR. Mais il ne boot pas xp qui est sur hda1 en ntfs.
J’ai reussi a monter la partition hda1 sous linux et je vois que ntldr (le chargeur de démarrage de win xp) est bien present (mais je ne peux pas le lire car gedit me dit qu’il ne reconnait pas les encodage des caractères). Le fichier boot.ini est aussi present.
Je vous livre le contenu de mon lilo.conf

[code]# /etc/lilo.conf - See: lilo(8)' andlilo.conf(5)’,

--------------- install-mbr(8)',/usr/share/doc/lilo/’,

and `/usr/share/doc/mbr/’.

±--------------------------------------------------------------+

| !! Reminder !! |

| |

| Don’t forget to run `lilo’ after you make changes to this |

| conffile, `/boot/bootmess.txt’ (if you have created it), or |

| install a new kernel. The computer will most likely fail to |

| boot if a kernel-image post-install script or you don’t |

| remember to run `lilo’. |

| |

±--------------------------------------------------------------+

Specifies the boot device. This is where Lilo installs its boot

block. It can be either a partition, or the raw device, in which

case it installs in the MBR, and will overwrite the current MBR.

boot=/dev/hda

Specifies the device that should be mounted as root. (`/’)

root=/dev/hda2

Enable map compaction:

Tries to merge read requests for adjacent sectors into a single

read request. This drastically reduces load time and keeps the

map smaller. Using `compact’ is especially recommended when

booting from a floppy disk. It is disabled here by default

because it doesn’t always work.

compact

Installs the specified file as the new boot sector

You have the choice between: text, bmp, and menu

Look in lilo.conf(5) manpage for details

#install=menu

Specifies the location of the map file

map=/boot/map

You can set a password here, and uncomment the `restricted’ lines

in the image definitions below to make it so that a password must

be typed to boot anything but a default configuration. If a

command line is given, other than one specified by an `append’

statement in `lilo.conf’, the password will be required, but a

standard default boot will not require one.

This will, for instance, prevent anyone with access to the

console from booting with something like `Linux init=/bin/sh’,

and thus becoming `root’ without proper authorization.

Note that if you really need this type of security, you will

likely also want to use `install-mbr’ to reconfigure the MBR

program, as well as set up your BIOS to disallow booting from

removable disk or CD-ROM, then put a password on getting into the

BIOS configuration as well. Please RTFM `install-mbr(8)’.

password=tatercounter2000

Specifies the number of deciseconds (0.1 seconds) LILO should

wait before booting the first image.

delay=100

You can put a customized boot message up if you like. If you use

`prompt’, and this computer may need to reboot unattended, you

must specify a `timeout’, or it will sit there forever waiting

for a keypress. single-key' goes with thealias’ lines in the

image' configurations below. eg: You can press1’ to boot

Linux',2’ to boot LinuxOLD', if you uncomment thealias’.

message=/boot/bootmess.txt

prompt

delay=100

timeout=100

Specifies the VGA text mode at boot time. (normal, extended, ask, )

vga=ask

vga=9

vga=normal

Kernel command line options that apply to all installed images go

here. See: The boot-prompt-HOWTO' andkernel-parameters.txt’ in

the Linux kernel `Documentation’ directory.

append=""

If you used a serial console to install Debian, this option should be

enabled by default.

serial=

Boot up Linux by default.

default=Linux
timeout = 100
prompt

image=/vmlinuz
label=Linux
read-only

restricted

alias=1

initrd=/initrd.img

image=/vmlinuz.old
label=LinuxOLD
read-only
optional

restricted

alias=2

initrd=/initrd.img.old

If you have another OS on this machine to boot, you can uncomment the

following lines, changing the device name on the `other’ line to

where your other OS’ partition is.

other=/dev/hda1
label=Windows
restricted[/code]

Dans l’outil système de démarrage de ma debian sarge, il est affiché qu’il ne reconnait pas ce qu’il y a comme système d’exploitation sur hda1.
Que faire ?


#2

au moment du lancement d’XP, tu lui tourne la tête, puisqu’il a été installé sur le disque de boot et que maintenant, son disque de boot (linux en l’occurence), n’est même plus lisible pour lui (puisqu’XP ne sait lire que les formats microcrotte).
il faut donc “tromper” le bios pour lui faire dire à winxp qu’il a booté sur son disque. D’aprés le man de lilo.conf:

il semblerait que ce soit obsolete, mais en attendant, ca marche toujours, donc tu rajoutes les lignes “map-drive” dans la section “other”, et ca devrait marcher.
Si tu veux tu peux aussi regarder comment fonctionne “boot-as=”, option que je ne connais pas.
Sinon, obsolescence pour obsolescence, je suis passé à grub, qui est à mon sens beaucoup plus robuste (on peut booter même avec une mauvaise config), mais avec le 64bits et le bios EFI, il va falloir en apprendre encore d’autres (des boot loaders).
Enfin… Juste pour info…


#3

Non décidément, ça marche pas. Quand lilo se lance il n’y a même pas l’entrée windows qui est proposée. J’ai bien rajouté ces lignes :

map-drive=0x80 to=0x81 map-drive=0x81 to=0x80
Mais rien n’y fait. Sinon, grub, moi je veux bien sauf qu’il est tjrs limité au 1024 cylindre et que ma partoche linux hda2 et largeemnt plus loin (note que j’ai pas essayé l’option lba).
D’autre part, il y a un délire dans le configurateur de boot de debian qui me demande quel chargeur de boot je veux configurer grub ou lilo (mais mon grub ne marche plus, il doit être sur hda2)
Bref un festival … :cry:


#4

hopopopopo !
pas tout en même temps. Deja, le pb de lilo.
Aprés avoir modifié lilo.conf, as tu bien lancé la commande ‘lilo’ (sans argument, qui réecrit le MBR avec les infos de /etc/lilo.conf) ?
sinon, l’entrée ‘label=windows’, c’est celle la qu’il faut modifier, et je ne comprends pas ce que vient faire la le ‘restricted’ .


#5

He ben t’as vu l’erreur, le restricted n’avait rien a faire là. C’est ce qui a posé problème quand j’ai tapé lilo. Mais ça m’a échappé la première fois. La deuxième j’ai commenté la ligne su restricted et enlevé le map-drive et ça marche.
En tout cas un grand merci pour ton soutient et ton travail. :stuck_out_tongue:
Parce que sans ça ma femme m’aurait fait la gueule. Cool. Merci encore


#6

yo !
de nada…