Clavier Apple Magic Keyboard bluetooth (via 'bluetoothctl')

Tags: #<Tag:0x00007ff8f22ac6f8> #<Tag:0x00007ff8f22ac180>

Bonjour.

J’utilise bluetoothctl en ligne de commandes pour gérer le bluetooth d’un mac mini 2012.

J’ai un clavier logitech qui s’y connecte très bien à chaque invite de session après démarrage.

Le clavier Apple Magic Keyboard demande à chaque démarrage d’être reconnecté manuellement.
Celui-ci est bien à chaque démarrage dans ma liste d’appareil de confiance mais il ne se connecte pas automatiquement.
Donc, via un autre clavier (par exemple le logitech) je dois ouvrir ma session et lancer la commande pour associé le clavier apple.

Alternativement:
Je pourrais utiliser mon fichier ~/.config/i3/config pour lancer l’association au clavier apple dès l’ouverture de session…
Mais comment puis je associé ce clavier depuis lightdm.

Mais, je pense que cela n’est pas forcément la meilleur solution…
Le clavier bluetooth logitech peut être utiliser dès lightdm pourquoi dois-je manuellement reconnecter celui de Apple?

Ais je oublié une commande ou étape ?

A titre informatif:
Pour bluetoothctl, je me suis aidé de ce tuto:
https://www.makeuseof.com/manage-bluetooth-linux-with-bluetoothctl/
et une fois le paquet installé, la manpage ne renseigne pas trop et il faut utiliser l’option –help pour avoir les détails d’utilisation.

mercii
a bientôt
C.

J’e viens de trouver ceci mais je ne sais si c’est pertinent …
https://github.com/irreleph4nt/mkinitcpio-bluetooth
Je n’ai pas encore essayé…

A savoir, je suis en dual-boot avec une Debian 11 et un macOS.
J’utilise rEFInd pour le choix de l’os.

rEFInd: https://www.rodsbooks.com/refind/
L’installation de celui-ci s’est fait via le macOS… Je ne sais si cela change quelque chose à une quelconque configuration à l’installation de ce bootloader.

voilà donc

Bonjour,

Si tu utilises déjà la commande, tu peux éventuellement faire en sorte que la commande que tu lances pour connecter le clavier se lance automatiquement au démarrage.
Je ne connais pas la commande bluetoothctl, mais s’il y a moyen de vérifier qu’un périphérique est bien connecté, tu peux éventuellement fait un petit script qui vérifie que le clavier est bien connecté à intervalles réguliers et le connecte si ce n’est pas le cas.

Tu peux sans doute regarder ce que font les gars de Arch pour ça :

https://wiki.archlinux.org/title/bluetooth_keyboard

Hello.

Disons que à mes session avec ce clavier … une fois connecté, celui d’Apple fonctionne très bien.
Je dois juste utiliser la commande :
bluetoothctl connect [ADRESS_MAC]
ADRESS_MAC étant l’adresse MAC du clavier Apple.
(ni utilisé l’option ‹ pair › ou ‹ trust ›, ça c’est ok)

J’utilise i3 donc il m’est facile d’ajouter une ligne au fichier ~/.config/i3/config:
exec_always --no-startup-id "bluetoothctl connect [ADRESSE_MAC]"

Mais cela ne m’avance pas à tellement plus, juste un petit peu:
lightdm ne reconnait pas le clavier Apple, contrairement au clavier Logitech.

rEFInd quand à lui, no problème avec le clavier Apple mais ne reconnait pas celui de Logitech.

Vais regarder cela avec un traducteur en ligne !..
Merci. Qui sait ?

Vais aussi allez voir la doc de lightdm, peut-être une piste.
Mais je vois pas pourquoi un clavier bluetooth plus qu’un autre pourrait ou ne pourrait pas se connecter et qu’une commande doit être à chaque fois exécuté …

mercii
a+

Tu peux aussi le déclencher à l’aide de cron, par contre, je ne sais pas comment faire.
La document dit qu’il faut utiliser le mot-clef @reboot, mais je n’ai jamais réussi à le faire fonctionner, mais c’était il y a longtemps.

ok ok … new piste
merci