Clavier en AZERTY lors du mot de passe demandé par ZFS

Tags: #<Tag:0x00007feddb2cc060> #<Tag:0x00007feddb2d7f50>

Bonjour,
j’ai essayé de trouver quelques tutos sur le sujet mais rien.
En gros mon disque est chiffré avec ZFS.
Comme n’importe quel disque chiffré il demande un mot de passe, sauf que sous ZFS, la tape est en qwerty.
J’ai essayé de mofigier le /etc/default/grub, de créer un fr.gkb avec la commande

grub-mklayout

dans /boot/grub mais toujours en qwerty au démarrage (et seulement au démarrage).

Quelqu’un aurait réussi sous buster à réaliser cette manip’ ?

Merci d’avance.

Ben en cherchant “grub keyboard layout”, j’ai trouvé plein de trucs, notamment ça:


ça parle bien de gkb, mais ils le génèrent avec grub-kbdcomp (ce qui est sans doute proche de grub-mklayout) mais surtout, aprés, ils modifient la config grub pour indiquer qu’il faut prendre le bon layout, puis ils l’appliquent avec un update-grub
Tu as fait tout ça en plus de génèrer ton .gkb ?

Bonjour,
Une solution, qui n’ en est pas une :

  • mettre un mot de passe qui ne serait pas sensible au changement azerty<->qwerty !

@Albert : Effectivement ! mais remarquons qu’un mot de passe que je dois taper en qwerty c’est une sécurité de plus tiens :stuck_out_tongue:
@mattotop : oui c’est ce que j’ai fait :confused: mais sans succès.

Je ne l’ai pas cité dans mon résumé, mais tu as bien aussi créé le fichier /etc/grub.d/40_custom comme indiqué ?

Aussi, et les directives apparaissent bien dans le grub.cfg
C’est ça qui m’étonne.

On vient de me donner la solution :dans /etc/initramfs-tools/initramfs.conf :

KEYMAP=y

Puis recharger l’initramfs, tout simplement