Clé USB etc


#1

Ma clé USB j’arrive pas à la faire fonctionner même après avoir compiler et activer la usb (mass-storage) voici quelque information.
Aussi j’ai pas du son j’ai installer alsa 0.9.3c
J’ai une carte mère ASUS P4PE

Merci

/ETC/FSTAB

/etc/fstab: static file system information.

/dev/hda2 / ext3 errors=remount-ro 0 1
/dev/hda3 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda4 /mnt/fat32 vfat defaults,rw,user,uid=1000,gid=1000,umask=022 0 0
/dev/hda1 /mnt/w2k ntfs defaults,ro,user,uid=1000,gid=1000,umask=000 0 0
/dev/sda /mnt/keyusb vfat defaults,noauto,user,uid=1000,gid=1000,umask=022 0 0

MOUNT /MNT/KEYUSB

BLK-DEBIAN:/home/fabrice# mount /mnt/keyusb/
mount : /dev/sda n’est pas un périphérique de bloc valide.

LSMOD

BLK-DEBIAN:/usr/src/linux# lsmod
Module Size Used by Tainted: P
sd_mod 9948 0 (autoclean) (unused)
nls_cp437 4384 2 (autoclean)
vfat 9404 2 (autoclean)
fat 30104 0 (autoclean) [vfat]
sg 24964 0 (autoclean) (unused)
scsi_mod 84552 2 (autoclean) [sd_mod sg]
snd-pcm-oss 36260 0 (autoclean)
nls_iso8859-1 2848 1 (autoclean)
nvidia 1539616 10 (autoclean)
snd-mixer-oss 11072 1 (autoclean) [snd-pcm-oss]
snd-intel8x0 15968 1
snd-pcm 57760 0 [snd-pcm-oss snd-intel8x0]
snd-timer 13856 0 [snd-pcm]
snd-page-alloc 4480 0 [snd-intel8x0 snd-pcm]
snd-ac97-codec 33808 0 [snd-intel8x0]
snd-mpu401-uart 3104 0 [snd-intel8x0]
snd-rawmidi 12352 0 [snd-mpu401-uart]
snd-seq-device 3892 0 [snd-rawmidi]
snd 27168 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
ppp_deflate 2944 0 (autoclean)
zlib_deflate 17536 0 (autoclean) [ppp_deflate]
zlib_inflate 18432 0 (autoclean) [ppp_deflate]
bsd_comp 3968 0 (autoclean)
ppp_async 6688 1 (autoclean)
ppp_generic 19020 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
slhc 4448 0 (autoclean) [ppp_generic]
3c59x 25608 1
ntfs 49472 1
rtc 6460 0 (autoclean)

vim /etc/modutils/son

/etc/modutils/son

Fichier de configuration des modules ALSA (nouvelle syntaxe)

Formation Debian GNU/Linux par Alexis de Lattre

via.ecp.fr/~alexis/formation-linux/

Ne pas oublier d’exécuter “update-modules” après chaque modification

alias char-major-116 snd
alias char-major-14 soundcore
options snd cards_limit=1 intel8x0 irq=7 dma=1

Remplacez “nom_du_module_ALSA” par le nom du module ALSA de votre carte son

(avec le préfixe “snd-”)

alias snd-card-0 snd-intel8x0

alias sound-slot-0 intel8x0
#snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Merci


#2

Essaye ceci :
mount /dev/sda1 /mnt/keyusb

si ca marche pas
tu peu regarder les logs :

dans /var/log/message , quand je branche ma clé, j’ai ca :

Jun 1 13:30:42 tibian kernel: Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
Jun 1 13:30:42 tibian kernel: SCSI device sda: 256000 512-byte hdwr sectors (131 MB)
Jun 1 13:30:42 tibian kernel: sda: Write Protect is off
Jun 1 13:30:42 tibian kernel: sda:<7>usb-storage: queuecommand() called
Jun 1 13:30:42 tibian kernel: sda1

on voit sur la dernière ligne que sda1 est ma clé !

vala
++


#3

J’ai réussi il fallait que je compile le noyau avec mass storage et scsi support.
et faire un apt-get install alsa-base alsa-utils
Et j’ai ajouter :
/dev/sda1 /mnt/keyusb vfat defaults,noauto,user,uid=1000,gid=1000,umask=022 0 0
au lieu de :
/dev/sda /mnt/keyusb vfat defaults,noauto,user,uid=1000,gid=1000,umask=022 0 0