Comment comprendre et traiter les nouveaux avertissements d’aptitude

Tags: #<Tag:0x00007f58cbc7f4e0> #<Tag:0x00007f58cbc7f148> #<Tag:0x00007f58cbc7f030> #<Tag:0x00007f58cbc7eec8> #<Tag:0x00007f58cbc7ebd0>

Bonjour o/

Depuis que je suis passé à Debian 11, le comportement d’aptitude contient une nouvelle fonctionnalité d’alerte qui prévient au cas où le paquet que l’on tente d’installer contient des bugs.

Par exemple, en tentant d’installer FontForge, j’optien la sortie de terminal suivante :

aptitude install fontforge
Les NOUVEAUX paquets suivants vont être installés :
  fontforge fontforge-common{a} libfontforge4{a} libspiro1{a} libuninameslist1{a}
0 paquets mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/5 749 ko d'archives. Après dépaquetage, 22,9 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité serious sur fontforge (→ 1:20201107~dfsg-4) <En attente de traitement>
 b1 - #665334 - non-DFSG postscript embedded in fontforge (currently August 2014
Résumé :
 fontforge(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à niveau les paquets ci-dessus ? [Y/n/?/...]

Le message adopte un ton assez alarmiste « gravité sérieuse », limite s’il dit « Non mais franchement mec, n’installe pas ce paquet » :joy_cat:. Mais sinon qu’en est-il vraiment ?

Quels sont les risques que l’on peut encourir ? Après tout, ça n’est que FontForge, ce n’est pas un navigateur, un clavardeur, ou courrielleur ou n’importe quel truc qui permet de se connecter à l’Internet.

Donc, en résumé, puis-je en dépit du message d’érreur l’installer (FontForge ou d’autres paquets qui présentent un message d’erreur), et au pire qu’est-ce que je risque ?

Merci par anticipation o/

Bonjour,

sympa cette fonctionnalité d’aptitude.
Le point fort est que tu as l’identifiant Debian du bug en question (665334), du coup c’est assez simple d’avoir le détail: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665334
En l’occurrence, c’est « juste » un problème de licences logicielles, donc pas de problème pour la majorité des utilisateurs, mais un sacré casse-tête pour les mainteneurs.

1 J'aime

Ah bah, merci, si ce n’est que ça, moi j’installe :>

Après, ce que j’ai donné n’était qu’un éxemple. Y’a d’autres messages selon les différents paquets. Je ne vais pas vous interroger sur chaque paquet un par un, mais je me demandais s’il y’avait, quelque part un forum ou quelque chose du genre dédié à chaque cas, pour savoir si on peut malgré tout installer ou pas.

Non effectivement, tu peux faire ce qu’a fait Sputnik93 en cherchant dans le bugs tracker de Debian, le lien au dessus est exploitable il suffit juste d’adapter avec le numéro adéquat :wink:

1 J'aime

Bonjour,

apt-listbugs te fournit exactement la même fonctionnalité pour l’outil apt - paquet hautement conseillé sous Sid.

1 J'aime