Comment installer midisport-firmware

Bonjour à tou(te)s,
J’utilise Debian 8 depuis 4 ans sur un mac pro 1 après des années sur PC et ubuntu et ça marche super.

J’aimerais faire fonctionner sous debian un boitier M-audio midisport pour commander un clavier maître. Il faut un driver, midisport-firmware qui malheureusement ne se trouve apparemment plus sous aucun dépot linux… Je l’ai trouvé sur sourceforge mais ne sais pas comment l’installer par ce biais… Pourrait-on m’aider?

En vous remerciant par avance!

Bonjour,

Ah bon ?


Par contre il faut activer les dépôts non-free

Merci! J’avais bien trouvé cette page, mais n’avais pas su quoi en faire.
Je viens d’activer les dépôts non-free par ce biais:

Pour la suite je sèche: En réponse à la commande
apt-get ou aptitude install midisport-firmware
on me répond qu’ il n’y a pas de version candidate.
Je sais pas par ailleurs installer directement depuis la page que vous m’indiquez: il est question de miroirs et là je suis un peu perdu!

Peut-être recharger le cache de APT avec un update avant ?

Comment fait-on pour recharger le cache? Les updates sont faites.
Et sinon pour installer directement depuis la page, sans apt?

Merci!

apt-get update

Après cela, que disent

apt-cache policy | grep non-free
apt-cache policy midisport-firmware

Il y a un lien « Téléchargement » en bas de la page. Ce paquet dépend du paquet fxload qu’il faudra installer préalablement. Le paquet .deb peut être installé avec dpkg -i ou apt install.

Merci! la réponse est

installé: (aucun)
Candidat: (aucun) 

(je n’arrive pas à faire de copier/coller)

Pour télécharger directement, je suis sur cette page:

En cliquant sur :
ftp.us.debian.org/debian
j’accède au téléchargement en interface graphique (que j’extrais et qui apparaît ensuite dans mon dossier personnel) mais il me semble en vous lisant devoir le faire via le terminal, n’est-ce pas (afin de le rendre opérationnel)? Et là je ne sais pas très bien comment faire…
J’avais déjà installé fxload en lignes de commande.
Merci encore.

Cela signifie que soit tu as mal modifié /etc/apt/sources.list pour ajouter la section « non-free » (peux-tu montrer son contenu ?), soit tu n’as pas mis à jour la liste des paquets ensuite avec apt-get update.

Il n’y a rien à extraire. Il faut enregistrer le fichier .deb tel quel et l’installer en tant que root avec

dpkg -i /chemin/vers/midisport-firmware_1.2-4_all.deb

Quelle est la commande pour montrer son contenu ?
J’ai fait en root:

apt install software-properties-common
add-apt-repository contrib
add-apt-repository non-free
cat /etc/apt/sources.list{,.d/*}

Je ne connais pas cette commande add-apt-repository, je modifie directement le fichier sources.list. Mais contrib et non-free ne sont pas des dépôts, ce sont des sections.

Je dois dire que je suis un peu dépassé!..
je n’arrives pas à faire un copier/coller de la réponse qui m’est donnée dans le terminal à la commande

de même pour

En dehors de ces démarches infructueuses, j’ai en revanche pu installer midisport-firmware_1.2-4_all.deb en faisant tout simplement un clic droit de la souris où je me suis vu proposer : ouvrir (l’archive) avec gestionnaire de paquet, et ça marche!!!
Du coup je vais pouvoir travailler, ça commençait à urger! Merci beaucoup à tout le monde!!

Qu’est-ce qui t’en empêche ?
Quel terminal utilises-tu ? Une console virtuelle (tty1-6), un émulateur de terminal (xterm, gnome-terminal…) ?

Au pire tu peux recopier à la main, ce n’est pas insurmontable.

En tty. S’il n’y a pas le choix, bien sûr que ce n’est pas insurmontable…

Tu peux installer gpm pour faire des copier-coller avec la souris en tty.
Tu peux aussi rediriger la sortie standard et la sortie d’erreur d’une commande dans un fichier texte :

commande > sortie.txt 2>&1

C’est inutile pour la commande cat qui ne fait qu’afficher le contenu des fichiers en argument, qu’on peut aussi bien afficher directement depuis l’interface graphique.
Mais pourquoi ne pas plutôt utiliser un émulateur de terminal ?