Comment installer ou compiler riverwm

Tags: #<Tag:0x00007fedddaf0ac8>

Bonjour, j’ai toutes les peines du monde à compiler le window manager river.
La version du compiler zig du dépot est dépassé, et river lui-même n’est pas présent. J’ai installé zig mais il manque des paquets pour le reste, et je ne sais pas lesquelles, parce que chaque distrib empaquête les programmes à sa façon… que c’est intelligent.
Voici les paquets demandés dans le readme:

To compile river first ensure that you have the following dependencies
installed. The "development" versions are required if applicable to your
distribution.

- [zig](https://ziglang.org/download/) 0.12
- wayland
- wayland-protocols
- [wlroots](https://gitlab.freedesktop.org/wlroots/wlroots) 0.17.2
- xkbcommon
- libevdev
- pixman
- pkg-config
- scdoc (optional, but required for man page generation)

Ce genre de chose est franchement énervante. Comment être sûr d’avoir les derniers paquets de développement (pour une compilation) pour chacune de ces choses ? Pour zig j’ai la bonne version en tout cas. Est-ce qu’il ya une seule personne sur debian qui utilise river ??

salut
les versions de developpement sont souvent les programmes avec -dev à la fin par exemple wayland-dev ou libwayland-dev
mais là j’ai regardé, c’est vraiment pas clair ; j’ai réussi à créer zig2 par bootstrap mais le build de river ne marche pas