Comment utiliser la carte 4G intégrée?

Tags: #<Tag:0x00007f32e8078948>

Bonjour,

Sous Debian Bullseye, je souhaite faire fonctionner la 4G sur un laptop ayant un emplacement pour carte sim. Comme je n’ai jamais fais ça auparavant et que je ne trouve pas beaucoup de documentation, j’ai du mal à savoir par où commencer.

Il s’agit d’un Elitbook 850 G3 dont il ne semble pas y’avoir eu beaucoup de test sous Linux mis à part cette sortie d’lspci et cette page du wiki de Debian mais pour un modèle différent quoique proche.

Bah en résumé, je ne sais vraiment pas par où commencer. Il me semble que le service qui gère ce genre de fonctionnalité est ModemManager or le paquet modemmanager est déjà installé chez moi.
Donc simplement, quelle est la marche à suivre maintenant ? :slight_smile:

Merci par anticipation

Salut,
Petite question en passant, est-ce que tu as déjà essayer d’utiliser la carte 4g en insérant une carte sim dans l’emplacement prévu à cet effet ?

Non, pas encore. Tu voudrais dire que ça marche out-of-the-box ? =)

Bonsoir,

lire la doc de ce service ?

Justement, comme je ne sais absolument pas quel service s’en occupe, je venais entr’autre quérir son nom que je puisse faire des recherches dessus :slight_smile: Pour le coup, je ne sais ni si c’est dbus, ni acpi, ni Network Manager qui s’en occupe, en fait.

Bonjour
Dans l’applet network-manager, quand tu cliques sur créer une nouvelle connexion, il te demande de sélectionner un type de connexion : là tu peux choisir Connexion mobile.

1 J'aime

Bon, bon, bon, je viens d’insérer une carte SIM, mais le problème, je le crains, est que ma debian ne détecte même pas le modem intégré. J’ai installé modem-manager-gui or lorsque je le lance, que je sélectionne NetworkManager ou ppdf comme gestionnaire de connexion, j’aboutis à « Pas de périphériques trouvés sur le système ».

mmcli me renvoit :

% mmcli -L 
No modems were found

Parcnotre, lsusb voit bien :

Bus 001 Device 002: ID 03f0:521d HP, Inc HP hs3110 HSPA+ Mobile Broadband Device

Bonjour , normalement si tout est bien configuré et que la carte modem 4G est prise en charge , il faut :

  • inserer une carte sim dans la fente prevu a cet effet .
  • parametrer une nouvelle connexion en passant par networkmanager comme l’ a dit @blunt .

une fois les parametres renseigne correctement , logiquement la connexion devrait etre fonctionnelle si il y a bien du reseau .

Toutefois , a la vue du retour de la commande mmcli -L , il se peut que le modem ne soit pas reconnu comme tel ou bien qu ’ il ne soit pas activé .
que donne : rfkill list
cat /lib/udev/rules.d/40-usb_modeswitch.rules

Merci à tous pour vos réponses :slight_smile: Entre temps, j’ai jeté un œil sur ce que font les copains de Mint, notement ici,

Et je suis parvenu aux conclusions qui suivent :

  1. Déjà, il fallait installer wvidal ;
  2. J’ai suivit les opérations décirtes dans le script suivant pour parvenir à faire détecter le modème :
modprobe qmi_wwan
modprobe option
echo "03f0 521d" > /sys/bus/usb-serial/drivers/option1/new_id

usb_modeswitch -H -v 03f0 -p 521d -s 10

echo "2" > /sys/bus/usb/devices/1-3/bConfigurationValue

wvdial 3G

Sachant que 03f0 et 521d sont les identifiants du constructeur et du périférique qu’affiche usb-devices.

Et c’est bon je peux accéder aux zinternets mondiales depuis mon modème \o/.


Nez en moins, deux problèmes se posent encore :

  1. Cette configuration n’est pas persistante ;
  2. Je n’arrive pas à envoyer d’sms depuis mmcli.

Je ne traiterais ici que du premier pour lequel j’ai déjà des élements de réponses sur cet autre fil d’un forum de Suse.

En fait, il préconise tout bettement de faire un service sur Systemd. En revenche, et c’est la ma (probablement derinère) question : est-il utile de le baptiser Huawey alors que le matos est fabriqué par HP ? Pourquoi ont-ils fait ça ?

perso je verrai plus ça comme nom d’unité systemD :

truc-a-la-con.service

En fait ce n’est qu’un nom du moment que l’unit et raccord avec ce que tu désires, le nom est accessoires.

1 J'aime

Parfait, bon bah, vala ce que je fis :

Dans le /usr/bin/hpbroadbandcard :

#!/bin/sh

modprobe qmi_wwan
modprobe option
echo "03f0 521d" > /sys/bus/usb-serial/drivers/option1/new_id

usb_modeswitch -H -v 03f0 -p 521d -s 10

echo "2" > /sys/bus/usb/devices/1-3/bConfigurationValue

wvdial 3G

Dans le /etc/systemd/system/hpbroadbandcard.service

[Unit]
Description=Load driver for HP hs3110 HSPA+ Mobile Broadband Device
Before=network.target

[Service]
Type=oneshot
ExecStart=/usr/bin/hpbroadbandcard
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target

Dès que je teste ça, je fais un retour et marque comme [Résolu].

2 J'aime

Bon bah, c’est bon, tout fonctionne comme sur des roulettes.

À ceux qui tomberont sur ce fil de discussion, le message précédent résume ce qu’il y’a à faire. Bonne chance à vous :slight_smile: