Compil de mplayer


#1

Hi there.
Bon, je m’amuse comme un fou avec ma compil d’mplayer que j’ai chargé depuis le cvs:
mplayerhq.hu/homepage/design7/dload.html
j’ai passé ma journée à faire des configure en ajoutant des libs de developpement dans tous les sens pour essayer d’obtenir une compilation avec un maximum de fonctionnalités, mais je n’avais pas encore testé le make.
pour info, j’ai découvert qu’on pouvait directement créer un paquet mplayer debian avec une commande DEB_BUILD_OPTIONS="--enable-gui --enable-menu" fakeroot debian/rules binary(ma liste d’options est beaucoup plus longue et active tout ce qui est possible).
Enfin, là n’est pas la question, mon problême est le même si je passe par un bête configure/make:
lors de la compil, j’ai dû créer au dessus du rep main de mplayer des liens symboliques pour passer au delà d’une série d’erreur ‘Makefile:4: …/config.mak: No such file or directory’ (et aussi …/config.h), et ca semblait passer, mais maintenant, ca plante lors de la compil des ffmpeg.
Ca ne dis rien à quelqu’un ?
Hein Jabba ?


#2

ffmpeg, c’est une petite bête sensible celle-là… Surtout ne pas la contrarier … :laughing:
Bon, comme je l’avais déjà laisser entendre dans un post précédent, j’ai testé différentes manières d’installer mplayer.
Y compris par la création de package Debian. J’avais réussi la création de ce package Debian du premier coup, sans options particulières, en suivant bêtement les indications données. Le problème est que aussitôt après l’apt-get upgrade suivant, ca ne marchait plus … :cry:
C’est ça qui m’a définitivement convaincu de ne plus faire de packaging debian pour ce genre de soft.

La seule que personnellement, je trouve la mieux adaptée pour un installation stable et qui ne casse pas à chaque apt-get upgrade, c’est une installation complètement isolée du système de packaging Debian.
Je mets toute la collection des utilitaires multimédia (codecs, libs …) dans /usr/local que je compile à la main. C’est souvent long et douloureux mais c’est la seule manière d’avoir un environnement fonctionnel.
Autre avantage, quand tu as ton environnement stable, tu fais un copier-coller de ton /usr/local, sur une autre machine et ca marche pratiquement à tous les coups
Mais j’imagine qu’en ayant une machine complètement en Sarge, il doit être possible d’obtenir un environnement stable, même en installant mplayer et le multimédia qu’avec des packages Debian, sinon je commencerais à désespérer de Debian… :frowning:

Sinon, pour ton problème, j’avais construit le .deb sans l’option “–enable-gui”, ce qui explique peut-être pourquoi je n’avais pas rencontré d’erreur…


#3

Bizarre, j’ai jamais eu besoin de faire ça …


#4

J’ai trouvé hier soir avant de me coucher: j’avais fait des liens symboliques vers …/ffmpeg/libav* au lieu de les copier…
Une fois corrigé, ca a bien compilé, mais j’ai essayé ce matin, et malgré le --enable-gui, quand je lancemplayer sans arguments, il ne se passe rien. J’ai essayé avec un fichier, ca passe, mais je croyais que je pouvais ouvrir un fichier aprés avoir lancé mplayer, non ?
Par ailleurs, tu prends quel output (x11, gl, xv,…), toi ?


#5

[quote=“MattOTop”]J’ai trouvé hier soir avant de me coucher: j’avais fait des liens symboliques vers …/ffmpeg/libav* au lieu de les copier…
Une fois corrigé, ca a bien compilé, mais j’ai essayé ce matin, et malgré le --enable-gui, quand je lancemplayer sans arguments, il ne se passe rien. J’ai essayé avec un fichier, ca passe, mais je croyais que je pouvais ouvrir un fichier aprés avoir lancé mplayer, non ?
Par ailleurs, tu prends quel output (x11, gl, xv,…), toi ?[/quote]

xv et essaie avec gmplayer alors

@+


#6

[quote=“MattOTop”]J’ai trouvé hier soir avant de me coucher: j’avais fait des liens symboliques vers …/ffmpeg/libav* au lieu de les copier…
Une fois corrigé, ca a bien compilé, mais j’ai essayé ce matin, et malgré le --enable-gui, quand je lancemplayer sans arguments, il ne se passe rien. J’ai essayé avec un fichier, ca passe, mais je croyais que je pouvais ouvrir un fichier aprés avoir lancé mplayer, non ?
Par ailleurs, tu prends quel output (x11, gl, xv,…), toi ?[/quote]
En général je prends xv mais tout dépends ton matos et avec quelles options tu as compilé, essayes-les toutes, pour voir.
x11 fonctionne aussi correctement mais ca bouffe plus de CPU chez moi.
Au cas oû, c’est “mplayer -vo help” pour connaître tous les drivers supportés.

Pour ouvrir un fichier, tu devrais y arriver avec un clic droit, non ?


#7

oui, mais comment tu fais pour un dvd distant, ou pour accrocher un stream realmedia ?
Pas que ca me gène de travailler en ligne de commande, mais alors à quoi sert --enable-gui, dans ce cas ?
Bon, gmplayer sinon, j’ai trouvé pkoi ca marche pas: c’est parceque j’ai pas de skin. je suis en train de corriger ça.


#8

Euh, je peux poser une question bête ? Pourquoi vous utilisez pas des packages déjà tout fait ? :confused:


#9

par curiosité


#10

[quote=“MattOTop”]oui, mais comment tu fais pour un dvd distant, ou pour accrocher un stream realmedia ?
Pas que ca me gène de travailler en ligne de commande, mais alors à quoi sert --enable-gui, dans ce cas ?
Bon, gmplayer sinon, j’ai trouvé pkoi ca marche pas: c’est parceque j’ai pas de skin. je suis en train de corriger ça.[/quote]
Ah, tu arrives à lire du realmedia ? Explique-moi vite comment tu fais :smiley:
Pour ma part, vu que mplayer est interfaçé avec ma tv, je n’utilise pas le gui. Et quand je veux utiliser mplayer autremenent, un pt’it raccourci dans l’explorateur de fichiers me suffit.


#11

Pour toutes les excellentes raisons citées plus haut ! :wink:


#12

je te rassure, j’utilise les packages pour mplayer et tous les codecs, ça m’a pris 2 minutes 50 à tout installer il y a de ça plusieurs mois maintenant et tout fonctionne toujours aussi bien comme au premier jour :smiley:

laissons les vieux faire joujou :stuck_out_tongue:


#13

je te rassure, j’utilise les packages pour mplayer et tous les codecs, ça m’a pris 2 minutes 50 à tout installer il y a de ça plusieurs mois maintenant et tout fonctionne toujours aussi bien comme au premier jour :smiley:
laissons les vieux faire joujou :stuck_out_tongue:[/quote]Comme dit un grand philosophe de chez toi:[quote=“Benoit POELVOORDE”]Viens là gamin ! C’était pour rire gamin ![/quote]les vieux t’e#{[^ent :smiling_imp:


#14

:laughing: :laughing: :laughing: :smiling_imp: :smiling_imp: :smiling_imp:


#15

p’tit Gregory va :stuck_out_tongue:


#16

C’est arrivé près de chez vous ? (je ne suis pas sûr :frowning: )


#17

KD je confirme :d

En attendant que je remette mplayer en version Jabba tu peux me dire avec quelles libs tu lis tes dvds car mplayer n’aime pas chez moi?


#18

libdvdnav4,libdvdplay0,libdvdread3 ?


#19

sans oublier libdvdcss :slightly_smiling:


#20

libdvdcss2 en fait, que j’avais oublié parcequ’il n’apparait pas dans l’apt-cache de la machine sur laquelle je regardais.
Merci ghost