Compilation du kernel -->kernel panic


#1

Bonjour,

Apres compilation et installation du noyau, au reboot j’ai le message suivant :

Quelqu’un peut m’aider à identifier le probleme.

Merci


#2

Il faudrait déjà qu’on sache comment tu l’as compilé ton kernel.

Méthode standard ou méthode debian ?

Et tu as créé ton initrd ?


#3

J’ai utiliser la metode debian.

J’ai copier l’ancien fichier de configuration et j’ai rajouté le modul pour carte tokenring madge 16/4 mk2. avec make menuconfig.

j’ai compiler, installer le .deb et résultat : ne boot pas sur le nouveau noyau.

C’est quoi initrd ?

Merci


#4

Ok… Nous y voilà ! :laughing:

Je te conseille de lire la man page. (man initrd)

Tu peux créer ton initrd pour ton nouveau noyau, de la manière suivante:
mkinitrd -f -v /boot/initrd-release-de-ton-noyau

il faut bien sûr adapter ton grub en conséquence:

Tu peux aussi reprendre la compil. de puis le début avec les optiions:
make-kpkg clean
make-kpkg –initrd
Ensuite tu mets ton grub à jour avec update-grub.


#5

desolé mais je début,

-f -v : ça fait quoi je ne trouve pas ces option dans man ou --help.
initrd-release-de-ton-noyau : je remplace par linux-2.6.13.4 ? (mon nouveau noyau)

comment adapter grub ? et pourquoi ?

Merci beaucoup pour ton aide.


#6

‘-v’ ca doit etre verbeux, et ‘-f’ pour forcer. Tu as essayé -? pour avoir l’info en ligne de commande ?

Sinon, il n’a pas dit que tu fasse une mise à jour de grub, il à dit que tu fasses ‘update-grub’ (‘man update-grub’ pour plus d’infos.


#7

Je n’arrive pas a faire mkinitrd, de plus les option -v et -f ne semble pas exister elle ne figure pas dans l’aide et le manuel (mkinitrd -?, mkinitrd --help ou man mkinitrd)

je commence à désesperer, tout cela à cause d’une carte token ring !!!

Merci à vous


#8

Bon, désolé de t’avoir laissé tomber :wink: C’est seulement maintenant que j’ai pu me reconnecter sur le forum…

En fait voici la commande exacte pour mkinitrd:


mkinitrd -o /boot/initrd.img-2.6.8-1-386 /lib/modules/2.6.8-1-386/

Il faut bien sûr adapter en fonction de la version du kernel que tu as compilé. Ensuite, tu modifies ton grub comme ça:

title           Debian GNU/Linux, kernel 2.6.11-23juillet
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.11-23juillet root=/dev/sda1 ro
initrd          /boot/initrd.img-2.6.11-23juillet
savedefault
boot

Ca veut dire que en plus de la ligne “kernel=…” tu dois rajouter la ligne “initrd=…”

Ensuite tu reboote et ça devrait être bon…

Mais bon, au lieu d’insister avec mkinitrd, tu aurais pu, comme je l’avais proposé plus haut refaire une compil avec l’option “–initrd”. Et ensuite, lancer un update-grub. Ca t’aurait tout fait automatiquement…

Pour faire les choses proprement, il te faut avoir les paquets suivants installés:
debhelper modutils kernel-package libncurses5-dev

Un bonne doc:
http://newbiedoc.sourceforge.net/system/kernel-pkg.html


#9

Merci je vais essayer.

j’ai recompiler avec cette methode j’ai eu le meme message au reboot.

Je fonce tete baissé dans la compilation d’un noyau mais à l’origine c’est pour faire fonctionner une carte résau tokenring : madge smart 16/4 pci ringnode.

j’ai ouvert un poste à ce sujet mais là aussi je ne trouve pas de solution.
http://forum.debian-fr.org/viewtopic.php?t=1497

à tu une idée ?


#10

Au fait, zylv, pour info, je suis dans le même caca pour compiler mon 2.6.13: quoi que je fasse, j’ai aussi un kernel-panic.
Et j’ai pourtant testé comme .config aussi bien la config de mon noyau courant (un 2.6.12) que celle d’un noyau 2.6.13 pris en binaire (mais qui n’est pas compilé avec mppe, dc ca ne me conviens pas).
Voila, voila…


#11

y aurai il un probleme avec le noyau 2.6.13 ?


#12

c’est possible, mais je n’ai pas encore trouvé lequel.
Je vais faire ce que je dis d’eviter de faire: je vais récupèrer les sources kernel.org, et les debianiser, pour voir…