Config reseaux. help


#1

bonjour a tous je vous explique mon problème. j’ai installer Debian sur un pc pour qu’il server de DHCP sur un site distant de ma boite. Et je voudrait lui rentrée en static sont ip correspond au site .
J’ai suivi le tuto present sur votre site mais sa fonctionne pas :cry: :cry:

j’ai fait:

iface eth0 inet static
adress 172.22.0.156
netmask 255.255.0.0
broadcast 172.22.255.255
network 172.22.0.0

mais meme comme ca je peut pas avoir l’ip. Si je remet en
iface eth0 inet DHCP il ne prend pas ip (on dispose d’un dhcp sur notre siteprincipal)

Comment resoudre se soucis.


#2

quel tuto ?
tu as mis un ‘auto eth0’ dans ton fichier d’interfaces pour que la carte soit active au démarrage ?
sinon, j’ai pas trop compris le problême. Quel rapport avec le dhcp ?


#3

si j’ai bien compris, il souhaite mettre en place un serveur dhcp et la on voit la config réseau dudit serveur.

[quote]# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or

/usr/share/doc/ifupdown/examples for more information.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 172.22.0.156
netmask 255.255.0.0[/quote]

ca devrait suffire pour fonctionner mais tu ne pourras pas avoir d’acces internet ou a un autre réseau vu que tu n’indique pas de gateway


#4

re , bon la c’est bon ca remarche mon linux a recuperer une adrese par le dhcp.

Bon j’expose se que je veut faire. Je veut installer un serveur dhcp sur un des site que dispose ma société .J’ai installer sur le site principal le linux avec le pacage DHCP3 et je configurait le dhcpd.conf sur le site en question.

La se que je veut faire, c est sur le linx que j’ai preparer lui attribuer une adresse IP fixe (qui correspond a l adresse du site ou je vait installer le serveur DHCp :172.22.0.156) et je suis aller dans le fichier /etc/network/interfaces pour changer la config :

auto eth0
iface eth0 inet static
adress 172.22.0.156
netmask 255.255.0.0
broadcast 172.16.255.255
gateway 172.22.0.1

mais des que je met ce ci et que je reboot le linux et que je fait ifconfig l’adresse (172.22.0.156) n’est pas pris en compte.

donc voila le soucis.


#5

hum… si je comprend bien, tu prépares un serveur dans un environnement qui ne sera pas l’environnement d’utilisation… est tu certain qu’il n’y a pas de conflit d’IP avec une autre machine actuellement ?


#6

(l’orthographe, ça n’est pas ça…)

Il n’est pas nécessaire de rebouter, fais un ifdown eth0 suivi d’un ifup eth0 pour tester.

Tu dis que ça n’est pas pris en compte, mais encore? Que donne

ifconfig eth0 (après)

ping 172.22.0.156

ping 172.22.0.1

route -n


#7

[quote=“guigui69”]auto eth0
iface eth0 inet static
adress 172.22.0.156
netmask 255.255.0.0
broadcast 172.16.255.255
gateway 172.22.0.1[/quote]

hum… il y a 2 D dans “address” …


#8

bien vu…


#9

MDR… j’avais la meme boulette sur un autre Topic…