Config Samba


#1

Bonjour,

Je suis confronté à un petit pb.
J’ai un serveur samba sur une machine linux. Sur cette machine est mounté un repertoire distant qui se trouve sur une machine Unix.
J’accède à la machine Linux à partir de poste sous Win.
Jje crée un fichier avec notepad que j’enregistre sur le repertoire Unix via Samba (donc, pour ceux qui n’ont pas suivi :laughing: sur la machine Linux).
Si j’edite ce fichier avec Vi directement de la machine Unix, à chaque retour chariot j’ai : ^M.

Y -a-il un param dans Samba qui pourrait me permettre de ne plus avoir ces retour chariot?
Merci


#2

il y a forcément une option, soit dans samba, soit dans nfs.
Mais dsl, je n’ai pas trouvé.


#3

Sinon tu as la commande unix :

dos2ux ou dos2unix pour enlever les retour chariot de windaube.

Par contre pour ce qui est des config smb je ne peu aucunement t’aider.


#4

merci pour vos réponses.

J’aivais bien vu dos2Unix mais vu le nombre de fichiers qui est copié je ne peux pas mes les taper tous à la main.

Merci quand même!


#5

Alors tu tapes un truc dans le style:
cd /dans-ton-repertoire
for fichier in *.txt
do
dos2unix -a $fichier
done

C’est quand même mieux que le clickodrome, non ? :laughing:


#6

merci du tuyau jabba mais il faut que j’arrive à le faire directement avec samba.
C’est apparement une histoire de “unicode”. Je suis en train de mettre à jour samba car apparement unicode est géré à partir de la V3


#7

Tu pourrais en faire un script qui est démarré régulièrement sur le serveur …
Mais bon, si samba se paramètre dans ce sens, pourquoi pas.


#8

Je viens de réaliser, c’est normal qu’un fichier dos finisse ses lignes avec ^j^m alors que le standard ascii c’est ^j tout seul : un eol ne suffit pas, il faut à bill un nl en plus. C’est comme ceux qui portent bretelles et ceinture, la redondance m’énerve.

C’est pour dire qu’en fait, maintenant que j’y réflechit, ca me parait normal, tes symptomes, et il ne faut toucher à rien dans ta config. Si tu veux absolument modifier sous linux tes fichiers windows, tu n’as qu’a utiliser emacs: il reconnait le format dos, et l’enregistrement se fera toujours au format dos. Si tu commences à transcoder tes fichiers textes windows, c’est avec tes clients windows que tu te mettra à avoir des pb…

Par ailleurs, le dos2unix sur des binaires me parait dangereux pour leur intègrité, fais attention si tu décides de transcoder tes fichiers.


#9

disons que j’ai pris l’exemple de notepad mais en fait ce qui pose vraiment problème c’est pour d’autres fichiers.
En fait je suis en stage dans une ets qui developpe ces propres applics.
Les sources sont sur un serveur unix. Les develops utilisent win car il existe un edi qui leur permet d’avoir une indentation avec des couleurs pour les instruction…
Ils voudraient pouvoir sauver directement sur le serveur. J’ai donc commencé à mettre en place Samba mais j’ai ces retours chariot.
Donc si je les laisse la compil va foirer. J’ai regardé leur edi mais il n’a pas d’option pour sauver en Unicode.
C’est pour cela que je me tourne vers Samba.


#10

Tu pourrais aussi leur proposer d’utiliser UltraEdit qui permet justement de sauvegarder leur code en format Unix.


#11

Le pb avec ultra edit est qu’il n’est pas libre.
Et ils veulent progressivement passer au libre


#12

Effectivement, tu as raison ce n’est pas libre …
Mais si tu dis qu’il veulent passer au libre, alors pourquoi ne pas leur proposer directement de passer leur station de travail sous linux, alors ?
Du coup, plus aucun souci de conversion de fichier.


#13

mais les compils, ils les font avec linux, ou sous win ?