Configuration de MPlayer ( ou plutôt du son...)


#1

Hello tout le monde,

Je suis en train de me construire une Freevo Box. Pour ça, j’ai à peu près tout recompilé les décodeurs recommandés sur la page du lecteur MPlayer. Tous les codecs aussi ont été installés.
(oui, je sais, je n’ai pas compilé à la méthode Debian, pas bien… :frowning: )

Quand je lance la lecture d’un fichier .wma OU mp3. Il fait la lecture mais aucun son ne sort et il me balance le message suivant:


[AO OSS] audio_setup: Can’t open audio device /dev/dsp: No such device
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO SDL] Unable to open audio: No available audio device

J’ai installé le serveur X “morceau par morceau”, pour ne pas trop alourdir l’ensemble.
J’ai sûrement oublié quelque chose mais je ne trouve pas quoi …

/dev/dsp, c’est en rapport avec KDE, il me semble ???

Si je lis le même titre en utilisant le soft “music123”, ca marche impecc…

Si je lis un fichier vidéo .avi ou autre ca marche, mais toujours avec le même message d’erreur, donc pas de son non plus pour la vidéo.
Je suis sûr que ce n’est pas une question de codecs, mais q’une bête quesion de config. du son, mais je ne trouve pas…

Une idée ?

Voici le détail avec mplayer, lancé en ligne de commande:

freevo:~/MEDIA/Sarah.Brigthman-The.best.of.1990-2000# mplayer 03-Who\ Wants\ to\ Live\ Forever\ -\ The\ London\ Symphony\ Orchestra,\ Sarah\ Brightman.wma

MPlayer dev-CVS-050207-17:58-3.3.5 © 2000-2005 MPlayer Team
CPU: Advanced Micro Devices K6-2 (Family: 5, Stepping: 12)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compil\uffff pour CPU x86 avec les extensions: MMX 3DNow

Linux RTC init error in ioctl (rtc_irqp_set 1024): Invalid argument
Try adding “echo 1024 > /proc/sys/dev/rtc/max-user-freq” to your system startup scripts.
Joue 03-Who Wants to Live Forever - The London Symphony Orchestra, Sarah Brightman.wma
Fichier de type ASF d\ufffftect

Ouverture du d\uffffcodeur audio: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x9), ratio: 16002->176400 (128.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))

Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit…
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little-endian 16-bit signed int
AF_pre: 44100Hz 2ch little-endian 16-bit signed int

[AO OSS] audio_setup: Can’t open audio device /dev/dsp: No such device
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO SDL] Unable to open audio: No available audio device

AO: [null] 44100Hz 2ch little-endian 16-bit signed int (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit…
Vid\uffffo: pas de vid
D\uffffmarre la lecture…
A: 4.1 (04.1) 14.5%

MPlayer interrompu par le signal 2 dans le module: play_audio
freevo:~/MEDIA/Sarah.Brigthman-The.best.of.1990-2000#

Merci


#2

bon, ca ressemble plus à un problème quand au système de son auquel fait appel MPlayer.
Il semblerait qu’il soit configuré pour faire appel au vieux système de son OSS, celui qu’à terme, alsa va remplacer.
Tu as dc deux pistes

  • débuguer ton OSS : voir si les modules de ta carte son de la famille oss te fournissent bien un /dev/dsp (au fait, as tu vérifié les droits sur ce fichier ?).
  • configurer ton MPlayer pour qu’il fasse appel au bon système de son, comme les autres (ca peut etre alsa, esound, ou nas, ou d’autres :slightly_smiling: )…
    PS: ce n’est peut etre pas MPlayer qui fait appel au système de son. Il semble qu’il est fait aussi mention dans ton message d’erreur d’une couche SDL (l’équivalent linux de DirectX). C’est peut etre aussi la qu’il faut configurer le bon système de son…
    PPS: en tout cas, tes messages ne concernent pas le décodage.

#3

Le problème, c’est que j’ai recompilé mon kernel en virant explicitement toute référence à OSS, à n’y plus rien comprendre … :open_mouth:

Selon les conseils du site Mplayer, j’ai vérifié les droits sur /dev/dsp et /dev/dsp0 et tout est correct…

J’ai tout misé sur alsa et le module de ma carte son (emu10kl…) est bien la version alsa.
Ca marche parfaitement en jouant mon fichier mp3 avec l’utilitaire en ligne de commande “music123” mais pas avec Mplayer …

Pour ce qui est des packages et autre décodeurs recommandés, j’ai recompilé (ou installé les paquets debian disponibles:

SDL, libpng, libjpeg, lame, zlib, libogg, libvorbis, libxmms, libavcodec, libavformat, FFMPEG … . Bref, à peu près tous les outils recommandés pour faire une Freevo Box…

Quand j’avais testé la première fois ma carte son, j’avais dû mettre default=alsa à la place de default=oss dans le fichier /etc/libao.conf, et seulement après ça, le son avait fonctionné avec music123 …
–> Vestige oss de l’installation de base d’une debian ?

Je viens de re-parcourir mon fichier configure.log de Mplayer, et j’y trouve des messages assez explicites:

  1512 ##########################################
   1513
   1514 ============ Checking for aRts ============
   1515 ./configure: line 4440: artsc-config: command not found
   1516 Result is: no
   1517 ##########################################
   1518
   1519 ============ Checking for EsounD ============
   1520 ./configure: line 4466: esd-config: command not found
   1521 Result is: no
   1522 ##########################################
   1523
   1524 ============ Checking for Polyp ============
   1525 ./configure: line 4501: pkg-config: command not found
   1526 Result is: no
   1527 ##########################################
   1528
   1529 ============ Checking for JACK ============
   1530 Result is: no
   1531 ##########################################

   1531 ##########################################
   1532
   1533 ============ Checking for ALSA audio ============
   1534
   1535 #include <sys/asoundlib.h>
   1536 int main(void) { return (!(SND_LIB_MAJOR==0 && SND_LIB_MINOR==5)); }
   1537
   1608
   1609 Result is: no
   1610 ##########################################

Ca se passe de commentaire, bien sûr … :confused:

Le problème est que Mplayer est censé accepter alsa esound et autre aRts PAR DEFAUT lors de la compilation …
Je vais essayer de lui forcer ces valeurs à la construction du Makefile …

Je dois dire que je n’y comprends pas grand chose au système de sons sous linux… :frowning:

Si je compile le kernel pour alsa, il peut prendre quoi, comme système de sons (n’importe lequel de: alsa esound ou aRts ??? )

Est-il correct de garder le support OSS en parallèle à alsa, au cas oû d’anciens programmes auraient besoin de l’émulation oss ?

Merci et A+

Jabba


#4

[quote=“Jabba”]<…>
Pour ce qui est des packages et autre décodeurs recommandés, j’ai recompilé (ou installé les paquets debian disponibles:

SDL, libpng, libjpeg, lame, zlib, libogg, libvorbis, libxmms, libavcodec, libavformat, FFMPEG … . Bref, à peu près tous les outils recommandés pour faire une Freevo Box…[/quote]
Je pense que le problème vient du mix entre debian et les paquets que tu as compilés (j’imagine que tu les as compilés avec make install, pas avec apt-build ? )

[quote=“Jabba”]Quand j’avais testé la première fois ma carte son, j’avais dû mettre default=alsa à la place de default=oss dans le fichier /etc/libao.conf, et seulement après ça, le son avait fonctionné avec music123 …
–> Vestige oss de l’installation de base d’une debian ?[/quote]
Tu as regardé s’il n’y avait pas le même genre de config à faire avec la SDL, finalement ?

[quote=“Jabba”]Je viens de re-parcourir mon fichier configure.log de Mplayer, et j’y trouve des messages assez explicites:

<...>
   1531 ##########################################
   1532
   1533 ============ Checking for ALSA audio ============
   1534
   1535 #include <sys/asoundlib.h>
   1536 int main(void) { return (!(SND_LIB_MAJOR==0 && SND_LIB_MINOR==5)); }
   1537
   1608
   1609 Result is: no
   1610 ##########################################

Ca se passe de commentaire, bien sûr … :confused: [/quote]

C’est là que je dis que ton installation mixte entre les .deb et les tar.gz fout la zouille: manifestement, le ./configure de MPlayer ne reconnais pas le systeme de son alsa tel qu’il est installé.
Tu l’avais bien installé, ainsi que toutes les autres libs, avant de compiler MPlayer ?
Sinon, quitte à compiler, j’aurais vraiment utilisé apt-build pour rester en logique debian.

[quote=“Jabba”]Le problème est que Mplayer est censé accepter alsa esound et autre aRts PAR DEFAUT lors de la compilation …
Je vais essayer de lui forcer ces valeurs à la construction du Makefile … [/quote]
Regardes dans les options de configure si tu ne peux pas lui passer le repertoire des includes alsa.
Tu peux “hacker” un peu le systeme: tu trouves asoundlib.h, et tu fais les liens symboliques nécessaires ans tes reps d’include pour que le configure le trouve et détecte la présence d’alsa.

tu veux un scoop : moi non plus :slightly_smiling:
mais en te répondant, j’ai trouvé ca, qui n’est pas mal:
applications.linux.com/print.pl? … 28/2229232

Alsa assure surtout la partie materielle, qui au travers du module fournit l’accés au devices (il emule/remplace OSS, normalement). Il fournit aussi les utilitaires de réglage des niveaux et l’interface mixer.

le démon permet juste le multiplexage du son (plusieurs pgm peuvent accèder simultanément au devices). Alsa n’assure pas, je crois ce multiplexage, et c’est pour ca qu’il faut un serveur de son par dessus.
le serveur esound est vieillissant.
de son coté, quoi qu’intègré à KDE, aRts est compatible avec tous les wm.
il existe d’autres serveurs de son…

[quote=“Jabba”]Est-il correct de garder le support OSS en parallèle à alsa, au cas oû d’anciens programmes auraient besoin de l’émulation oss ?
Merci et A+
Jabba[/quote]

Ce contre indiqué nulle part, mais ca fait double emploi, je crois.
Par contre, peut etre quand même qu’il faut activer les options de base d’OSS dans ton noyau: pas les modules, puisque tu utilises ceux d’alsa, mais quand même les options de base d’OSS (je n’ai pas ces options en tète). C’est fort possible que cela soit necessaire pour l"émulation.


#5

Oui, en fait je devrais recommencer, à la méthode Debian…

Je ne pense pas pouvoir tout compiler à la méthode Debian, mais au moins Mplayer, là je sais que les sources sont prévues pour.

[quote]Tu as regardé s’il n’y avait pas le même genre de config à faire avec la SDL, finalement ?
[/quote]
Là aussi, je vais revoir toute la doc et pas seulement le readme …

[quote]C’est là que je dis que ton installation mixte entre les .deb et les tar.gz fout la zouille: manifestement, le ./configure de MPlayer ne reconnais pas le systeme de son alsa tel qu’il est installé.
Tu l’avais bien installé, ainsi que toutes les autres libs, avant de compiler MPlayer ? [/quote]
Oui toutes les libs requises par Mplayer ont été soit installées par apt-get, soit par ./configure … et le système alsa a été entièrement installé via les paquets debian. Peut-être que si je ré-installe alsa à la mode “goret”, comme Mplayer, il sera correctement reconnu… :stuck_out_tongue:

Pourquoi j’avais choisi de maintenir ma solution en dehors du système Debian:

  1. Pour pouvoir upgrader mes libs et autres codecs EN DEHORS des apt-get upgrade Debian.
    Raison: souvent si on fait des maj. du système Debian, en testing, il y a des trucs qui ne fonctionnent plus. Le son en est un exemple tristement célèbre …:frowning:
    Et cette install, j’ai plutôt envie de l’installer, de la stabiliser de la placer sous la télé, de ne l’upgrader qu’en cas de besoin (nouveaux codecs). Je n’ai pas très envie de devoir résoudre un problème d’upgrade, le samedi soir, quand c’est l’heure de regarder le film … :slightly_smiling:

  2. Quand j’aurai des sous :unamused: , je vais m’acheter un mini-PC qui sera du plus bel effet sous ma télé. Un copier-coller de /usr/local/*, suivi d’une recompilation générale me paraissait plus facile à faire qu’une re-configuration debian avec toutes les librairies exotiques requises par le soft Freevo/MPLayer.
    L’idée étant de ne faire qu’une install Debian basique sur le nouveau PC et ensuite, copier-coller /usr/local puis recompiler pour “que ca colle” avec la nouvelle architecture…

l’erreur que je fais actuellement, c’est peut-être de mettre le système de son avec les packages debian et Mplayer compilé à l’ancienne mode …

Qu’en penses-tu ?

[quote]u veux un scoop : moi non plus Smile
mais en te répondant, j’ai trouvé ca, qui n’est pas mal:
applications.linux.com/print.pl? … 28/2229232 [/quote]
Un chose est sûre, tu le connais bcp mieux que moi …:slightly_smiling:
Cette doc a l’air super intéressante, ca va peut-être éclairer ma lanterne, merci ! :bulb:

Ou encore, étant donné que je veux une install. dédiée au multimédia, j’aurai dû faire une install complète de GNOME, par exemple, là je serais pratiquement sûr d’avoir toutes mes librairies et autre démons de sons installés. Et ensuite seulement, virer progressivement le superflu …

Merci encore !


#6

Je ne sais pas: c’est vrai que le coeur est plus dur à monter, mais quitte à faire de l’optimisé, pourquoi pas une solution “from scratch” ?
lfs.icx.fr/lfs/news.html

la majorité des codecs aussi, me semble t il…
Mais c’est vrai que c’est pas plus con d’installer les binaires à la main proprement.
Il me vient à l’idée en effet que même en compilant avec make, tu peux peut etre installer toi même les éléments produits à la main aux endroits ou debian installe les siens: tu regardes ce que souhaites faire le ‘make install’ (avec “-n” pour voir sans faire), tu compare avec les lieux d’install des fichiers du paquet correspondant, et ensuite, tu fait tout à la main en respectant les repertoires debian. Ou bien tu reécris le makefile :laughing:

rien ne le dis pas, en effet :slightly_smiling: .
Mais à mon avis, comme je l’ai dit avant, il faut surtout eplucher le configure et le makefile du composant qui plante, pour ajuster les répertoires.

[quote=“Jabba”]Pourquoi j’avais choisi de maintenir ma solution en dehors du système Debian:

  1. Pour pouvoir upgrader mes libs et autres codecs EN DEHORS des apt-get upgrade Debian.
    Raison: souvent si on fait des maj. du système Debian, en testing, il y a des trucs qui ne fonctionnent plus. Le son en est un exemple tristement célèbre …:frowning:
    Et cette install, j’ai plutôt envie de l’installer, de la stabiliser de la placer sous la télé, de ne l’upgrader qu’en cas de besoin (nouveaux codecs). Je n’ai pas très envie de devoir résoudre un problème d’upgrade, le samedi soir, quand c’est l’heure de regarder le film … :slightly_smiling:[/quote]
    C’est ma spécialité: “bien sur que je peux regarder des DVD sous linux: regardes…” et devant un pote ebahi, je lance un vlc… ki plante. “atan, c’est juste que je ne regarde pas beaucoup de films, je règle ca tout de suite” … et me voila lancé dans quelques heures de config que j’avais estimé à 2 minutes…
    Ma douce hurle régulièrement quand elle veut faire un jeu java ou regarder un film sur Canal: je tripatouille tellement ma machine pour l’optimiser qu’elle n’est JAMAIS opérationnelle :slightly_smiling:

J’ai à coté de chez moi un petit assembleur qui fait des PC/BareBone avec facade bourrée de potards et de curseurs, fonctionnant en chaine quand la partie bécane est éteinte, avec télécommande et tout, configurés pile poil (linux si on veut).
C’est beau, et ses prix publics sont en général inferieurs à ceux que j’avais auprés de mes grossistes quand j’avais ma SSII.
Je bosse pas mal avec lui :slightly_smiling:

[quote=“Jabba”]Un copier-coller de /usr/local/*, suivi d’une recompilation générale me paraissait plus facile à faire qu’une re-configuration debian avec toutes les librairies exotiques requises par le soft Freevo/MPLayer.
L’idée étant de ne faire qu’une install Debian basique sur le nouveau PC et ensuite, copier-coller /usr/local puis recompiler pour “que ca colle” avec la nouvelle architecture…
l’erreur que je fais actuellement, c’est peut-être de mettre le système de son avec les packages debian et Mplayer compilé à l’ancienne mode …
Qu’en penses-tu ?[/quote]
A part les codecs, et le noyau, à mon avis, le reste ne mérite pas d’évoluer.
Dans cette optique, tu peux te permettre d’oublier le respect naturel dû à debian et faire d’abord qqchose ki marche pile poil blindé au niveau utilisation, et fournissant un accés en mise à jour au répertoire des codecs, et à /boot pour le modifs de noyaux.
tout le reste (y compris le player), c’est du bronze pour lequel mise à jour s’appelle reinstallation.

[quote=“Jabba”][quote]u veux un scoop : moi non plus Smile
mais en te répondant, j’ai trouvé ca, qui n’est pas mal:
applications.linux.com/print.pl? … 28/2229232 [/quote]
Un chose est sûre, tu le connais bcp mieux que moi …:slightly_smiling:
Cette doc a l’air super intéressante, ca va peut-être éclairer ma lanterne, merci ! :bulb: [/quote]
c’est peu utilisable, mais ca explique bien, et les réferences en bas de page sont bien pratiques.

Pourquoi virer ?
Si tu n’as pas l’intension de stocker quoi que ce soit sur l’espace libèré, pourquoi veux tu risquer de casser. Laisses tout tel quel, sale et tout: tu t’en fout.

de rien: tu debroussailles pour moi. :slightly_smiling:


#7

[quote]Je ne sais pas: c’est vrai que le coeur est plus dur à monter, mais quitte à faire de l’optimisé, pourquoi pas une solution “from scratch” ?
lfs.icx.fr/lfs/news.html [/quote]
Ouaip, ca fait longtemps que j’y pense mais j’ai jamais eu le courage :blush: de me lancer, et ca risque de prendre du temps jusqu’a ce que j’aie quelque chose d’utilisable … :cry:

[quote]Jabba a écrit:
Je ne pense pas pouvoir tout compiler à la méthode Debian, mais au moins Mplayer, là je sais que les sources sont prévues pour.

la majorité des codecs aussi, me semble t il… [/quote]
C’est juste, j’en avait loupé un bon paquet … ffmpeg et SDL par exemple sont dispos sous forme de paquets debian et il s’agit des plus gros morceaux.

Si je fait comme ça, j’ai peur de me retrouver au final, avec une horrible bidouille ingérable :cry:

[quote]J’ai à coté de chez moi un petit assembleur qui fait des PC/BareBone avec facade bourrée de potards et de curseurs, fonctionnant en chaine quand la partie bécane est éteinte, avec télécommande et tout, configurés pile poil (linux si on veut).
C’est beau, et ses prix publics sont en général inferieurs à ceux que j’avais auprés de mes grossistes quand j’avais ma SSII.
Je bosse pas mal avec lui [/quote]
Et en Gaule, ca vaut combien une solution dans ce genre ?

Ok, je te tiendrai au courant
:wink:


#8

[quote=“Jabba”][quote]Je ne sais pas: c’est vrai que le coeur est plus dur à monter, mais quitte à faire de l’optimisé, pourquoi pas une solution “from scratch” ?
lfs.icx.fr/lfs/news.html [/quote]
Ouaip, ca fait longtemps que j’y pense mais j’ai jamais eu le courage :blush: de me lancer, et ca risque de prendre du temps jusqu’a ce que j’aie quelque chose d’utilisable … :cry: [/quote]
J’ai essayé de me monter une LFS il y a deux ans, mais je me suis arrèté faute de temps :laughing:

[quote=“Jabba”][quote]Jabba a écrit:
Je ne pense pas pouvoir tout compiler à la méthode Debian, mais au moins Mplayer, là je sais que les sources sont prévues pour.
la majorité des codecs aussi, me semble t il… [/quote]
C’est juste, j’en avait loupé un bon paquet … ffmpeg et SDL par exemple sont dispos sous forme de paquets debian et il s’agit des plus gros morceaux.[/quote]
regardes le contenu du rep “jones” que je t’ai donné pour ton nVidia. Il y a pas mal de paquets multimedia.
sources:

deb http://debian.jones.dk sarge misc
deb-src http://debian.jones.dk sarge misc
deb http://debian.jones.dk woody misc
deb-src http://debian.jones.dk woody misc
deb http://debian.jones.dk sid misc
deb-src http://debian.jones.dk sid misc

As tu aussi regardé la distrib agnella/demudi comme source de paquets multimedia et de codecs ?
le site:
agnula.org/
c’est une distrib “debian based” orientée son.

#deb http://freesoftware.ircam.fr/mirrors/demudi sarge main local extra
#deb http://freesoftware.ircam.fr/mirrors/demudi testing main local extra
#deb http://freesoftware.ircam.fr/mirrors/demudi [sarge|testing|unstable] main local extra
deb http://apt.agnula.org/demudi testing main local extra
deb-src http://apt.agnula.org/demudi testing local
#deb http://apt.agnula.org/demudi stable main local extra
#deb-src http://apt.agnula.org/demudi stable local
deb http://apt.agnula.org/demudi unstable main local extra
deb-src http://apt.agnula.org/demudi unstable local

Si je fait comme ça, j’ai peur de me retrouver au final, avec une horrible bidouille ingérable :cry: [/quote]
justement, le but, c’est d’éviter que les “make install” dispersent les fichiers dans des repertoires qui ne correspondent pas aux standards debian: si tu laisse faire ce qui est prevu dans les makefiles pour le make install, ca va t’installer des libs ou des executables dans des repertoires parfois ignorés par debian.
Donc, si tu veux rester clean, tu compiles avec un simple make, et ensuite, tu installes toi même ce qui est produit là ou il faut.

[quote=“Jabba”][quote]J’ai à coté de chez moi un petit assembleur qui fait des PC/BareBone avec facade bourrée de potards et de curseurs, fonctionnant en chaine quand la partie bécane est éteinte, avec télécommande et tout, configurés pile poil (linux si on veut).
C’est beau, et ses prix publics sont en général inferieurs à ceux que j’avais auprés de mes grossistes quand j’avais ma SSII.
Je bosse pas mal avec lui [/quote]
Et en Gaule, ca vaut combien une solution dans ce genre ?[/quote]
Ca dépend de quel barebone tu veux et de ce que tu mets dedans :slightly_smiling: … Le but n’etait pas de te vendre ou de te faire acheter, mais si ca t’interresse, pour info, c’est un MegaPC MSI dont je parle:
chez mon pote, ses tarifs ne sont pas à jour, et il n’a pas mis la fiche du 865: generation-net.com/catalogue … ef=3901232
sur kelkoo, par contre:
fr.kelkoo.com/ctl/do/sort?pid=10 … Totalprice
ca tourne aux alentours de 350 €


#9

Moi aussi, mais c’est toujours le même problème… le temps. Maintenant j’essaye de me limiter à 1 seule distrib, au maximum 2. J’en ai un peu marre de me disperser. Mais je vais certainement re-tenter le LFS un de ces jours …

[quote]regardes le contenu du rep “jones” que je t’ai donné pour ton nVidia. Il y a pas mal de paquets multimedia.
sources:[/quote]
YES, génial, que des bons liens :astonished:

D’aillleurs, si j’avais un peu ouvert les yeux, de mon côté, j’aurais tout de suite trouvé la plupart des paquets Debian nécéssaires… sur le site Freevo ! :imp:
http://freevo.sourceforge.net/cgi-bin/doc/FreevoAptDebian
C’est un comble, je cherche à me monter une Freevo Box et je ne suis même pas foutu d’aller voir à la source … :blush:

Entre tes adresses et le site Freevo, je pense pouvoir faire une installation à 90 voire 95% pure Debian ! :stuck_out_tongue:

[quote]As tu aussi regardé la distrib agnella/demudi comme source de paquets multimedia et de codecs ?
le site:
agnula.org/
c’est une distrib “debian based” orientée son. [/quote]
Je viens de visiter leur site et je dois dire que ca me paraît un peu déroutant, en fait pas très clair … Cette fois-ci c’est décidé, je crois que je vais rester Debian “pur sucre”… :wink:

[quote]Ca dépend de quel barebone tu veux et de ce que tu mets dedans Smile … Le but n’etait pas de te vendre ou de te faire acheter, mais si ca t’interresse, pour info, c’est un MegaPC MSI dont je parle:
chez mon pote, ses tarifs ne sont pas à jour, et il n’a pas mis la fiche du 865:[/quote]
Ton copain, il habite tout près de la Suisse ? :unamused:

A oui, au fait, grande nouvelle :smiley: : J’arrive maintenant à écouter des sons et des vidéos avec mplayer, ca n’était pas un problème alsa mais il fallait seulement activer l’émulation OSS à la compilation du kernel, uniquement l’émulation, pas les modules OSS:

<M> Advanced Linux Sound Architecture
	<M> Sequencer support                                                              │ │
	<M> Sequencer dummy client                                                       │ │
	<M> OSS Mixer API                                                                  │ │
	<M> OSS PCM (digital audio) API                                                    │ │
	[*] OSS Sequencer API    

Et étant donné que j’ai le support Frame Buffer activé dans le kernel, je peux aussi regarder des vidéos sans démarrer X … Je me demande si je vais pas carrément virer Xwindow…

Il me reste maintenant à trouver comment afficher autre chose qu’un écran gris sur ma télé … :cry:
Mais restons optimiste, ca avance …

Allez, prochaine étape, un cht’it fdisk pour repartir sur des bases saines :exclamation:


#10

voila. moi, je suis arrèté sur debian et j’y reste, mais une tite LFS, pour réviser en grand, je ferais certainement un nouveau détour.

[quote=“Jabba”]…C’est un comble, je cherche à me monter une Freevo Box et je ne suis même pas foutu d’aller voir à la source … :blush:[/quote]:lol:

Ben non, il est à Caen, en normandie, comme moi :frowning:
Mais vu que ca tourne aux alentours de 350 €, c’est peut etre pas trop grave de la payer légèrement plus cher, mais par chez toi, non ?

[quote=“Jabba”]
Et étant donné que j’ai le support Frame Buffer activé dans le kernel, je peux aussi regarder des vidéos sans démarrer X … Je me demande si je vais pas carrément virer Xwindow…
Il me reste maintenant à trouver comment afficher autre chose qu’un écran gris sur ma télé … :cry:[/quote]
ben en fb en console, je ne sais pas si on peut faire du dual head.
J’imagine que c’est faisable, mais ca ne me parait pas standard.
Enfin je dis ca, mais je ne sais pas si tu veux faire du dual head, si c’est ca ton pb.
Si tu as besoin sinon, mon XF86config-4 contient toutes les options du server nVidia avec les commentaires pour chacune (repris dans les readme nVidia, mais je ne sais plus ou).


#11

[quote]Ben non, il est à Caen, en normandie, comme moi Sad
Mais vu que ca tourne aux alentours de 350 €, c’est peut etre pas trop grave de la payer légèrement plus cher, mais par chez toi, non ? [/quote]
En fait je suis en train de regarder près de chez moi et je vois que ca n’est pas beaucoup plus cher qu’en france, donc…

[quote]ben en fb en console, je ne sais pas si on peut faire du dual head.
J’imagine que c’est faisable, mais ca ne me parait pas standard. [/quote]
D’après la doc, on doit pouvoir installer une Freevo Box avec sortie sur la télé sans avoir de serveur graphique, on verra …

Maaaaaais très volontiers… :slightly_smiling: [/code]


#12
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86
Section "Files"
	FontPath	"unix/:7110"			# local font server (xfs-xtt)
	FontPath	"unix/:7100"			# local font server (xfs)
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
#	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
#	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection
Section "Module"
#	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
#	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
	Load	"xtt"
EndSection
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"logidak"
	Option		"XkbLayout"	"fr"
EndSection
Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/gpmdata"
	Option		"Protocol"		"IntelliMouse"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "Device"
	Identifier	"NVIDIA Corporation NV17 [GeForce4 MX 440]"
	Driver		"nvidia"
	Option		"DPMS"			"false"

#	Option		"NvAGP"			"3"	#0 desactive, 1 - NVIDIA , 2 - AGPART, 3 - 2 si possible sinon 1
	Option		"NoLogo"		"true"
#	Option		"RenderAccel"		"true" # experimental, default: "false"
#	Option		"NoRenderExtension"	"true" # pour le 8 bits, default "false"
#	Option		"UBB"			"false" # gpu quadro,  default "true"
#	Option		"WindowFlip"		"true" # si UBB, ameliore la 3D, default "false"
#	Option		"PageFlip"		"false" # default "true"
#	Option		"DigitalVibrance"	"0" # defaut 0
#	Option		"Dac8Bit"		"true" # pour quadro, default "false"
#	Option		"Overlay"		"true" # pour quadro, restreint, default "false"
#	Option		"CIOverlay"		"true" # pour quadro, restreint, default "false"
#	Option		"TransparentIndex"	"0" # depend de Overlay, default "0"
#	Option		"OverlayDefaultVisual"	"true" # idem default "false"
#	Option		"SWCursor"		"true" # default "false"
#	Option		"HWCursor"		"false" # default "true"
#	Option		"CursorShadow"		"true" # gf2 et plus, default "false"
#	Option		"CursorShadowAlpha"	"64" # default "64" 
#	Option		"CursorShadowXOffset"	"4" # default "4"
#	Option		"CursorShadowYOffset"	"2" # default "2"
#	Option		"NoBandWidthTest"	"true" # default "false"
#	Option		"IgnoreDisplayDevices"	"" # TV|CRT|DFP, si X est lent au d	marrage
#	Option		"MultisampleCompatibility" "false"


#	Option		"UseEdidFreqs"		"true" # pour demander les plages de sync au moniteur
#	Option		"IgnoreEDID"		"true" # default "false"
#	Option		"NoDDC"			"true" # Synonyme de "IgnoreEDID"
#	Option		"FlatPanelProperties"	"Scaling = centered, Dithering = enabled" # Scaling =[default,native,scaled,center,aspect-scaled], dither=[default,enabled,disabled]
#	Option		"UseInt10Module"	"true" # pour utiliser XFree pour initialiser les ecrans, default "false"
#	Option		"UseClipIDs"		"true" # necessite quadro+UBB

	Option		"TwinView"		"true" # activation du twinview, default false
	Option		"TwinViewOrientation"		"RightOf" # ["RightOf"|"LeftOf"|"Above"|"Below"|"Clone"] default NULL
	Option		"ConnectedMonitor"		"CRT,TV" # CRT: cathodique, DFP: Plat sur DVI, TV: tv
	Option		"SecondMonitorHorizSync"	"30-50" 
	Option		"SecondMonitorVertRefresh"	"60"
	Option		"MetaModes"			"1280x1024,800x600;1280x1024;320x200,NULL"
#	Option		"MetaModes"			"1024x768,1024x768;800x600,800x600;640x480,640x480;320x200,NULL"
#	Option		"NoTwinViewXineramaInfo"	"true" # par default: false
	Option		"TVStandard"			"PAL-N"
#	Option		"TVOutFormat"			"PAL-N"
	Option		"TVOverScan"			"0.8" # Valeur decimale comprise entre 0.0 et 1.0, default 0
#	Option		"Stereo"			"0" # stereovision pour quadro



EndSection
Section "Monitor"
 Identifier "Generic Monitor"
 HorizSync 30-70
 VertRefresh 50-160
EndSection
Section "Monitor"
 Identifier "IIYAMA A901HT [Vision Master Pro 450]"
 HorizSync 27.0-115.0 
 VertRefresh 50.0-160.0 

# Sony Vaio C1(X,XS,VE,VN)? 
# 1024x480 @ 85.6 Hz, 48 kHz hsync 
#ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync 
     
 # TV fullscreen mode or DVD fullscreen output. 
 # 768x576 @ 79 Hz, 50 kHz hsync 
 #ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630 

 # 768x576 @ 100 Hz, 61.6 kHz hsync 
 ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616 

EndSection
Section "Screen"
 Identifier "Default Screen"
 Device  "NVIDIA Corporation NV17 [GeForce4 MX 440]"
 Monitor  "IIYAMA A901HT [Vision Master Pro 450]"
 DefaultDepth 24
 SubSection "Display"
  Depth  1
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  4
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  8
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  15
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  16
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  24
  Modes  "1280x1024" "1024x768" "800x600" "640x480"
#  Modes  "1024x768" "800x600" "640x480"
 EndSubSection
EndSection
Section "ServerLayout"
 Identifier "Default Layout"
 Screen  "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
EndSection
Section "DRI"
 Mode 0666
EndSection

#13

Merci MattOTop !

M’en vais “prestement” étudier tout ça :slightly_smiling: