Configuration Marble Mouse sur Debian 9

Tags: #<Tag:0x00007f3b7b5c6670>

J’ai de la difficulté à configurer ma Marble Mouse sous Debian 9. Normalement, je suis cette recette (https://help.ubuntu.com/community/Logitech_Marblemouse_USB). Mais rien n’y fait. C’est comme si mes fichiers .conf étaient complètement ignorés. J’ai essayé à la fois dans /etc/X11/xorg.conf.d et /usr/share/X11/xorg.conf.d mais rien n’y fait.

Auriez-vous quelque chose à suggérer? :thinking:

Normalement, c’est /usr/share/X11/xorg.conf.d, pas /etc/X11/xorg.conf.d
Peux tu dire quel nom tu as donné au fichier de config ainsi que son contenu ?
Peux tu aussi, aprés redémarrage, nous fournir le début de ton log xorg (head -40 /var/log/Xorg.0.log)

J’ai appliqué l’exemple suivant: https://www.hutsky.cz/blog/2017/02/scroll-emulation-with-trackman-marble-in-debian-9/.

Résultat de head -40 /var/log/Xorg.0.log après avoir fait la modification et redémarré:

[    37.453] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    37.453] X Protocol Version 11, Revision 0
[    37.453] Build Operating System: Linux 4.9.0-4-amd64 x86_64 Debian
[    37.453] Current Operating System: Linux MBP-de-Pierre 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64
[    37.453] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-5-amd64 root=UUID=c3f56f25-2f03-40c1-bcb5-abbb60ed9393 ro single
[    37.453] Build Date: 16 October 2017  08:19:45AM
[    37.453] xorg-server 2:1.19.2-1+deb9u2 (https://www.debian.org/support) 
[    37.453] Current version of pixman: 0.34.0
[    37.453]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    37.453] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    37.454] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 13 17:45:33 2018
[    37.454] (II) Loader magic: 0x564c6f5b6e00
[    37.454] (II) Module ABI versions:
[    37.454]    X.Org ANSI C Emulation: 0.4
[    37.454]    X.Org Video Driver: 23.0
[    37.454]    X.Org XInput driver : 24.1
[    37.454]    X.Org Server Extension : 10.0
[    37.454] (--) using VT number 2

[    37.454] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    37.455] (II) xfree86: Adding drm device (/dev/dri/card0)                                                                                                                                
[    37.468] (--) PCI:*(0:0:2:0) 8086:0d26:106b:0147 rev 8, Mem @ 0xa0000000/4194304, 0x90000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
[    37.469] List of video drivers:
[    37.469]    amdgpu
[    37.469]    ati
[    37.469]    intel
[    37.469]    nouveau
[    37.469]    qxl
[    37.469]    radeon
[    37.469]    vmware
[    37.469]    modesetting
[    37.469]    fbdev
[    37.469]    vesa
[    37.469] (II) LoadModule: "amdgpu"
[    37.470] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so

Pour l’aide, c’est bien gentil. :smile:

Bon, alors là, il y a un premier truc que je ne comprends pas.

Chez moi, j’ai:

[    14.174] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 12 15:13:20 2018
[    14.177] (==) Using config file: "/etc/X11/xorg.conf"
[    14.177] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
(...)
[    14.184] (II) Loader magic: 0x56464c59ce00

Alors que chez toi, c’est:

[    37.454] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 13 17:45:33 2018
[    37.454] (II) Loader magic: 0x564c6f5b6e00

Pourtant, c’est la même version de Xorg, que j’ai.

Ensuite:

Ce que je voulais vérifier, c’est si tu avais bien respecté un nom de fichier au format ##-XXXXX.conf (avec un ## de priorité, et un .conf à la fin).

Mais là, j’ai l’impression que ton serveur Xorg ne va même pas chercher dans /usr/share/X11/xorg.conf.d du tout, et peu importe le nom que tu as donné à ton fichier de conf.

Essayes un truc, crée un fichier /etc/X11/xorg.conf vide, et aprés redémarrage du serveur X, regarde s’il le lit dans le log.

Petite question sinon: tu démarres avec startx, où bien tu as un login graphique ?

Le chemin complet pour le fichier de config est /usr/share/X11/xorg.conf.d/50-trackball.conf.

Voici ce que je trouve dans le log pour xorg.conf:

[  1321.755] (++) Using config file: "/root/xorg.conf.new"
[  1321.755] (==) Using system config directory "/usr/share/X11/xorg.conf.d"

J’ai fait un Xorg -configure mais ça ne change rien.

Quand Debian démarre, il affiche quelque chose en erreur du genre Failed to configure network interface (je sais pas, ça passe très vite…). Peut-être que le problème est là. Après, j’ai mon écran de login qui apparaît. Je n’emploie pas startx pour lancer ma session.

OK, j’ai arrangé le problème avec les interfaces réseaux. Il cherchait eth0 mais ça n’existe pas car j’ai seulement une connexion wifi.

Mais ça n’a rien changé pour la configuration de la souris qui ne défile toujours pas.

J’ai trouvé le problème.

[  1322.041] (II) LoadModule: "evdev"
[  1322.041] (WW) Warning, couldn't open module evdev
[  1322.041] (II) UnloadModule: "evdev"
[  1322.041] (II) Unloading evdev

Donc, j’ai un problème avec ce driver. Là, je sais pas ce que je peux faire.

Vérifie que tu as bien le paquet xserver-xorg-input-evdev
Si ce n’est pas le cas, installe le ?

Oui! Il manquait ce paquet pour que ça fonctionne! :ok_hand: :joy: Merci.

Donc voici ma solution finale. Pour un gaucher, avec le défilement vertical et horizontal avec la boule quand on tient le petit bouton droit enfoncé, navigation avant et arrière dans le navigateur web avec les petits boutons:

cat /usr/share/X11/xorg.conf.d/50-marble.conf 

Section "InputClass"
	Identifier "Marble Mouse"
	Driver "evdev"
	MatchProduct "Logitech USB Trackball"
	MatchDevicePath "/dev/input/event*"
	MatchIsPointer "yes"
	Option "ButtonMapping" "3 2 1 4 5 6 7 8 9"
	Option "EmulateWheel" "true"
	Option "EmulateWheelButton" "9"
	Option "ZAxisMapping" "4 5"
	Option "XAxisMapping" "6 7"
	Option "Emulate3Buttons" "false"
EndSection

Pour un droitier ça devrait être:

cat /usr/share/X11/xorg.conf.d/50-marble.conf 

    Section "InputClass"
    	Identifier "Marble Mouse"
    	Driver "evdev"
    	MatchProduct "Logitech USB Trackball"
    	MatchDevicePath "/dev/input/event*"
    	MatchIsPointer "yes"
    	Option "ButtonMapping" "1 2 3 4 5 6 7 8 9"
    	Option "EmulateWheel" "true"
    	Option "EmulateWheelButton" "8"
    	Option "ZAxisMapping" "4 5"
    	Option "XAxisMapping" "6 7"
    	Option "Emulate3Buttons" "false"
    EndSection

On peut mettre Option "Emulate3Buttons" "yes" à la place de false. Le troisième bouton est émulé en cliquant les deux gros boutons en même temps.

Good !
C’était pas évident… :smiley: