Configurer Steam avec le pilote propriétaire Nvidia [résolu]

Tags: #<Tag:0x00007f8a413b38c8> #<Tag:0x00007f8a413b36c0>

Bonjour,

J’ai un soucis pour exécuter Steam avec le pilote propriétaire Nvidia.
Dans ce lien, ils expliquent comment faire, mais je ne comprend pas comment taper les commandes, pouvez-vous m’expliquer s’il vous plait ?

https://wiki.debian-fr.xyz/NVidia_Optimus_Bumblebee#Gestion_de_Steam

Merci

Pour exécuter les commandes, il faut que tu passes en root.
Tu sais lancer une fenêtre console ?
Normalement, tu dois avoir la possibilité de lancer directement une console root, sinon, console normale, et là tu tapes su pour passer root.
Dans les deux cas, tu auras besoin du mot de passe rot.

Si tu as oublié et que tu utilises en général sudo, alors tu lances une console normale, puis sudo su, et la, il te demandera de taper ton propre mot de passe.

A la fin, au lieu de se terminer par un $, ta ligne de commande se terminera par un #, ça voudra dire que tu es en ligne de commande root, et que tu peux commencer à taper une à une les commandes que t’indique le tuto.

Oui mais cette commande > $OPTIMUS_PREFIX %command%
Il faut la taper tel quel ?

Oui, il semble qu’il faut taper les commandes tel quel, je m’embrouillais pour rien.
Bref, merci quand même.

Explication:
le tuto te fais définir la variable OPTIMUS_PREFIX pour qu’elle contienne la valeur "primusrun"
ensuite, dans steam, une fois configuré ton truc comme ils disent, au lieu de lancer la commande %command% comme c’est configuré par défaut, il va lancer:
primusrun %command%
donc ça va passer par primusrun qui encapsule le lancement de la commande %command%

Et %command% ça doit être tapé tel quel ?

Ca je ne sais pas.
C’est peut être à tester littéralement et steam remplace par le chemin vers le jeu ou peut être que c’est un truc genre /chemin/vers/le/jeu.exe qu’il faut mettre à la place.
Je ne connais pas steam.

Ba oué c’est bien ça le problème, personne ne l’explique…

Je suis pour que $OPTIMUS_PREFIX %command% soit tapé tel quel.

Exécutez Steam, allez dans votre librairie de jeux, sélectionnez le jeu en question, puis faites un clic droit dessus, et choisissez le menu “Properties”. Ensuite, cliquez sur le bouton [SET LAUNCH OPTIONS] et spécifiez dans le champ l’information qui suit : $OPTIMUS_PREFIX %command%

Optimus and Steam for Linux

How can I force a Steam for Linux game to use my NVidia card instead of the integrated video card?
https://support.steampowered.com/kb_article.php?ref=6316-GJKC-7437&l=french

Oui tu as raison r2mi, je crois qu’il faut taper tel quel les commandes.