Connexion internet avec la Debian


#1

Bonjour,
Je veux etablir une connexion internet dsl avec la debian 3.1(Sarge), installée à partir d’un dvd.Quand je fais, en mode console:

j’obtiens:
eth0 bla …bla

lo bla…

…bla…

Remarque: le ppp0, n’y est pas.

Le fichier /etc/resolv.conf, contient:
nameserver (1ère adresse ip du serveur)
nameserver (2ème adresse ip du serveur)

J’installe le paquet pppoe:

l’installation se fait sans problème.
Quand je fais:

google.fr unknowen host.

Comment faire dans ce cas pour avoir le net?

P.S.Pour la connexion, j’utilise un modem ethernet .
si vous voulez:
Modem:
connexion adsl ----> eth0: (Realtek|RTL-8139)


#2

Bonjour,
as-tu fais #pppoeconf


#3

Salut :wink:

Comme te dit yo4, t’as dû omettre de lancer pppoeconf,
ce script te posera quelques questions et notamment ton identifiant et ton mot de passe de ta connexion, après ça tu devrais avoir internet :slightly_smiling: .


#4

Oui, j’ai oublié, javais fait:

et introduit, soigneusement, touts les paramètres demandés, cependant, malgré ça, quand je veux aller sur le net, en faisant:

#ping google.fr
unknown host

ou en utilisant, Mozilla —> impossible de se connecter à google.fr

Alors, comment on fait?


#5

et ping 213.228.0.42 (free) ?


#6

Ca vient peut-être d’une mauvaise configuration du réseau.


#7

Bonjour,

ghost333 a dit:

Alors, comment dois-je faire pour configurer mon réseau pour acceder au net, …je ne suis qu’un débutant.[/quote]


#8

peut-être en retentant un pppoeconf, et en reparametrant.
edit: tu renseignes bien ton login donné par ton FAI, et le mot de passe connexion donné par celui-ci? Désolé si ma question est un peu basique, je veux juste t’aider, :wink: .


#9

Juste pour la question de Anti-T, j’ai fait un :

et j’obtiens, alors:
un défilement de messages…

[code]From 10.0.0.138 icmp_seq = 57 Destination Host unreachable

—213.228.0.42 ping statistics—
75 packets transmitted, 0 received, +75 errors, 100% packets loss, time 73988ms.[/code]

J’ai consulté le fichier /etc/resolv.conf et j’ai constaté qu’il contient que ça:
lan

En fait, j’ai oublié de vous dire que j’ai déjà une Mandriva 2006, installée et je m’y réfère tout le temps parce qu’ elle marche trés bien: elle reconnait, facilement mon matériel et le passage au net se passe sans problème avec elle…etc…et, j’ai consulté le /etc/resolv.conf de la Mandriva 2006, et j’ai trouvé qu’il contient les lignes suivantes:
#ppp temp entry
nameserver (1ere adresse ip du server)#ppp temp entry
nameserver (2eme adresse ip du server)#ppp temp entry

Ma question est:
est-ce que c’est possible de copier les valeures des ip nameservers (figurants sur le /etc/resolv.conf de la Mandriva)sur le /etc/resolv.conf de la debian, sachant que la configuration du modem de la Mandriva 2006 a été fait en pppoe alors que celui de la debian est en dhcp?


#10

bon, tu confonds plusieurs choses: la résolution des noms, et le routage des paquets.
Ton resolv.conf, il faudra t’y interresser si la resolution par nom ne fonctionne toujours pas quand tu auras règlé le problême du ping sur l’adresse 213.228.0.42
en attendant, ce serait pas mal que tu donnes le contenu de /etc/network/interfaces
Tu n’as pas l’air super technique, donc ca peut te gonfler, mais tu peux essayer de comprendre mieux ta connection ppp (oe) en lisant ça, et les pages autour:
pptpclient.sourceforge.net/howto … re_by_hand
Par ailleurs, tu peux debuguer ta connection en lancant :
pon provider debug dump logfd 2 nodetach
(tiré de pptpclient.sourceforge.net/howto … html#debug) en changeant peut être provider par dsl-provider (ça dépend de comment s’appelle ta connection, à retrouver dans /etc/ppp/peers)

sinon, pour info, je ne sais pas pourquoi, mais je n’ai jamais réussi ma config avec pppoeconf (je la fais à la main).
donc voilà ce que j’ai pour mon “peer” chez moi:

# Minimalistic default options file for DSL/PPPoE connections pty "pppoe -I eth1 -T 80 -m 1412" noipdefault defaultroute replacedefaultroute hide-password #lcp-echo-interval 30 #lcp-echo-failure 4 noauth persist #mtu 1492 usepeerdns #plugin rp-pppoe.so eth1 user "fti/ZZZZZZZ@fti"
ou tu remarquera que j’ai commenté l’appel à rp-pppoe, et que ma carte réseau est sur eth1 (chez toi, sans doutes eth0).
et dans /etc/network/interfaces:

auto dsl-provider iface dsl-provider inet ppp provider dsl-provider pre-up /sbin/ifconfig eth1 up

PS: ta carte réseau ne doit surtout pas être déclarée dans ton /etc/network/interfaces, c’est pppoe qui la gère avec la ligne pre-up.


#11

Voici le /etc/network/interfaces :

[quote]# This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

auto eth0
iface eth0 inet dhcp [/quote]


#12

T’es en DHCP, il faut pas se mettre en réseau static pour une connexion par modem ethernet?
Enfin je pose une réserve, je connais pas trop le fonctionnement des réseaux :blush: :confused: .
Bon courage :slightly_smiling: .


#13

rarement tu dois configurer en statique.
de deux choses l’une:

premier cas (ancien): le modemfonctionne en routeur IP (!) à savoir qu’il fonctionne comme un dispositif réseau IP, auquel cas il dispose d’une adresse interne (typiquement 10.0.0.138).
Dans ce cas, il peut soit être configuré pour attribuer les adresses IP lui même (le client est alors en automatique dhcp), soit il faut effectivement passer au client une adresse fixe (genre 10.0.0.100), les dns, et la route par défaut sur 10.0.0.138 par l’ethX du client, mais c’est devenu super rare.
Dans ce cas, le modem se retrouve ENTRE le LAN (avec eventuellement un hub) et l’internet: c’est lui qui recoit en frontal les paquets.

Deuxiême cas (qui semble nous interresser), le modem devient un dispositif externe de son client (cable direct sur la carte réseau) auquel cas la transmission ne se fait plus en IP entre le client et le modem (même si on peut parfois continuer à utuiliser l’IP, mais c’est aléatoire), mais, directement par le cable en point à point, sans vrai protocole réseau, en pppoe. La carte ethX n’a alors aucune adresse, elle n’est pas configurée dans /etc/network/interfaces, et pppoe qui crée une interface pppX qui est l’accés à Internet du client.
Dans ce cas, le client est alors en frontal, et tout ce qui arrive sur le modem arrive en fait jusqu’à la machine cliente, car c’est elle qui est branchée directement sur le net (le modem n’existe plus en tant qu’élément du réseau).

cheikhbouchihda: comment était configurée ta mandriva ?
As tu essayé de faire les modifs dans tes fichiers pour mettre les fichiers interface et provider comme je t’ai montré qu’ils étaient chez moi ?


#14

Bonjour MattOTop et tout le monde,
La Mandriva 2006 que j’ai installé, a été configurée, automatiquement, en pppoe et la connexion au net est trés parfaite, comme sur Windows XP, jusqu’à dire…est-ce ce n’est pas le linux qui va concurencer Windows?..et pour la Débian (et les autres linux, comme la Fedora), ont des configuration vraiment affolantes, pour acceder au net??..je crois et pour ma santé mentale, je vais me contenter de la Mandriva 2006, pour maintenant.
@+


#15

C’est toi qui vois. Mais comme tu peux le constater, nous sommes en pleine forme nous aussi de ce côté-là :wink:


#16

Bonjour,
J’ai résolu le problème de la connexion internet de la debian, en procédant ainsi:
#vi /etc/network/interfaces

et j’ai commanté tout ce qui fait réference à la carte réseau et puisque l’interface est eth0, et la configuration est en pppoe, alors j’ai commenté les lignes suivantes:

auto eth0
iface eth0 inet dhcp

et ça marche, j’ai envoyé ce message en “utilisant” la débian.Merci pour l’aide et à bientôt.