Connexion partagée USB sans problème mais clé WI-FI tp-link impossible [Résolu]

Tags: #<Tag:0x00007f1ee5da3620>

Bonjour,
toute nouvelle sous Debian après trois ans de Ubuntu et un peu lassée, je suis bien coincée, sachant que cette clé fonctionnait sous Ubuntu et fonctionne sous Win10, ça fait 24 heures et trois ré-installations que j’en ai conclu que je n’y arriverais pas seule.
Mon Pc est un vieux Lenovo A55 et, avant de faire une installation en dur sur ce PC, j’ai installé Debian sur cléUSB 32Go.
Je précise que ma carte ethernet est reconnue mais à un problème de connexion filaire et donc, après avoir essayer l’ISO de 650Mo pour une installation en réseau échouée, un autre installation minimale, je suis maintenant sur le Debian de l’ISO live-10.2.0 amd64-gnome. et c’est lors du test en live que j’ai testé la connexion partagée USB avec ma tablette et là, fonctionnant correctement, j’ai fais cette dernière installation complète. mais toujours sans solutions pour cette clé soit disant compatible Linux et qui est ici:
https://www.tp-link.com/fr/search/?q=TL-WN725N&t=product&s=MODEL
et j’ai téléchargé le pilote ici:


qui a un gros soucis vu que c’est le firmware rtlwifi/rtl8188eufw.bin avec ce terminal:

root@lou:/home/lou/Téléchargements/Driver# sudo make
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.19.0-6-amd64/build M=/home/lou/Téléchargements/Driver  modules
make[1] : on entre dans le répertoire « /usr/src/linux-headers-4.19.0-6-amd64 »
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
  CC [M]  /home/lou/Téléchargements/Driver/core/rtw_cmd.o
In file included from /home/lou/Téléchargements/Driver/include/osdep_service.h:41,
                 from /home/lou/Téléchargements/Driver/include/drv_types.h:32,
                 from /home/lou/Téléchargements/Driver/core/rtw_cmd.c:22:
/home/lou/Téléchargements/Driver/include/osdep_service_linux.h: In function ‘_init_timer’:
/home/lou/Téléchargements/Driver/include/osdep_service_linux.h:261:8: error: ‘_timer’ {aka ‘struct timer_list’} has no member named ‘data’
  ptimer->data = (unsigned long)cntx;
        ^~
/home/lou/Téléchargements/Driver/include/osdep_service_linux.h:262:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration]
  init_timer(ptimer);
  ^~~~~~~~~~
  _init_timer
cc1: some warnings being treated as errors
make[4]: *** [/usr/src/linux-headers-4.19.0-6-common/scripts/Makefile.build:309: /home/lou/Téléchargements/Driver/core/rtw_cmd.o] Error 1
make[3]: *** [/usr/src/linux-headers-4.19.0-6-common/Makefile:1534: _module_/home/lou/Téléchargements/Driver] Error 2
make[2]: *** [Makefile:146: sub-make] Error 2
make[1]: *** [Makefile:8: all] Error 2
make[1] : on quitte le répertoire « /usr/src/linux-headers-4.19.0-6-amd64 »
make: *** [Makefile:1367: modules] Error 2

Après de nombreuse recherche j’ai fini par trouver ce correctif mais voilà, c’est soit par git soit par wget que je n’arrive pas à installer vu qu’on m’annonce qu’ils ne sont plus dans les dépots et je ne sais plus quoi faire sauf démander votre aide.

Non, je crois que j’ai le même, et je ne me souviens pas avoir eu besoin de compiler quoi que ce soit (enfin rien d’importé hors debian).
Edit:
Oublie, moi aussi ça a la même tête et c’est du tp-link, mais pour le bluetooth.
Mais je parie que tu n’as pas besoin de rien d’autre que d’installer le paquet firmware-realtek (oui oui realtek, je sais ce que je dis) et peut être de redémarrer et ça passera.

Pour l’instant ça fonctionne mais j’ai peur que la batterie de ma tablette n’apprécie pas le branchement permanent…
Là je suis sur l’installation de mon pilote graphique, c’est cool

Alors là je ne comprend plus ce que tu dis…
[edit: ah ok, j’ai compris, tu es en usb sur ta tablette, OK]

Et bien, ma seule connexion est celle de la connexion partagée USB de ma tablette et en mème temps elle charge alors qu’elle est déjà à fond de batterie.

Bonsoir et excusez mon absence impromptue et donc, sans raison hier soir plus moyen de booter et en live avec le fichier debian-live-10.2.0-amd64-gnome.iso plus moyen de faire quoi que ce soit vu que mème fdisk ne fonctionnait plus malgrés la vérification de cet iso et donc j’ai refais une quatrième installation avec firmware-10.2.0-amd64-netinst.iso espérant bêtement que tout serait réglé…
Donc comme indiqué dans le post de mattotop j’ai téléchargé le paquet firmware-realtek all deb et impossible de l’installer:

root@Lou:/home/loux/Téléchargements# dpkg -i firmware-realtek_20161130-5~deb8u1_all.deb
dpkg: avertissement: « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg: avertissement: « start-stop-daemon » introuvable dans la variable PATH ou non exécutable
dpkg: erreur: 2 programmes attendus non trouvés dans la variable PATH ou non exécutables
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin 

Surprise je vérifie et:

loux@Lou:~$ update-alternatives --config x-terminal-emulator
Il existe 3 choix pour l'alternative x-terminal-emulator (qui fournit /usr/bin/x-terminal-emulator).

  Sélection   Chemin                           Priorité  État
------------------------------------------------------------
* 0            /usr/bin/gnome-terminal.wrapper   40        mode automatique
  1            /usr/bin/gnome-terminal.wrapper   40        mode manuel
  2            /usr/bin/konsole                  40        mode manuel
  3            /usr/bin/mate-terminal.wrapper    30        mode manuel
Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :

Où j’ai déconné???

Ca y est! le plus bête c’est qu’en fait je suis passé par apt-get install, comme pour Ubuntu!

Et tu avais fait une deuxième erreur en passant root avec su, alors qu’il faut passer root avec su - (sinon, ton PATH n’est pas à jour et il ne trouve pas les commandes).

Zut… c’est vraiment stupide !! Merci