Créer un dossier réseau connecté à ma freebox en CLI

Bonjour tout le monde !

Je suis nouveau dans le monde de linux et j’essaie d’avancer pas à pas. Je m’excuse d’avance si je peux ne pas être complétement claire. Mais je vais faire au mieux.
Alors voilà j’ai une Freebox delta avec le protocol SMBv2 activé sur la freebox et un accès authentifié.
J’aimerais pouvoir aller lire les disques dure de ma freebox serveur depuis ma VM debian(Bullseye) j’ai 4 disques avec cette écriture:
Disque 1 /Disque 2 /Disque 3 / Disque 4
J’ai l’impression que quoi que je face, il n’arrive pas à reconnaitre le chemin ou les commandes. Je tourne en rond.
Cifs-utils et installé smb aussi (En théorie) les paquets sont à jours je n’ai aucun retour d’erreur…
J’ai également tenté les version smbv1 et forçant le smbv1 dans le smb.conf section global…
rebasculé en smbv2 mais rien n’y fait.
Quelqu’un pourrait m’aider à bien comprendre mon erreur ?
Je vous remercie d’avance ! :grinning_face_with_smiling_eyes:

smbstatus

Samba version 4.13.5-Debian
PID     Username     Group        Machine                                   Protocol Version  Encryption           Signing
----------------------------------------------------------------------------------------------------------------------------------------

Service      pid     Machine       Connected at                     Encryption   Signing
---------------------------------------------------------------------------------------------

No locked files
cat /etc//*release
ID="generic"
VERSION="20210603-657"
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

mon fichier fstab:

//Freebox_Server/Freebox /media/freebox cifs _netdev,rw,users,credentials=/home/freebox/.smbcredentials,iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0 0 0

retour de la commande mount - a :

mount -a
mount error: could not resolve address for Freebox_Server: Unknown error

retour de la commande smb://192.168.0.254 ou smb://Freebox_Server ou n’importe qu’elle autre commande de smb:// :

smb://192.168.0.254
-bash: smb://192.168.0.254: No such file or directory

Bonjour,

Je doute que le nom Freebox_Server soir reconnu par ta Debian. Essaie plutôt avec l’adresse IP locale ou le nom freebox-server.local.

Pour tester la connectivité et les partages :

smbclient -L //192.168.0.254 -U nom_utilisateur_freebox

Pour tester le montage :

sudo mount -t cifs //192.168.0.254/nom_du_partage /mnt -o rw,uid=1000,gid=1000,username=nom_utilisateur,password=mot_de_passe

Bonjour @Bruno1 !

Merci beaucoup pour ta réactivé ! je te fais le retour des commandes que tu me demandes.
Quand tu dis "nom_du_partage " j’aimerais que se soit toute la freebox avec les 4 disques accessibles. Peut-être que mon erreur est la. Puis quand je test avec le nom du disque je met l’espace entre disque et 1 ou 2…
J’ai également déjà testé en changeant le nom de plusieurs manière que se soit. Mais quand je regarde sur le partage depuis mon windows il est bien en « Freebox_Server »

# smbclient -L //192.168.0.254 -U freebox
Enter WORKGROUP\freebox's password:

        Sharename       Type      Comment
        ---------       ----      -------
        réservé au système Disk      AutoShare of fbxhdiskd partition 3001
        disque 1        Disk      AutoShare of fbxhdiskd partition 1001
        ipc$            IPC       IPC share
        disque 2        Disk      AutoShare of fbxhdiskd partition 2001
        volume 249go    Disk      AutoShare of fbxhdiskd partition 3002
        disque 4        Disk      AutoShare of fbxhdiskd partition 4001
sudo mount -t cifs //192.168.0.254/disque 1 /mnt -o rw,uid=1000,gid=1000,username=freebox,password=XXXXXXX
mount: bad usage
Try 'mount --help' for more information.

j’ai également pris la réponse de dmesg

 required for access to very old servers
[267778.665032] CIFS: VFS: cifs_mount failed w/return code = -6
[303124.182276] CIFS: Attempting to mount //192.168.0.254/disque1
[303124.182319] CIFS: No dialect specified on mount. Default has changed to a more secure di                                                                                                                         alect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS (SMB1). To use the less secure SMB1 dialec                                                                                                                         t to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=                                                                                                                         1.0 on mount.
[303124.248740] CIFS: VFS: cifs_mount failed w/return code = -22
[303134.701824] CIFS: Attempting to mount //192.168.0.254/
[303134.798565] CIFS: VFS: cifs_mount failed w/return code = -22

Je suis à la lettre tes indications car je sens que je loupe quelque chose ! j’avais déjà testé de mettre dans
nano /etc/fstab la version 1.0 0.0 / 2.0 le code erreur change
et j’ai essayé de faire les modifications et forcé le protocol smb2.0 dans le dossier de smb.conf mais la peut-être encore une fois j’ai loupé quelque chose

Lorsqu’il y a des espaces dans les noms des répertoires il faut les « échapper » avec \ :

sudo mount -t cifs //192.168.0.254/disque\ 1 /mnt -o rw,uid=1000,gid=1000,username=freebox,password=XXXXXXX

Dans le fstab il faudra utiliser \040à la place des espaces :

 //192.168.0.254/disque\0401 /media/freebox cifs  …
1 J'aime

@Bruno1 wow !Merci !!! et dire que ca fait 2 jours que je cherche ce détail ! Merci tu as assuré en effet il est bien monté maintenant :joy:
Pour être sur donc si j’ai bien compris mon fichier fstab:
//192.168.0.254/disque\0401 /media/freebox cifs _netdev,rw,users,credentials=/home/freebox/.smbcredentials,iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0 0 0

Et je suis donc obligé de monter les disques 1 par 1 je ne peux pas monter l’ensemble de mes disques ?

AMHA, certaines options sont tout à fait inutiles :

//192.168.0.254/disque\0401 /media/freebox cifs _netdev,rw,users,credentials=/home/freebox/.smbcredentials,iocharset=utf8,uid=1000,gid=1000

Et oui, il te faut monter tes « disques » un par un, sur des points de montage différents.

1 J'aime

@Bruno1
C’est super encore Merci tout est ok ! Je vais continuer mon exploration