Créer un hotspot wifi

Tags: #<Tag:0x00007f1ef67a1518> #<Tag:0x00007f1ef67a1130>

Je souhaite partager ma connexion filaire avec mes collègues.

J’ai ouvert les paramètres wifi, cliqué sur « allumer le point d’accès WiFI », et là c’était magique, je n’ai rien eu à faire : était affiché le nom de mon réseau, le type de sécurité (WPA en l’occurence) et un mot de passe.

Sauf que… nul ne peut s’y connecter. Pire encore, quand je tape ce mot de passe sur mon téléphone portable, il me montre une connexion active pendant trois secondes, avant d’être déconnecté et de m’annoncer que le mot de passe est erroné.

Des idées ?


PS : je me sers de Debian 10 sur un portable Asus équipé d’un Core i5-8250U

Salut
voir de ce coté https://wiki.debian-fr.xyz/Hotspot_wifi

c’est pas si facile apparement, et attention aux nom des interfaces réseau qui ont des nouvelles règles
cf

ip link

Exemple mon ethernet s’appelle enp4s0:

Bonjour,
Je vois aussi des régles IPtables et des références eth0…
Je ne suis pas sûr que sous Buster ce soit valide !
En revanche, dès que je rentre je teste avec NFtables et les nouveaux noms d’interfaces réseau.

Avec Network-Manager en mode graphique

il faut que le mode AP soit disponible

sudo iw list | grep "Supported interface modes" -A5
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor

La methode graphique est facile, le hotspot est créé, la clé d’authentication est ok mais le smartphone reste scotché sur “obtention de l’adresse ip”.:rage:

Comment le PC fourni t il une adresse ip à son client?

en ne refusant pas par le firewall, :joy: :joy:
dans mon cas

systemctl stop nftables

et hop le smartphone est connecté via le hospot debian avec une adresse 10.42.0.148

Je n’ai pas utilisé ce script, qui me semble complexe et pas forcément adapté à Debian 10.

J’ai bien :

# sudo iw list | grep "Supported interface modes" -A5
Supported interface modes:
	 * IBSS
	 * managed
	 * AP
	 * AP/VLAN
	 * monitor

J’ai fait :

# systemctl stop nftables

… et la connexion reste impossible.

La connexion est toujours impossible. Mes collègues ont essayé avec un iPhone, un téléphone sous Android, un PC sous fenêtres… rien.

Peut-être que c’est encore iptables qui gère le pare-feu ?
J’ai cru lire que la migration des règles vers nftables n’est pas automatique.

https://www.debian-fr.org/t/migrer-de-iptables-a-nftables/78639?u=r2mi

Les iptables n’ont pas l’air utilisées :

# systemctl stop iptables
Failed to stop iptables.service: Unit iptables.service not loaded.

Si le mot de passe généré pour l’accès WPA est réellement valide pour les clients,
Il faut partir à la recherche dans les journaux de l’erreur qui empêche la connexion.
Je ne sais pas vraiment vers quel journal t’orienter.

Tu pourrais donner ce mot de passe généré, pour vérification.
Ce ne serait pas la première fois qu’un mot de passe généré ou créé ne passe pas comme il devrait.

Je suis allé voir dans le fichier qui comporte le mot de passe. Je l’ai modifié. Pas d’amélioration.

Super la magie avec laquelle il n’y a rien à faire :confused:

Peux-tu essayer avec un SSID caché et sans authentification ?
Pour valider le côté radio.

Édition :

J’ai suivi le lien « Avec Network-Manager en mode graphique » de grandtoubab

J’ai réussi avec ma Gentoo et mon portable à faire fonctionner
un Hotspot en mode B/G avec nm-connection-editor

Manque de bol, La Méthode « Automatique (DHCP) » de l’onglet Paramètres IPv4 est grisée.
Il ne me reste que « Partagé avec d’autres ordinateurs » comme Méthode.

Et en passant la connexion de mon smartphone en adressage statique, ça marche.
C’est un essai rapide sans authentification.

Je n’ai pas trouvé comment cacher le SSID.

Il est peut-être possible de bidouiller le .nmconnection
de /etc/NetworkManager/system-connections/

J’ai utilisé nm-connection-editor, changé la priorité de connexion à 1, à 2, etc. ; j’ai bien mentionné que tous les utilisateurs peuvent se connecter en nombre illimité, j’ai utilisé le mode B/G à la place du mode automatique… rien n’y fait.

J’ai tenté de me connecter avec un iPhone. J’ai choisi « réseau masqué » et, quand j’ai sélectionné le protocole de sécurité WPA2, le téléphone a immédiatement rétorqué que ledit protocole n’était pas utilisé par ce hotspot : cela ne tendrait-il pas à prouver que les deux appareils avaient échangé des informations ?

Tout à fait.

Pour ce que j’en pense, il n’y a qu’un groupe d’informations que le dispositif (iPhone, …) attend du HotSpot et que ce dernier n’arrive pas à lui fournir :

- Une adresse IP dans une plage d’un réseau local
- Le masque de réseau
- L’adresse de la passerelle
- L’adresse d’un ou deux DNS

Tout ceci est normalement pris en charge par le protocole DHCP
mais curieusement HotSpot avec nm-connection-editor ne le gère pas.

Du moins, c’est ce qui me semblait.

C’est pour cela que je dis d’une :

et d’autre part :

- 192.168.1.75
- 255.255.255.0
- 192.168.1.1
- 8.8.8.8

Pareil pour moi.

Bon, de toute façon comme je ne suis pas dans un contexte avec Debian,
je ne vais pas trop m’acharner.

Quoique il n’y a rien qui ressemble plus à NetworkManager qu’un autre NetworkManager.
J’ai actuellement networkmanager-1.16.0

J’ai finalement réussi sans modifier la configuration de la connexion de mon smartphone :
Sans script, ni hostapd ou dnsmasq : NetworkManager suffit.

Capture%20d%E2%80%99%C3%A9cran_2019-08-11_05-36-45

Il est possible d’utiliser un réseau local différent mais je ne connais pas par cœur les adresses.
(voir la RFC 1918)

192.168.1.3 est l’adresse IP de mon poste sur le réseau 192.168.1.0/24
192.168.1.1 est la passerelle (Livebox)

Je ne sais pas quelle méthode est utilisée pour donner au client le ou les serveurs DNS.
C’est probablement la box qui s’en est chargé en délivrant l’adresse IP au smartphone.

Mon smartphone s’est vu attribuer en DHCP l’adresse 192.168.1.73

Si je continuais avec Hotspot, je ferai un bail permanent dans ma box avec l’adresse MAC du smartphone.

Capture%20d%E2%80%99%C3%A9cran_2019-08-11_05-40-15

La bande doit pouvoir être mise en automatique.
Le choix « Adresse MAC clonée » n’est pas important pour la connexion au HotSpot.

Capture%20d%E2%80%99%C3%A9cran_2019-08-11_05-46-50

Cette simple coche doit suffire.
Quoique la suivante peut servir aussi (?)

Pour la Sécurité Wifi, tu peux choisir ce que tu veux ; WPA ou WPA2 c’est très bien.

Inutile de choisir « réseau masqué » pour une connexion à un HotSpot
fait avec nm-connection-editor car ce dernier ne sait pas cacher son SSID.
Il peut sembler normal que le SSID d’un HotSpot ne soit pas caché.

Il faut redémarrer le service network-manager après des modifications du profil HotSpot.

Je n’aime pas mettre de Sécurité Wifi ;
Je préfère cacher le SSID du point d’accès et utiliser une liste blanche d’adresses MAC.
J’ai mon bon vieux routeur point d’accès WRT54G qui s’occupe bien de ça.
C’est évidemment qu’un pis-aller par rapport à un cryptage. Mon environnement le permet.

ps : quand on lance nm-connection-editor dans un terminal, il y a quelques infos affichées qui peuvent aider.

https://packages.debian.org/buster/network-manager mentionne :

Dépendances optionnelles⋅:

– ppp⋅: requis pour établir des connexions commutées (par exemple par
GSM)⋅;
– dnsmasq-base/iptables⋅: requis pour créer des connexions ad-hoc et
des partages de connexion⋅;
— configuration d’adresse ;
– libteam-utils⋅: le pilote Network Team permet à plusieurs interfaces
réseau d’être rassemblées pour fonctionner comme une seule. Ce
processus est appelé « ethernet bonding », « couplage de canaux » ou
« agrégation de liens ».

J’ai aussi essayé avec :

Capture%20d%E2%80%99%C3%A9cran_2019-08-11_09-07-33

Ce qui donne également automatiquement une adresse IP (10.0.0.27) à mon smartphone
mais dans un autre réseau, ce qui peut être utile pour séparer les réseaux.

Bonjour,
Je n’ai pas trop compris où tu en est de ton Hotspot Wifi.
En librairie il y a Linux Pratique no 114 pour créer un hotspot Wi‐Fi sécurisé. Source : https://linuxfr.org/users/floxy
Je ne l’ai pas lu, mais si ça peut t’aider…

Bonjour,

  • ça fonctionne (en sécurisé ou non) avec nm-connection-editor pour créer un profil hotspot.
  • le SSID du hotspot ne peut pas être caché.
  • je n’ai pas vraiment trouvé comment restreindre les connexions à son cercle autorisé.
  • c’était expérimental : j’en ai pas besoin car j’ai un autre point d’accès.
  • mes messages ne sont probablement pas assez clairs et/ou trop longs.

Je n’ai pas compris si tu t’adressais à moi.

1 J'aime

Euh, oui et non !
Je m’adressais plus particulièrement au créateur du post @Pathe
Mais avant de tenter moi-même à la maison, j’ai parcouru cette discussion avec beaucoup d’intérêt. Du coup je verrai à la rentrée si je me lance…
Bonne journée !

N’étant pas en France, je ne puis me procurer Linux Pratique.

Je constate un truc : le hotspot est désormais activé par défaut ! Il me faut l’éteindre à chaque démarrage de l’ordi !

@Albert : je posterai bien entendu mes éventuelles avancées.

C’est dû à la coche « Se connecter automatiquement … » de l’onglet Général du profil.

La dernière fois que j’ai créé un hot-spot Wi-fi avec Network-manager, j’ai fait les deux constats suivants :

  • Pour avoir du DHCP, il faut créer le serveur approprié (isc-dhcp fait bien l’affaire), et le configurer pour qu’il réponde sur la carte Wi-fi, sinon ça ne fonctionne qu’avec des adresses statiques
  • Le WPA était cochable mais ne fonctionnait pas. Le fait de passer en WEP a résolu le problème. Comme il s’agit d’un lieu peu fréquenté, je m’en suis contenté, mais il manque peu-être juste un paquet pour que ça fonctionne bien