[Deb9] Soucis installation php-curl

Tags: #<Tag:0x00007f151329b948>

Bonjour,

Je viens vers vous car après quelques jours de recherche, je suis perdu…

Lorsque je veux installé php7.3-curl il me l’installe mais supprime apache2 pour m’installer lighttpd, mais je veux apache2 moi :frowning:

https://i.imgur.com/ievtkLW.png
https://i.imgur.com/a7NCIqa.png

Si vous avez une solution ça serait cool !

1 J'aime

salut
Tu es sous quel systeme d’exploitation??

mieux vaut ne jamais indiquer de numéro de version…
tu as le même retour avec sudo apt install php-curl ?

donne aussi le retour de :

grep -Rn --include=\*.list ^[^\#] /etc/apt/

pour voir ce que tu as comme éventuels PPA exotiques

Debian 9

Et la commande php-curl pareil aussi j’avais déjà tester de base ^^

Le résultat de ta cmd :

tu as installé le PPA d’ondrej sury qui met le bazar dans ton install.

il y a une raison à ça ?

dans tous les cas je te conseille de le virer.
si tu as besoin de PHP 7.3 mieux vaut passer par docker ou plus simple mettre à jour vers debian 10.

Salut,

Ppa je ne sais pas ce que c’est lol,

Et Debian 10 non car je devrais tout refaire à zéro… :frowning:

Je connais pas ton docker je vais regarder ça

tu as besoin de PHP 7.3 ou PHP 7.0 te suffit ?
PHP 7.0 c’est pas terrible parce que cette version n’est plus supportée depuis 2019…
https://www.php.net/supported-versions.php

docker c’est bien, c’est propre mais c’est plus technique…

Procède a sa lise à jour et reprends la meme chose.

@kro , les ppa c’est pour Ubuntu. Là c’est une frankendebian avec en plus les dépôts sury. Mais le résultat est le même, c’est cassé à la première tentative de mise à jour :wink:

Vu le mélange entre les dépôts : oldstable, stretch, sarge, sid, etc. cela va être compliqué à réparer à moins d’être un as de l’épinglage de paquet s (apt pining)et d’aptitude.

1 J'aime

Il me faut un PHP qui marche quoi 7.0 minimum après quitte à passer sur du 7.4 mais surtout avec Apache2

Comme dit Bruno, il serai plus judicieux de repartir sur une base propre

Une base propre OK, mais j’ai tout mes serveurs de jeux, config que ça soit vpn ssl mail, fin un vrai bazar :frowning: