Debian 10 Buster - Installation du pilote Nvidia avec Gnome

Tags: #<Tag:0x00007f1ee6398b98> #<Tag:0x00007f1ee63989b8> #<Tag:0x00007f1ee6398850> #<Tag:0x00007f1ee63981e8> #<Tag:0x00007f1ee63980a8>

Bonjour à tous,

Je ne sais pas si le titre est tout à fait clair, je vais donc essayer d’ajouter quelques éléments supplémentaires.

J’ai installé Debian 10 Buster avec le gestionnaire de bureau Gnome proposé lors de l’installation du système.

J’ai fait cette installation sur mon ordinateur portable qui est assez récent, et dispose donc d’une carte graphique intégrée au processeur Intel, et d’une carte graphique dédiée (Nvidia MX150).

Par la suite, et pour profiter au mieux des possibilité offertes par la carte graphique dédiée, j’ai voulu installer le pilote Nvidia. Et là, c’est le drame… :tired_face:

J’ai parcouru en long en large et en travers différents tutoriels sur le sujet, je les ai suivi, et… Ben ça ne marche pas. En résumé, j’ai :

  1. installé nvidia-detect,
  2. installé le pilote Nvidia recommandé,
  3. effectué diverses modifications proposées dans les tutoriels sur des fichiers de configuration, mais sans résultat : j’ai toujours un message d’erreur au démarrage en lien avec le driver Nvidia, et les test que je fais semblent me confirmer que c’est le GPU du processeur qui est encore utilisé.

Je dois avouer qu’entre Debian, Gnome, Wayland, X11, je suis pommé… Je ne suis pas sûr:

  1. d’avoir une bonne vision de tous ces éléments, et notamment de comment ils s’articulent entre eux,
  2. que les tutoriels soient bien adaptés à ce cas précis (la plupart proposent en effet de paramétrer le serveur X pour l’utilisation de la carte graphique, mais aucun n’évoque Wayland)…

Donc voilà, si quelqu’un peut m’aider, je suis preneur! De plus, ayant envie d’apprendre et de comprendre, si vous connaissez une doc accessible sur le sujet, je prends également!

Merci d’avance!

que dit la commande:

lspci | egrep ‘VGA|3D|Display’

si il y a deux lignes il faut alors installer optimus- bumblebee après avoir désinstallé et nettoyé toutes traces du pilote nvidia que tu as installé avant.

Il y a bien deux lignes…:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)

Je pensais que Bumblebee ne servait qu’à faire une bascule entre GPU ?

Je vais quand même tenter le coup comme ça!

A part le fait que tu aies un message d’erreur, tu ne dis pas ce qui ne marche pas, c’est un peu génant. :smiley:

La carte graphique est gèrée à 2 niveaux:

  • un module noyau qui fait la gestion de la carte pour le compte du noyau linux, qui fournit les fonctionnalités graphiques de base à tous le système (le module nvidia qui apparait dans lsmod quand tout fonctionne).
  • un serveur de fenètres X11 spécifique dédié à la carte, qui fait appel à la gestion noyau précédente, et qui fournit les fonctionnalités graphiques supplémentaires aux applix X11
    Dans aucun cas, donc, le window manager (gnome/kde/etc) ne joue un role là dedans.

Non, ta carte a une double puce graphique, et il faut que les deux puces intel et nvidia soient gèrées par bumblebee pour fonctionner.

Salut mattotop,

Quelques éléments en plus :

Ce qui ne marche pas, c’est tout simplement le pilote Nvidia : j’ai des “Echec” (en rouge) qui apparaissent dans la liste qui défile au démarrage de Debian. Je ne sais pas où retrouver le détail de ces messages, mais de ce que j’arrive à comprendre, il semblerait que cela soit lié à une impossibilité de désactiver le pilote Nouveau qui serait associé à systemd. Du coup, ben ma carte Nvidia n’est pas utilisée, et je suis toujours sur le processeur graphique Intel.

Je vais peut-être dire une connerie, mais il me semblait avoir compris que le serveur de fenêtres n’était plus X dans la version de Gnome associée à Debian 10, mais Wayland. Est-ce que cela peut changer quelque-chose ? A priori, je dirais non, vu ce que tu m’as expliqué.

OK pour Bumblebee, mais est-ce que ça ne devrait pas déjà marcher simplement en choisissant une des deux cartes ? Après, je suis d’accord que chacun des GPU a son avantage, et que l’installation de Bumblebee est intéressante!

C’est la commande dmesg pour le matériel, et la partie de /var/log/syslog à l’heure de ton dernier reboot qui commence pas loin d’une ligne qui doit contenir quelque chose ressemblant à:
kernel: [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-XXXXX-amd64 root=UUID=XXXXXXXX ro quiet

Non, ça, c’est n’importe quoi:
par défaut, l’installation de nvidia désactive nouveau en ajoutant une instruction blacklist nouveau dans le fichier /etc/modprobe.d/nvidia-kernel-common.conf (tu peux vérifier qu’il est bien là et que le blacklist y est bien).

Effectivement, je parlais de X11, sans préciser si je parlais de xorg (avant) ou de wayland (maintenant), mais comme tu dis, ça ne change pas grand chose au fait que ce soit la couche qui gère X11 pour l’un ou l’autre.
Bref, oui, c’est kif kif et ça ne change rien au probléme.

Non, mais de ce que j’ai compris (là on sort de mon expérience), ce type de double puce fonctionne >solidairement< avec les deux:
tu ne peux pas utiliser un GPU sans l’autre et il te faut bumblebee, ce n’est pas un choix mais une obligation.
Mais là, comme je te dis, on sort du terrain que je connais, je n’ai jamais eu besoin de bumblebee donc je me trompe peut être.

Bonjour,
Les pilotes libres de carte graphique on atteint un niveau de qualité suffisant pour utiliser correctement l’accélération matérielle. Perso, je n’utilise pas les drivers propriétaires de ma carte Nvidia.
Dans ce cas précis, il est probable que ton ordi utilise la technologie Optimus (technologie hybride entre la CG Nvidia et le GPU de la CM). Pour savoir si c’est le cas:
lspci -nn | egrep -i “3d|display|vga”

ça donne le modèle de CG. Si ça renvoie 2 lignes, c’est bien la technologie Optimus qui est utilisée. Dans ce cas:
pour utiliser les pilotes libres(nouveau):
aptitude install bumblebee primus

pour utiliser les pilotes Nvidia:
aptitude install bumblebee-nvidia primus

Alors, pour @mattotop :

  • Je n’ai pas retrouvé les messages auxquels je pensais dans le fichier/var/log/syslog, mais dans /var/log/boot.log. Les messages auxquels je fais allusion sont :

[e[0;1;31mFAILEDe[0m] Failed to start e[0;1;39mSwitcheroo Control Proxy servicee[0m.
See ‘systemctl status switcheroo-control.service’ for details.
[e[0;1;31mFAILEDe[0m] Failed to start e[0;1;39mLoad Kernel Modulese[0m.
See ‘systemctl status systemd-modules-load.service’ for details.
[e[0;1;31mFAILEDe[0m] Failed to start e[0;1;39mNVIDIA Persistence Daemone[0m.
See ‘systemctl status nvidia-persistenced.service’ for details.

Il y en a encore d’autres…

  • Contenu du fichier /etc/modprobe.d/nvidia-kernel-common.conf :

alias char-major-195* nvidia
#options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=44 NVreg_DeviceFileMode=0660
# To enable FastWrites and Sidebus addressing, uncomment these lines
# options nvidia NVreg_EnableAGPSBA=1
# options nvidia NVreg_EnableAGPFW=1

En revanche, j’ai un fichier “nvidia-blacklists-nouveau.conf” dans le même dossier, dont le contenu est :

# You need to run “update-initramfs -u” after editing this file.

# see #580894
blacklist nouveau

Et pour répondre à @julio13 également :

  • Je vais essayé Bumblebee et je vous dis ce que ça a donné!