Debian 11 bullseye et KDE

Tags: #<Tag:0x00007fb9955d1d70> #<Tag:0x00007fb9955d1640> #<Tag:0x00007fb9955d10f0> #<Tag:0x00007fb9955d0ce0>

Bonsoir à tous,

Après avoir passé une bonne soirée à chercher, je me permet de m’en remettre à vous. M’étant monté une nouvelle machine, j’ai décidé d’y installer directement Debian 11 Bullseye. J’ai donc durant l’installation sélectionné « environnement Debian », « KDE » (que j’ai choisis) et les utilitaires de base.

Après avoir résolu un problème de firmware Realtek qui empêchait la machine de booter, elle démarre désormais… en tty uniquement!
L’écran de démarrage bloque sur « started Unattended upgrades shutdown », mais je peux me logger sur les tty 2 a 6.

Par contre là où il y a problème, impossible de lancer un environnement graphique, en l’occurrence KDE et SDDM comme gestionnaire de connexion. Je ne trouve aucune commande me le permettant.
J’ai installé certains paquets que j’ai lu comme recommandé et qui étaient manquants. Par contre, je me rends compte que « kdm » n’est pas dans les dépôts. Je ne sais pas si le problème viens de là où s’il a été remplacé maintenant…

Quelles sont vos idées?

En vous remerciant par avance,
Bien cordialement.

En ligne de commande tu peux installer le gestionnaire lightdm et le choisir par défaut dans l’écran de reconfiguration qui va s’afficher

sudo apt install lightdm

redemarrer
et voir si l’écran de connexion s’affiche

Bonsoir,
Quelle est ta carte vidéo? les firmware et pilotes correspondant sont-ils bien installés?

J’arrive à me connecter, en effet. Merci beaucoup.

Mais j’aimerai bien comprendre me soucis, et le signaler à la communauté si besoin (je n’ai jamais fais). Ma carte est une RX460 de chez Gigabyte (achat d’ occasion). Je vais chercher les drivers.

Il y a visiblement bien un soucis avec les drivers de la carte, car je suis actuellement bloqué en 720p. Je vais chercher cela demain.

Je vous remercie et vous tiens informé.

pour avoir les infos sur ta carte

lspci -nnk | grep -i vga -A3

Il s’agit bien d’une RX460 4 Go de chez Gigabyte. J’ai essayé d’lnstaller le pilote « Radeon » en suivant le guide d’Ubuntu:
www.doc.ubuntu-fr.org/radeon

Mais le fichier xorg a beaucoup d’erreur et quand je le met dans /etc/X11, lightdm ne démarre plus. Je ne comprends pas comment cela fonctionne sous Debian…

il y a bien longtemps qu’on ne cree pas de fichier xorg à la main , tout est automatisé
les éléments de la configuration se retrouve dans le dossier
/usr/share/X11/xorg.conf.d par auto-détection de xorg
exemple mon fichier radeon simplissime

/usr/share/X11/xorg.conf.d$ cat 10-radeon.conf
Section "OutputClass"
	Identifier "Radeon"
	MatchDriver "radeon"
	Driver "radeon"

avec
firmware-amd-graphics
firmware-linux-free
firmware-linux-nonfree
xserver-xorg-video-radeon

ca doit être suffisant

Bonjour,

Je ne saurais comment vous remercier!!!
Je ne connaissais pas les premiers paquets que vous listez, je les ai installé et micracle… même SDDM fonctionne!!

J’ai donc désinstallé lightdm, reconfiguré SDDM, et tout semble fonctionner parfaitement!!

Encore tout mes remerciements!