Debian 2.4-24


#1

Bonjour à tous,

où pourrais-je trouver une image de CD avec Debian noyau 2.4-24?

Merci d’avance!


#2

LA


#3

Un grand merci :slightly_smiling:!


#4

Finalement il s’avère que c’est un noyau 2.4-27 à la place d’un 2.4-24 initialement demandé.

J’ai réellement besoin d’une galette avec un 2.4-24.


#5

Prends une version anterieur si tu n’arrive pas a trouvé la version directement et patch la avec ca


#6

Débutant, je suis !
Qu’est-ce que c’est exactement un “patch” ?
Je suppose que c’est un additif qui corrige un bug.
Je viens d’aller sur le site que tu donnes et j’ai vu qu’il y en a une floppée.
Lesquels choisir ?
Comment les installer ?
Peut-on les installer avec un systeme déjà en place ?

Merci de vos lumières


#7

En fait quand tu install linux tu as un certain noyaux et il n’est pas forcement le dernier qui viens de sortir avec toutes les mises a jours puisqu’il faut a Dario98 absolument un kernel 2.4.24 il n’a qu’a installé une version de linux anterieur a la 2.4.24 par exemple la 2.4.18 ou une autre et faire la mise a jour avec les sources du kernel que j’ai donné dans le lien (la derniere version stable est la 2.6.9 actuellement)

Oui tout a fait tu upgrade dans ce cas la ton noyau et ca te permet d’avoir les dernieres mises a jour

En recompilant le noyau tu trouveras des tutos partout sur le net

Tout depend de ton noyau actuel en general tu ne fait pas la mise a jour directement comme ca vers la derniere sorti si tu as un kernel ancien tu fait plusieurs mises a jours pour arrivé a la derniere

Et bien moi aussi je suis debutant je souhaiterais installé sarge avec le mode graphique mais je n’y arrive pas il y a un probleme au niveau des paquetages j’attendrais donc sa sorti pour reessayer car pour le moment elle n’est quand testing :wink:


#8

Merci pour tes réponses.
J’attends aussi pour Sarge car je n’avance plus :cry:


#9

Bonjour

[quote=“Ricardo”]Qu’est-ce que c’est exactement un “patch” ?
Je suppose que c’est un additif qui corrige un bug.[/quote]
sous windaube, c’est effectivement ce que ca veut dire: une rustine !
Avoir la prétention de corriger un bug de windaube, c gonflé :laughing: !!!
sous linux, un patch, c’est plus généralement un fichier de modifications a appliquer sur une arborescence de sources dans le but d’obtenir des sources dites (donc :slightly_smiling: ) “patchées”.
Grossièrementsi tu installe avec apt-get le patch que t’indique #nemes1s#, cela va modifier tes sources de noyau afin qu’elles correspondent aux standard debian.

[quote]Je viens d’aller sur le site que tu donnes et j’ai vu qu’il y en a une floppée.
Lesquels choisir ?[/quote]
à priori, si ton objectif n’est que d’obtenir une debian (n’importe laquelle) avec un noyau 2.4.24, tu n’as besoin d’aucun patch en particulier, contrairement à ce que dit #nemes1s#.

Si ta debian fonctionne, tu télécharges les sources officielles du noyau que tu veux, tu les déploies dans /usr/src, en faisant en sorte que ton lien symbolique /usr/src/linux designe bien tes sources, et ensuite, tu debianise tes sources avec make-kpkg:

/root# cd /usr/src /usr/src # wget ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-2.4.24.tar.gz /usr/src # tar xzf linux-2.4.24.tar.gz /usr/src # ln -s linux kernel-source-2.4.24 /usr/src # cd linux /usr/src/linux# make-kpkg debian
si tu veux ne pas te casser les pieds, tu copies la config de ton noyau sous lequel tu tournes actuellement dans le répertoire :

ensuite, tu ajustes ce nouveau fichier pour les options du 2.4.24 qui n’existent pas dans ton noyau courant (il va te demander une à une les infos qui lui manquent, ca peut etre long):

ensuite tu peux aller “tweaker” ton noyau:

aprés, tu compiles ton noyau “à la debian”:

cela va engendrer ds /usr/src un paquetage debian avec un nom de daube, que tu pourra ensuite installer de la manière suivante:

(à priori ce nom la)

et hop, ta debian rajoute un noyau à ton boot !
plus qu’a redemarrer sur ton noyau 2.4.24

[quote]Comment les installer ?
Peut-on les installer avec un systeme déjà en place ?[/quote]

à priori, si tu installes un patch avec apt-get, il s’installe dans /usr/src/kernel-patch, afin que make-kpkg puisse l’appliquer à tous les noyaux que tu voudras compiler. Mais il faudra de ttes les manières préciser au moment de la compile de ton noyau quels patchs tu veux appliquer.

De rien, mais il me vient une question soudaine: pourquoi veux tu ABSOLUMENT un 2.4.24 ?


#10

[quote=“MattOTop”]à priori, si ton objectif n’est que d’obtenir une debian (n’importe laquelle) avec un noyau 2.4.24, tu n’as besoin d’aucun patch en particulier, contrairement à ce que dit #nemes1s#. [/quote]En fait je lui disais de prendre un autre noyau et de faire la mise a jour jusque la 2.4-24 si il ne trouvait pas directement le noyau mais c’est vrai que c’est plus simple en compilant le noyau 2.4-24 directement a la sauce debian