Debian 7 install GLIBC_2.14 GLIBC_2.15


#1

Bonjour à tous.

Alors avant de commencé, un petit rappel de ma part.
Oui je suis sur Debian 7. Oui c’est une vieille version obsolète. Oui elle est plus à jour. Oui je suis un vieux :), Oui ,Oui oui, etc etc etc…

Bref, si je suis ici, c’est que je suis dans une impasse, et que j’ai essayé pas mal de solution qui n’ont rien abouti.
Certe pas mal de chose sont un peu dépassé, MAIS, si je suis dans ce genre de cas, c’est que les moyens me manque, que ce sois Hardware, personnel, technique, etc etc…
Donc je n’accepte pas les réponses du genre. “fais une MAJ pour réglé t’on problème”. J’en veux pas

Alors je suis en train de faire une installation de Debian 7 en x64 sur une machine réelle. (ACTUELLEMENT), Une installation au propre durant un petit moment.

Malgré que la version soit vieille, j’ai réussi à trouvé des paquets ici, que j’ai ajouté à ma sources.list dans “/etc/apt

deb http://archive.debian.org/debian/ wheezy contrib main

Et à leur actuelle, ou je bloque, c’est pour l’installation d’un serveur factorio (aussi une vieille version en 14.19). Mais mon souci ne concernant pas le serveur factorio en lui même.

Mais plutôt aux paquets que le serveur factorio à besoin pour fonctionner. Car oui durant une époque, j’avais réussi à le faire fonctionner. Mais j’ai oublié de prendre des notes, Voila :frowning:

Et donc à l’heure actuelle, lorsque je veux éxécuté le serveur factiorio (non je ne vais pas le tuer :)). J’ai un message d’erreur , me disant que je dois installé:

GLIBC_2.14 et GLIBC_2.15.

Sauf que je ne trouve rien de concret pour l’installation de ces paquets.
Et j’ai besoin de vous pour trouvé ces paquets et les installers.

Voila, j’attends vos réponses avec impatience.
En vous remerciant.


#2

Bonjour,
On dirait un problème ressemblant au tien :


#3

?
Apparemment il faut être très prudent.
Personnellement, j’ai déjà «cassé» une Stretch en jouant avec glibc…


#4

Bonjour albert.
Merci pour ton poste. Alors le premier, ne fonctionne pas du tout, j’ai toujours une erreur :

./bin/x64/factorio: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/x64/factorio)
./bin/x64/factorio: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by ./bin/x64/factorio)
./bin/x64/factorio: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.15' not found (required by ./bin/x64/factorio)

J’ai téléchargé et GLIBC_2.14 et GLIBC_2.15.
Mais si cela ne te dérange pas, je voudrais bien que tu me donne un coup de main pour l’installation, s’il te plait :slight_smile:


#5

Bonjour,
Pour le premier lien, j’ai vu après coup qu’il ne fonctionne pas pour Wheezy.
J’en profite pour rappeler le danger d’installer, de modifier Glibc sur un système qui fonctionne bien !
Regarde si cet article peut t’aider :
https://linuxfr.org/users/tilk/journaux/faire-coexister-plusieurs-versions-de-la-glibc
Peut-être qu’un développeur Debian passant par cette discussion te serait plus utile que moi !
En tout cas, si tu tiens à ton installation, sois très prudent.


#6

Merci beaucoup, je vous tient au courant très vite


#7

Avec plaisir, si ça peut aider :+1:


#8

En ce moment j’ai une gros semaine, je vais commencé à bossé dessus ce week-end. Je vous tient au courant très vite.
Mais si par exemple, je devais passer sous debian 8, ou est ce que je peux voir la différence par rapport à debian 7.

Je vous remercie, a plus tard.