[debian][dpkg][apt-get] Problème de corruption de paquets


#1

Bonjour.

Cela fait plusieurs semaine sans que ni moi ni personne ne trouve de solutions: Depuis une mise à jour fin août deux paquets openoffice posent problèmes. Ils restent bloqués en version 1.1.2-2 et impossible de les mettre à jour vers 1.1.2-3
voici le résultat d’un apt-get dist-upgrade

[root@latibo]$ apt-get dist-upgrade Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Calcul de la mise à jour... Fait Les paquets suivants seront mis à jour : openoffice.org openoffice.org-mimelnk 2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour. 6 partiellement installés ou enlevés. Il est nécessaire de prendre 10,5Mo dans les archives. Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés. Souhaitez-vous continuer ? [O/n] Réception de : 1 ftp://ftp.de.debian.org testing/main openoffice.org-l10n-en 1.1.2-3 [3518kB] Réception de : 2 ftp://ftp.de.debian.org testing/main openoffice.org 1.1.2-3 [6926kB] Réception de : 3 ftp://ftp.de.debian.org testing/main openoffice.org-mimelnk 1.1.2-3 [62,2kB] 10,5Mo réceptionnés en 26s (404ko/s) Reading package fields... Done Reading package status... Done Retrieving bug reports... Done (Lecture de la base de données... 106885 fichiers et répertoires déjà installés.) Préparation du remplacement de openoffice.org-l10n-en 1.1.2-3 (en utilisant .../openoffice.org-l10n-en_1.1.2-3_all.deb) ... dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-l10n-en_1.1.2-3_all.deb (--unpack) : le sous-processus pre-installation script a retourné une erreur de sortie d'état 139 dpkg : erreur lors du nettoyage : le sous-processus post-removal script a retourné une erreur de sortie d'état 139 Préparation du remplacement de openoffice.org 1.1.2-2 (en utilisant .../openoffice.org_1.1.2-3_all.deb) ... dpkg : avertissement - ancien script pre-removal a retourné un code d'erreur de sortie 139 dpkg - tentative d'exécution du script du nouveau paquet à la place ... dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org_1.1.2-3_all.deb (--unpack) : le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 139 dpkg : erreur lors du nettoyage : le sous-processus post-installation script a retourné une erreur de sortie d'état 139 Préparation du remplacement de openoffice.org-mimelnk 1.1.2-2 (en utilisant .../openoffice.org-mimelnk_1.1.2-3_all.deb) ... dpkg : avertissement - ancien script pre-removal a retourné un code d'erreur de sortie 139 dpkg - tentative d'exécution du script du nouveau paquet à la place ... dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-mimelnk_1.1.2-3_all.deb (--unpack) : le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 139 dpkg : erreur lors du nettoyage : le sous-processus post-installation script a retourné une erreur de sortie d'état 139 Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/openoffice.org-l10n-en_1.1.2-3_all.deb /var/cache/apt/archives/openoffice.org_1.1.2-3_all.deb /var/cache/apt/archives/openoffice.org-mimelnk_1.1.2-3_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) [root@latibo]$
openoffice et openoffice-mimelink ne veulent pas s’installer quoi que je fasse. J’ai essayé:

  • de faire un apt-get update évidemment.
  • de faire un apt-get clean mais les nouveaux paquets sont pareil.
  • d’installer les paquets de sid mais visiblement ce sont les même et j’ai toujours le bug.
  • de les désinstaller mais le système me répond que leur état est bizarre et qu’il faut les réinstaller. MAJ en modifiant un fichier de conf et utilisant force, la désinstallation fonctionne mais toujours pas l’install
  • de les réinstaller un a un mais ça loupe à chaque fois, erreur 139, même avec force-all comme lors du dist-upgrade.
  • d’utiliser aptitude ou dpkg ou synaptic à la place d’apt mais le résultat est le même, même avec des force.
  • d’installer les binaries téléchargées sur le site d’openoffice dans /usr/local puis de le désinstaller le tout pour faire le ménage, ça ne résoud pas le problème
  • de copier /etc/openoffice et /usr/lib/openoffice de mon pc de bureau qui a une config identique, toujours erreur 139.
  • de modifier /var/lib/dpkg/status pour déclarer les paquet récalcitrants comme installés ou désinstallés. Si je les déclare comme installé dpkg dit que le fichier de conf contient une erreur et refuse d’aller plus loin. Et si je le déclare comme supprimé, que je déplace les fichiers de l’appli, alors dpkg lors de la ré-install ressort la même erreur 139.
  • de modifier /var/lib/dpkg/info, ça c’est le seul truc qui a un tant soit peu marché puisque avec des force la désinstalle des paquet passe

Je signale qu’avant chaque modif pas très Catholique j’ai fait des sauvegarde que j’ai utilisé par la suite pour revenir à l’état initial.

J’ai une Debian Testing, kernel 2.6.7. Mon PC n’est pas overckloké et n’a pas de trous dans la ram comme dans le disque dur.
ça fait 3 semaines et plusieurs dizaines d’heures que je me bat contre ce problème. Y’a pas trop d’infos sur le net et personne ne sait quoi faire devant ce problème.
Merci de votre aide, je désespère.


#2

mise à jour du post


#3

Bon ce problème dure depuis trop longtemps. Je souhaite trouver un moyen d’effacer l’entrée de ces paquet openoffice dans apt. Il doit y avoir y avoir un fichier où est enregistré tous les paquets installés, lequel est-il? Je pourrais alors l’éditer, supprimer l’entrée de ces deux paquets et ensuite faire la réinstallation de ces paquets sans que apt se pose de question.

La question est donc: savez-vous où se trouve ce fameux fichier de préférences?


#4

t’as essayé de faire un apt-get clean pour vider ton cache, puis apt-get --reinstall install openoffice.org ?


#5

ouais, plusieurs fois mais sans succès :cry:


#6

Il y a /var/lib/dpkg/status qui contient la liste des packages installés sur ton systéme, mais ça me semble un peu risqué d’y toucher, et je suis pas sûr que ça résolve ton pb.
Autre solution, t’as essayé d’installer tes packages directement avec dpkg à partir des archives contenues dans /var/cache/apt/archives ? Au pire avec un --force-all en dernier recours


#7

ok merci pour l’info je tente l’édition demain.
Par contre pour installer le paquet avec force-all, ça passe pas non plus.


#8

y’a rien a faire c’est dingue ça ne marche pas! j’ai essayé de déclarer le paquet comme configuré mais en ce cas dpkg dit que le fichier de conf contient une erreur. Et si je le déclare comme supprimé, que je déplace les fichiers de l’appli, alors dpkg lors de l’install ressort la même erreur 139.
C’est dingue ça fait 3 semaines que je suis bloqué et personne ne sait quoi faire devant ce problème.


#9

J’ai aie vraiment plein le c** de ce problème de m**** qui me fait ch*** depuis des semaines. Je viens de passer des heures encore aujourd’hui à essayer de micmacer une solution à cette m**** sans succès. Put*** c’est dingue j’ai jamais autant été emme*** je me croirait sous Windows. Tout ce que j’ai réussi à faire c’est à désinstaller les paquets mais aucune réinstallation n’est possible!


#10

t’es arrivé à les desinstaller? ça s’arrange alors :laughing:
Bon, un truc con (et ça m’étonnerait que ça aide mais c’es la seule idée qui me passe pour l’instant), t’as essayé à partir d’un autre repository? (je vois que t’utilises un miroir allemand, fr ça serait ptet mieux, au moins au niveau débit)


#11

j’ai essayé carément d’autres paquets de woody avec toujours les mêmes erreurs. Tant qu’au débit étant en Lorraine les serveurs Allemands marchent mieux et je tire habituellement dans le 650ko/750ko


#12

as tu essayé de faire une install avec les sources officielles OO (pas celles debian), en récupèrant les tarballs sur le site officiel ?
(en attendant la prochaine dist-upgrade)…


#13

oui j’ai essayé et ça passe.
Le problème ne vient pas des paquets debian, n’importe quel paquet debian d’openoffice que j’ai essayé plante à cause de l’install calamiteuse des précédents paquets qui étaient buggés.


#14

C’est dingue cette histoire, personne est capable de résoudre ce blem…


#15

Dis donc, je viens de “subir” une mise à jour d’OO qui me propose d’installer les exe “linkés” en précisant que cette option risque de casser les sommes MD5, et donc d’empècher la vérification de la cohérence du paquet.
Ca ne pourrait pas avoir un rapport avec ton pb, le script de désinstall refusant de supprimer des fichiers modifiés ?
Par exemple, tu peux essayer de réinstaller ta version d"'origine, faire un dpkg-reconfigure en non linké (voir même peut être sans réinstaller), puis une mise à jour.
Juste pour voir… :slightly_smiling:
Par ailleurs, aprés investigation, l’erreur shell 139, c’est un core dump (SIGSEGV, signal 11), une segmentation fault qui peut être causée, entre autres par un manque de swap.
Quoi qu’il en soit, si tu n’es pas en ulimit 0, tu dois avoir un core qqpart, qui peut - peut etre - te permettre de deboguer . :laughing:
Des pistes quoi…
Mais j’ai vu plusieurs “erreur 139” toutes liées à apt, mais pas forcément sur OO.
Si tu trouve qqchose avec ca, n’hésites pas.


#16

je n’aie plus la version d’origine des paquets, ils ont disparu des serveurs


#17

malheuresement je ne peux pas reconfigurer openoffice en non-linké puisque le paquet ne se s’installe pas correctement.


#18

je me répète: si tu veux absolument réinstaller OO, tu peux peut être récupèrer les sources d’origines, et compiler le tout “à l’ancienne” sans utiliser un système de paquetage…
(attention aux répertoires d’install tt de même)


#19

ouais mais c’est chiant


#20

tout est relatif :slightly_smiling: