Debian education


#1

bonjour à tous

je suis nouveau et debutant.
je me suis procuré le cd iso debian education, mais je ne veux pas l’intaller avec windows mais sur un disque vierge. Quelle est la procèdure.
ma config.
msi kt3 ultra2
amd 1800+
1 disque 60 windows
1 disque 40 mandrake 10.0
1 disque 30 debian sI…
merci de vos réponses.

:unamused:


#2

lances toi, si ton CD est correct, tu n’as rien à faire d’autre que rajouter ton disque et installer.

la config de partition de debian, ca depend de tes besoins et de tes gouts, mais le partitionnement par défaut, pas trop mal, c’est une grosse partition / et une partition de swap.

Sinon, si tu ne souhaites “surtout pas” toucher même au MBR de ton disque windows, il y a un petit hack à faire pendant l’install:
1/dans le bios actives la sequence de boot cdrom/disque linux/disque windows, au lieu de cdrom/disque windows/disque linux.
2/tu installes le boot loader que tu as choisi (si tu as le choix installes grub plutot que lilo) SUR LE MBR DE TON DISQUE LINUX, pas sur le MBR de windows.
fais une disquette de boot si tu en as l’opportunité durant l’install.
aprés, si ca plante, tu pourra tjs remettre le bios sur son boot d’avant, et essayer de booter linux avec la disquette…

Dernier conseil: si ton install se passe bien, mais qu’au reboot, tu n’arrives pas à booter sous linux, pas la peine de recommencer ton install: elle plantera de la même manière une deuxieme fois. La solution, c’est de booter sur un “livecd” (une knoppix, par exemple) et d’aller corriger ton boot. Si ca arrive, tu demandes, et on te pilotera.

Bonne chance…


#3

:laughing: Meilleurs voeux à tous.
mattOtop

  1. je ne peux booter mon cd car je n’ai pas le saveur adéquate, avec bf24 ça ne marche pas.Où trouver le bon?
  2. j’ai un multiboot LILO. Au boot du cd comment faire pour qu’il s’installe sur son disque?.
    Merci de vos réponses.
    A+

#4

[quote=“urlux”]:lol: Meilleurs voeux à tous.
mattOtop

  1. je ne peux booter mon cd car je n’ai pas le saveur adéquate, avec bf24 ça ne marche pas.Où trouver le bon?
    [/quote]
    ecoutes, tu me fais découvrir le bf24, dc mes pistes seront aléatoires.
    il me semble que tu peux télécharger des disquettes avec différentes saveurs, en suivant les instructions ici, au par. 4.2:
    debian.org/releases/stable/i … nel-choice
    sinon, je n’utilise plus de cd pour mes installs depuis un bout de temps, et je fais toutes mes installs en “chroot/livecd”: une knoppix et roule ma poule je démarre mon install debian. Je viens de trouver un nouveau wiki ici:
    ensilinx1.imag.fr/~mat/installdebtest2

[quote=“urlux”]
2) j’ai un multiboot LILO. Au boot du cd comment faire pour qu’il s’installe sur son disque?.
Merci de vos réponses.
A+[/quote]
La, je comprends moyennement de quoi tu parles :slightly_smiling:

PS: aprés t’avoir relu, si ta question c’est “comment utiliser mon lilo existant pour tout booter”, je te dirais que la seule maniere, c’est d’installer ta debian sans installer de bootloader, puis d’aller configurer ton lilo sous ta mandrake pour y rajouter l’entrée de ton noyau debian (j’imagine que c’est la que tu as ton lilo.conf).


#5

bonsoir à tous
MattOTop.
Je me suis lancé, au moment du 1er écran il suffit de faire entrée.
Tout se déroule bien, arrivé au partitionnement je fais manuel et là sur l’écran je nai que 2 dd :
hda le disque de windows suivi du disque que je veux dédier à debian
hdc celui de mandradre.
Je me suis fait peur, j’ai arrêté.
mon souci, si je partitionne hda j’ai peur pour widows.
En fait pourquoi mon futur disque debian n’apparait pas comme hdb?pourtant il a booté jusque après le cdrom.
Merci de tes réponses.
a+
:unamused:


#6

pour linux, c’est le disque déclaré comme disque de boot dans le bios qui est considèré comme hda, donc pas forcément le disque primaire.
Mais si tu as trop peur, débranches (ou desactives dans le bios) tes disques inutiles pendant ton install (je l’ai dèja fait moi même :slightly_smiling: ), puisque de toutes les manières, tu n’a pas à installer le boot loader ailleurs que sur ton disque debian.
Il suffira d’aller ajuster ton grub aprés l’install :slightly_smiling:


#7

Bonjour.
MattOTop.

Je crois que j’ai trouvé pourquoi mon disque n’apparait pas au partitionnement. Celui-ci se trouve en maitre sur une carte raid et debian ne doit pas apprécié???


#8

Ce n’est pas le pb dont tu parlais dans ton post précedent, il me semble…
je ne comprends pas, tu disais qu’il apparaissait en tant que hda ?
sinon, qu’a cela ne tienne: fais ton installe avec ton disque debian tout seul en ide primaire, et il sera toujours temps dans un deuxieme temps de tout remettre à la normale, et d’ajuster le boot.
et puis tu peux aussi essayer d’installer un pilote pour ton RAID lors de l’install, mais ca me semble plus aléatoire…


#9

bonjour
matOTop
Insallation réussi en primaire, mais ensuite pour repasser en normal mon lilone marche plus,j’'ai du booter avec le disque de mandrake et faire comme si je faisais une mise à jour, pour que jeretrouve lilo,mais impossible de demarrer windows, il fait rebooter, en ce moment je suis avec mandrake et maraid débranchée. Quid…,
A+


#10

il faut que tu “trompe” ton windows en lui faisant croire que tu as boote sur son disque.
ton entrée de lilo.conf pour ton windows doit ressembler à ca:

other=/dev/XXXX
      label=nt
      map-drive = 0x81
      to = 0x80
      map-drive = 0x80
      to = 0x81

ca, c’est si ton disque win est en premier, mais que tu boote sur ton lilo qui est sur le deuxieme.
pour ajuster a ta config (que je n’ai toujours pas tres bien compris et je m’en excuse), il faut que tu ajuste les mappages d’ordre des disques, en premant les bons codes (0x8?) sur la page suivantre:
howtos.linux.com/howtos/LILO-6.shtml


#11

bonsoir
matOtop
ma config
disque windows en maitre
disque mandake slave
disque debian sur raid désactivé
au démarage le bios se déroule bien
LILO
WINDOWS
LINUX
etc
quand je veux lancer windows la machine reboote
donc je n’ai plus d’accés a windows; Ca m’embetrai de reformater et de perdre toutes les données .
je lance linux ça démarre
:unamused:


#12

ben c’est ce que je dis, je peux pas tout te macher quand même :slightly_smiling: !

dans ton /etc/lilo.conf, tu cherches l’entrée “other” qui est censée te permettre de booter windows, et tu la modifies de la manière suivante (j’ai trouvé mieux qu’hier depuis en lisant ‘man lilo.conf’):

...
other=/dev/hdb1 
      label=WINDOWS
      boot-as = 0x80
...

ensuite, tu relilote, en tapant “lilo”. il va te faire un warning, mais c’est normal.

ca devrait marcher.

mais avec ca, quand tu dis que ca boote sous linux, tu peux booter ta mandrake ET ta debian ?

si tu veux qqchose d’encore plus propre, tu me donnes le lilo.conf de ta debian, et le lilo.conf actuel de ta mandrake, et on integre les deux…

mais pourquoi reformatter ? en changeant l’ordre du boot dans le bios pour booter sur C: au lieu de booter sur ton raid, tu rebootes sous windows, non ?

++