[Debian] Impossible de compiler sur Kdevelop


#1

Bonjour.

Je suis en train de recommencer des développements en C sur mon Dell Debian Sarge, en utilisant Kdevelop. Mais je n’arrive pas à compiler le moindre projet, (même un projet neuf C en console ne contenant que hello world), il me dit qu’il n’y a pas de makefile:
J’ai le message d’erreur intitulé “Fichier makefile non trouvé” et qui contient

Quand je faisait un build, j’avais affiché que kdevelop avait besoin automake 1.5, lorsque j’avais la 1.4. J’ai donc désinstallé automake 1.4 et kdevelop pour installer automake 1.6 et kdevelop ensuite. Je n’ai plus d’erreur à la construction mais toujours la même erreur à la compilation!

En attendant j’utilise kwrite, mais si vous saviez comment faire marcher kdevelop ça serait cool, ne serait-ce que pour le debugeur!

Merci de vos réponses :hello:


#2

J’ai tenté de prendre kdevelop3 de sid mais avec automake 1.6 ou 1.7 toujours pas moyen de compiler j’ai:

[quote]*cd “/home/tibo/tset3” && WANT_AUTOCONF_2_5=“1” WANT_AUTOMAKE_1_6=“1” make -f Makefile.cvs && mkdir “/home/tibo/tset3/debug” && cd “/home/tibo/tset3/debug” && CFLAGS="-O0 -g3" “/home/tibo/tset3/configure” --enable-debug=full && cd “/home/tibo/tset3/debug” && WANT_AUTOCONF_2_5=“1” WANT_AUTOMAKE_1_6=“1” make -k
**** Exited with status: 2 ***
[/quote]


#3

d’après le bug report de packages.debian.org/unstable/kde/kdevelop
je ne suis pas le seul à avoir ce prob. ce n’est donc pas de ma faute (pour une fois lol!).
J’ai parcouru les bug report sans trouver de solutions malheuresement…


#4

ça marche!
En fait il me manquait le paquet g++. Je trouve un peu curieux d’en avoir besoin puisque:
1- je n’ai fait que des projets en C console
2- il n’est pas cité dans les dépendance de kdevelop.
Enfin là ça marche enfin, ouf!
Merci de votre aide :jap: