[DEBIAN] kernel-headers-2.6.12-1-686


#21

En général, quand je sais quel flag activer/desactiver dans le .config, je me passe de retrouver l’option avec le menu de config.
En fait, ce que je n’ai pas vérifié, c’est si dans drivers/char/drm/ il y a quelque part mention d’un CONFIG_qqchose que tu aurais pu desactiver directement dans le .config
Sinon, l’option que je te disais doit bien être CONFIG_BROKEN=n, qu’on retrouve dans "Code maturity level options|Prompt for development and/or incomplete code/drivers|Select only drivers expected to compile cleanly.
Mais j’imagine qu’il faut que “Prompt for development and/or incomplete code” soit activé pour pouvoir activer le deuxiême (ce que tu semble avoir trouvé, donc).


#22

PS: je n’avais pas pensé qu’on pouvait mettre CONFIG_XXX=n, je croyais qu’il fallait le mettre en commentaire, mais tu m’apprends que c’est la même chose…


#23

c normal peut etre le packege i386 ?? j essaye de l installer ou pas :> ?
j’ai relancer une compilation avec un autre nom pour tester


#24

c’est normal: le nom (i386) veut juste dire qu’il est compilé pour un PC, mais pour savoir s’il est bien optimisé pour ton processeur, c’est dans “processor type and features” que tu le précises.


#25

salut a tous et surtout a mat qui est tres present , thx special a toi d aider des gros nul comme moi :>

suite a ta reponce, i386 c la meme chose que i686 ??
j’ai telecharger hier l instalateur de debian etch que je vien d installer (je fini mes petites modif, alsa, flex-old,mesa et les headers present d origine ^^), le probleme comme je l ai dit dans un post precedent c’est qu il m installe un noyau :

faut t il que je retente une compilation du noyau pour passez sur un kernel 2.6.12-1-686 ??
ou cela ne change rien (mais bon sous war3 ca rame alors qu avec un 686 ca ramer beaucoup moins)
bon j’ai bien capter la facon de proceder et je ne devrai pas etre embeter mais il y a t il des truc a modif sur la conf ? a part le changement de prosseceur et de cocher sur compile drivers only ?

j’ai une autre question, je voulait faire coohabiter les 2 versions (stable et testing) mais il a blocker au momment d installer grub, j’ai essayer avec expert26 en sautant l install de grub mais il veut pas :frowning: une idee de la maniere a suivre ?? installer un noyau que je met en stable avec apt.conf ?

merci encore :slightly_smiling:


#26

alors, mon gros nul préfèré :wink: , i386 n’est pas la même chose que i686. Mais quel que soit le choix de processeur que tu fais lors de la config du noyau, le paquet “kernel-image” que produit ta compilation sera toujours nommé “kernel-image…_i386.deb”, pour préciser que c’est destiné à un PC.
Par contre, ce n’est pas normal dans le résultat de uname -r, il aurait dû te dire que tu étais passé en 2.6.12-1-686, si tu as compilé et installé ce que tu as compilé.
Sinon, tu as vraiment besoin de recompiler ?
Parceque si tout ce que tu veux c’est installer un noyau compilé pour topn processeur et le module nvidia qui va avec, ca peut se faire bêtement avec apt-get.
Tu veux quoi précisément ?
Quel processeur as tu ?

2eme question:
Qu’est ce que tu veux dire par “faire cohabiter” ?
Si c’est installer tes deux distribs sur des partitions différentes, il faut installer le 2eme grub sur le mbr d’une des partitions (pas sur le mbr du disque), et ensuite, tu créeras une entrée dans le premier grub pour lancer le deuxiême grub.
Mais ca serait interressant que tu sois plus précis sur l’organisation de ton disque…


#27

whaaa comme tu flate bien xD

oui c bon j’ai resolut tout seul comme un grand mon probleme :slightly_smiling:
apt-get install linux-image-2.6.12-1-686 linux-headers-2.6.12-1-686

et voila now j ai un 686 :slightly_smiling: (tien je verifie…)

voilouuu :slightly_smiling:

mais par contre j ai un petit bleme la j’ai log nikel j ai ply a warcraft3 nikel avec quelque lag assez regulier (bizzare) le jeu se block pendant 1s et il repart nikel bref no probleme

en revenant sous mon bureau, j’ai voulut activer le serveur de son, j ai cochez la case activer le server de son et jouer un son pour chaque evenement, ensuite j ai clicker sur fermer et la paf plus rien qui repond :frowning:
j’ai donc fait un alt+ctl+backspace pour relancer le serveur graphique mais il boot pas, j’ai autoriser root a se loger sur x11 et je suis actuelement connecter avec root (pas bon ca v faire des betises …)
comment je peut desactiver l option que j ai cocher depuis le root ou je suis ?? ya un fichier preference quelque part ?


#28

déja, tu as peut être une session de type “failsafe” que tu peux utiliser au login, pour effectivement eviter les ennuis avec le compte ‘root’.
Ensuite, ca serait interressant de savoir quel wm tu utilises pout pouvoir te repondre, non ?


#29

wm ??

debian testing 2.6.12-1-686 avec alsa avec gnome 1.2.10

j ai repondu correctement ?

edit: youpiii j suis un grand posteur ^^

eme edit c’est bon j ai fouiller dans les paquet sous root et j ai installer tout les paquet avec gnome et alsa et c’est passer cool now j ai des son quand je click :slightly_smiling:


#30

Meuh non …
–>[code]burp:/usr/src/linux# grep DRM .config
CONFIG_DRM=y
CONFIG_DRM_TDFX=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m

CONFIG_DRM_MGA is not set

CONFIG_DRM_SIS=m
burp:/usr/src/linux#
[/code]
:laughing: