[DEBIAN] kernel-headers-2.6.12-1-686


#1

salut a tous,

bon ca fait un petit moment que je n’ai rien poster car j’ai ete occuper a telecharger et a lire pas mal sur les prochaines sorti de etch.

j’ai donc entreprit de telecharger la version etch en install direct mais je me suis heurter a un probleme ( et pas des moindre), il m install un system i386 alors que je possede un i686 :astonished:

j’ai donc reinstaller en stable en fesant BIEN gaffe au depedance et tout et tout ^^. j’ai recompiler un nouveau noyau avec le tuto a Ashgenesis (thx)
mais je n arrive toujours pas a construire mes kernel-headers dont j ai besoin pour les drivers nvidia.

j ai bien essayer avec l image mais il ne la trouve pas, faudrait il que j essaye avec un lien symbolique ?? (genre : ln -s /usr/src/kernel-image-2.6.12-1-686)

ya t il une simple commande pour construire les headers depuis le noyau ?? pour le faire, faut t’il que je soit loguer avec le kernel (2.6.12)dont je contruit les headers ou que je le construise depuis l ancien (je pense que je doit etre sous le nouveau mais je vouldrai etre sur de moi)

question en plus:
ou es que je pourrai acheter un bouquin dont tout le monde parle sur debian en francais ??? une adresse ? le nom ,titre et editeur ?


#2

Je te conseille celui-là :
http://www.amazon.fr/exec/obidos/ASIN/221211639X/qid=1133977365/sr=1-2/ref=sr_1_9_2/171-8002443-2200201


#3

hardcoffe, je ne sais pas ce que tu as lu, mais en tout cas pas les interventions sur ce site: toutes les reponses à tes problêmes y sont.
1/peu importe le noyau que tu as à l’install, aprés tu peux toujours en installer un spécifique avec apt-get.
2/ensuite si tu n’as pas de besoin de compiler ton noyau, alors pour nVidia installes le module assistant, tapes ‘m-a’ et laisses toi porter…
pour résumer: qu’est ce que tu te compliques la vie…


#4

salut a tous :stuck_out_tongue:

et bien mat c tres simple, parce que d’une: je veut apprendre TOUT (et ne me dit pas que c’est pas bien ^^), et de 2 j’ai lancer module-assistant et j obtient 4 ligne (overview,update,prepare et select ainsi que exit) et j ai fait un update puis un prepare et je lance select mais je ne voit pas le module qui m interesse :frowning: a savoir GLX de nvidia.
et pour finir j’etait vraiment satisfait de l install du nvidia installer :slightly_smiling:

petite news nvidia vien de sortir ses nouveaux drivers les 8174

edit:
en fermant modules-assistant , je voit ca:

je voit donc linux-headers-2.6.12-1-686 et c ceux que je cherche non ?? !!
j 'ai regarder dans /usr/src mais il n y sont pas :frowning: ils se trouve ou c petit fichier ? j’ai essayer avec find mais il se limite au repertoire courant et le --help est assez mal fait je trouve :stuck_out_tongue: (mais je sais, c’est aprce que je suis nul )


#5

nvidia-glx est un paquet comme les autres, que tu peux installer avec apt-get…
mais de toutes les manières, si tu fabriques module nvidia avec le module assistant, il va te signaler qu’il télécharge nvidia-glx pour satisfaire les dépendances du paquet/module nvidia, donc normalement, tu n’as même pas à t’en préoccuper.

Par ailleurs, je ne vais pas te jeter la pierre et contrairement à d’autre à qui je reproche de vouloir “construire une cathedrale sans apprendre à tailler une pierre” (désolé pour lui), je ne disais pas que tu t’attaquais à des problêmes trop dur pour toi: je disais juste que ce problême est SUR traité partout, et que tu peux en trouver au moins 10 traitements différents ici.
Désolé si je suis parfois un peu … caustique (mais ce que je propose n’est pas du doubitchou)… :laughing:
Edit: normalement, le “prepare” de m-a t’installe tout ce dont tu as besoin.
Normalement, il doit aussi te faire un lien “linux” qui pointe vers ce qu’il utilise pour compiler (les sources si tu les a installées, les headers qu’il a téléchargé automatiquement, sinon). Regardes vers quoi pointe linux, et tu trouvera normalement tes headers.


#6

find ne se limite pas au répertoire courant.
find / -name “headers” -print devrait te dire ou ils sont…
Mais ne t’en préoccupes pas pour l’instant, va jusqu’au bout du module assistant pour compiler le module nvidia…


#7

ben ca pointe la
/usr/src/linux-headers-2.6.12-1-686
mais le fichier n’y est pas :frowning:
je vait tenter une apt-get remove de ces headers en esperant qu il me les remette apres avec m-a


#8

mais non !
ce n’est pas un fichier, mais un répertoire.
as tu essayé de faire un bête “cd” dans ce répertoire ?
PS: si tu veux absolument reinstaller ces headers, tu peux faire un apt-get install --reinstall


#9

oui c’est bon je les ai reinstaller (le repertoire n exister pas je sais quand meme reconnaitre un rep d unfichier :stuck_out_tongue: )
quand je lance:

sh NVIDIA-Linux-x86-1.0-8174-pkg1.run --kernel-source-path /usrc/src/linux-headers-2.6.12-1-686

il me dit qu il ne trouve pas le kernel.h , j’ai verifier et il s’ trouve bien :frowning:

je n’ai pas installer les nvidia-glx car en meme temp il me precise que ce paquet est fait pour un kernel 2.4 , puis-je l installer sans probleme ? cela ne va pas me porter prejudice , il va s update pour mon kernel tout seul commme un grand ?


#10

Bon, puisque tu n’ecoutes rien, je te laisse te démerder…
Bonne chance tout de même :wink:


#11

j’ai fait comme tu m a dit;
installer les glx run m-a j ai selectionner le seul paquet nvidia apparaisant a savoir nvidia-kernel (pas de glx ), j’ai fait un update et apres list voila a list mon message:

desoler pour mon ignorance j’avait pas eu de probleme avant vu que j avait les headers


#12

Bon, le problême, c’est que le noyau que tu utilises n’est plus disponible en binaire (kernel-image)…
As tu insisté et fait quand même le “prepare” et le “select” ?


#13

vouivoui j 'ai meme fait le build :frowning: mais ca marche pas
j’ai entreprit de recompiler a nouveau le kernel avec un cette methode la:
http://www.gcolpart.com/howto/kernel.php4#debian

vu que je pensais que tu m avais lachement abandonner :cry:


#14

Pas trop mal à première vue, sauf que ca ne va pas marcher, à cause de l’initrd.
Pour comprendre ce que je veux dire:
forum.debian-fr.org/viewtopic.php?t=1806


#15

j’ai redemander une precision sur le message pour etre sur de pas comprendre de travers :neutral_face:


#16

j’ai fait exactement ce qui est marquer dans le post pour compiler le kernel
j’ai utiliser
cp /boot/config-2.6.8-2-686 /usr/src/linux
ensuite
make-kpkg --append-to-version “compiled” --initrd kernel_image modules_image kernel_headers

et paf je suis maudit

j’ai lut que initrd, s’etait pour bien boot sur les disk dur ok, mais moi j’ai un SATA es que l option change ou c’est toujours la meme ??
hier j’ai compiler avec la methode (lien plus haut) et j y suis arriver, j’ai reussi a avoir les 3 packages sauf que des le boot j’ai un kernel panic :’( donc ca doit venir du initrd que je n avait pas mit non?

bonne appetito a touti :smiley:


#17

[quote=“hardcoffee”]j’ai fait exactement ce qui est marquer dans le post pour compiler le kernel
j’ai utiliser
cp /boot/config-2.6.8-2-686 /usr/src/linux
[/quote]cp /boot/config-2.6.8-2-686 /usr/src/linux/.config, tu veux dire ?

[quote=“hardcoffee”]ensuite
make-kpkg --append-to-version “compiled” --initrd kernel_image modules_image kernel_headers

et paf je suis maudit

[quote]
drivers/char/drm/gamma_drv.c:56:22: erreur: drm_proc.h : Aucun fichier ou répertoire de ce type
drivers/char/drm/gamma_drv.c:57:20: erreur: drm_vm.h : Aucun fichier ou répertoire de ce type
drivers/char/drm/gamma_drv.c:58:22: erreur: drm_stub.h : Aucun fichier ou répertoire de ce type
drivers/char/drm/gamma_drv.c:59:25: erreur: drm_scatter.h : Aucun fichier ou répertoire de ce type
make[4]: *** [drivers/char/drm/gamma_drv.o] Erreur 1
make[3]: *** [drivers/char/drm] Erreur 2
make[2]: *** [drivers/char] Erreur 2
make[1]: *** [drivers] Erreur 2
make[1]: Leaving directory `/usr/src/kernel-source-2.6.12’
make: *** [stamp-build] Erreur 2
debian-stable:/usr/src/linux#
[/quote][/quote]
trouves le pilote qui plante dans les pilotes du coté de bloc-devices, et désactives le. Tu as bien coché la case “only drivers …” dans la config générale ?

[quote=“hardcoffee”]j’ai lut que initrd, s’etait pour bien boot sur les disk dur ok, mais moi j’ai un SATA es que l option change ou c’est toujours la meme ??
hier j’ai compiler avec la methode (lien plus haut) et j y suis arriver, j’ai reussi a avoir les 3 packages sauf que des le boot j’ai un kernel panic :’( donc ca doit venir du initrd que je n avait pas mit non?

bonne appetito a touti :smiley:[/quote]absolument, SATA ou PATA, si tu ne mets pas le pilote en dur dans le noyau et que tu oublies l’initrd->kernel panic…


#18

cp /boot/config-2.6.8-2-686 /usr/src/linux/.config, tu veux dire ?
oui j’ai verifier avec les fleches du haut (remonter dans la console) c bien ca j’ai mit linux/.config :slightly_smiling:

trouves le pilote qui plante (la je vait en avoir pour 1 semaine lol)

Tu as bien coché la case "only drivers … humm je vait voirr…

ahhh tien en cherchant je voit qu il m a mit le sale emuk21 pour sound blaster (or j’ai lut qu il ne faut surtout pas que je l utilise, car j ai une live24bit apparanter a une ls drivers CA0106) donc hop changer :stuck_out_tongue:

ca y est j’ai trouver block-devices
select only drivers est cocher

ben je voit pas le drivers qui block , comment je peut savoir a quoi il correspond ?? et puis le code donnerje ne sais pas trop a quoi il sert :’(


#19

Le code peut te servir a faire des recherches, mais à part si tu es fort en C/C++ et noyau…
Pour ce qui est de trouver le bon module à desactiver, je n’ai pas encore trouvé de methode…
Mais je vais voir si une idée que j’ai se verifie et je te dis (en attendant, je vais mettre mon bb au lit et mefaire à manger)…


#20

encherchant un peu j’ai trouver un reponce ou le gas avait la meme erreur que moi:
http://www.andesi.org/forum/viewtopic.php?t=4187&postdays=0&postorder=asc&start=0&sid=cf783675fa70f5c07374114dc88600eb

j’ai ajouter CONFIG_BROKEN=n en editant mon config car il n y etait pas dans le choix des option je suis en train de recompiler en ce moment meme,
et j’ai aussi cochez la case only drivers (j’en ai vu 2 en fait l une etait cochez l autre non donc j’ai cochez les 2)

je te tien au courant et merci encore :slightly_smiling:

bon ca y est ca marche en mettant CONFIG_BROKEN=n mais ca m enerve il m a construit un package en i386 et non en i686 !!! c’est quoi ce B… !!
je vait retenter de compiler en selectionant dans proces dans le .config…