Debian ne démarre plus suite à mise à jour du bios

Tags: #<Tag:0x00007fae527e20b8>

Bonjour,
J’ai un PC HP construit en fin d’année 2019, à l’origine il y avait un Windows 10, je l’ai remplacé par une Debian 10.
Hier j’ai mis à jour le BIOS du système en restaurant le Windows et en exécutant la procédure HP, tout s’est très bien passé.
J’ai restauré la Debian, sauvegardé au préalable par Clonezilla, la restauration s’est bien passé aussi mais le système de démarre plus (no bootable device found)
J’ai remonté tous les FS en mode rescue avec systemrescuecd :

/dev/vgsys/lvroot /media
/dev/vgsys/lvboot /media/boot
/dev/sdb1 /media/boot/efi
/dev/vgsys/lvvar /media/var
/dev/vgsys/lvtmp /media/tmp
/dev/vgsys/lvhome /media/home
mount --bind /dev /media/dev
mount --bind /sys /media/sys
mount --bind /proc /media /proc

chroot /media

Je voudrais savoir comment re-installer grub sachant que mon /boot se trouve sur du lvm.
La commande
grub-install /dev/sdb
retourne l’erreur
« /usr/lib/grub/i386-pc/modinfo.sh doesn't exist »
je pense parce que le répertoire boot se trouve sur du lvm.

Pour info après la mise à jour du BIOS la procédure automatique a mis à jour le bootblock de Windows, je pense que c’est pour cela que je dois ré-installé le grub avec la nouvelle version du bios.

Merci.

Willy

Si la partition EFI est montée sur /boot/efi, alors ton système Debian est installé pour l’amorçage EFI. A mon avis c’est une connerie étant donnée tous les bugs dont l’UEFI est affligé, mais chacun fait comme il veut.

Il est possible que la mise à jour du firmware UEFI (ce n’est plus un BIOS) ait effacé la variable de boot de Debian. Mais pour la recréer, il faut amorcer en mode EFI. Or grub-install recherche quelque chose lié à i386-pc, donc il essaie d’installer GRUB pour l’amorçage BIOS et non pour l’amorçage EFI, ce qui indique que ton système live a démarré en mode BIOS.

Tu as trois options :

  1. Te débrouiller pour démarrer en mode EFI puis exécuter grub-install sans paramètre pour recréer la variable de boot EFI.

  2. Exécuter

    grub-install --target=x86_64-efi --force-extra-removable --no-nvram
    

    qui va installer une copie de GRUB pour l’amorçage EFI dans un emplacement qui n’a pas besoin de variable de boot.

  3. Installer GRUB pour l’amorçage BIOS. Pour cela si la table de partition est au format GPT il faudra d’abord créer une toute petite partition de type « BIOS boot » (100 ko suffisent) dans l’espace libre du disque (par exemple le Mo situé avant la première partition), pas besoin d’alignement, puis installer le paquet grub-pc et sélectionner le MBR du disque. Certains firmwares HP son buggés et refusent de booter si aucune partition du MBR n’a le drapeau « boot », ça se corrige avec fdisk ou parted.

Merci Pascal pour ta réponse, je viens de résoudre mon problème, à la procédure que j’ai donné au début de ce post j’ai ajouté les commandes ci-dessous:
exit => pour sortir du chroot

mount --bind /run  /media/run
mount --bind /sys/firmware/efi/efivars /media/sys/firmware/efi/efivars
chroot /media
grub-install  --target=x86_64-efi  --efi-directory=/boot/efi
update-grub

Le système démarre nickel maintenant.
Je verrais à la longue si les problèmes de ventilo CPU (tourne assez souvent maintenant alors que pendant 6 mois il était presque muet) et de consommation de batterie sont résolus avec cette nouvelle version du bios.

Willy