[Debian] Problème à l'installation des pilotes graphique Nvi


#1

Bonjour.

Sur mon AthlonXP j’ai une Geforce3. Depuis quelques temps je n’installait plus les pilotes Nvidia. Mais le besoin OpenGL se faisant sentir, je dois les réinstaller.
Tentative 1: Mon kernel 2.6.6 fraichement installé, je lance le script des pilotes 53.36. Celui-ci m’indique que la version de compilateur ne correspond pas, comme il me le signalait autrefois sans que cela pose de problèmes. Mais juste après la compilation il me signale qu’il ne trouve pas le module nvidia.ko. C’est curieux car les sources de mon kernel sont bien dans /usr/src/linux
Tentative 2: Je me dis qu’après tout les cripts c’est moyen, autant utiliser des paquet Debian. Je lance le script une dernière fois avec comme paramètre --uninstall puis je fais apt-get install nvidia-kernel-source et nvidia-kernel-common. Je décompresse le nvidia-kernel-source, va dans les sources de mon kernel et tappe make-kpkg modules-image
La compil se passe bien, le paquet est crée et s’installe. Je modifie XF68config avec nvidia mais le serveur X ne se lance plus dans indiquer de message d’erreur. J’ai refait une compilation des modules en faisant un EXPORT CC=gcc-2.95 mais le résultat est le même.

Que faire? merci de votre aide.


#2

je que j’ai fait de mon cote , apres un mois de galere
j’ai telecharge les pilotes proprietaires directement chez nvidia
et ca sa marche et c’est rapide meme si ce n’est pas tres libre


#3

Je n’ai laissé que les paquet nvidia-kernel-source et nvidia-kernel-common, utilisé le script .run et ça marche!

Ce qui est un peu dommage c’est que je n’arrive pas à faire fonctionner les pilotes nvidia sous forme de package debian: ça serait plus simple et plus propre à faire fonctionner!

Voila merci de votre aide


#4

Je viens de réussir de faire marcher les pilotes propriétaires par la méthode paquet Debian!
En fait il faut installer nvidia-kernel-common, puis le nvidia-kernel-2.6.6 compilé à la main et enfin nvidia-glx. Avantage de cette situation: C’est plus propre, après un nouveau kernel on n’a a recompiler que le nvidia-kernel-2.6.x, et pas besoin de rebooter une fois sur le nouveau kernel pour compiler.
J’ai eu des conflits entre les lib installés par les paquets et ceux installés par le script nvidia, je vous conseille donc fortement de faire un uninstall du script avant de vous lancer là-dedans. Autre prob que j’aie eu concerne les dépendances du nvidia-glx, qui quand il n’avait pas le nvidia-kernel-2.6.x installait le nvidia-kernel-2.4.25 ça foutait aussi le bordel!

Donc voila j’ai réussi à faire marcher tout comme je voulais, merci de votre aide!


#5

vous dites propriétaires, mais il me semble que nvidia-kernel et nvidia-glx ne le sont pas, ou est-ce que je me trompe.
en fait, s’ils le sont , cela voudrait dire que je devrais installer d’autres oilotes(libres) s’ils existent.


#6

oui ils sont propriétaires. Tu veux que du libre sur ta distro?