Debutant debian, installation


#21

as tu au moins testé ton internet ?

??? quand j’essaye de faire les apt par le net y me renvoie une erreur comme quoi il a pas pu se connecter

s"il a reconnu tes cartes réseaux, alors tu es DEJA sur le net. c’est par elles qu’il passe pour atteindre le net, et pas par un dispositif de type modem qui serait connecté à ta machine. il se trouve que sur ton réseau, ce que tu appelles un “modem DHCP” et qui est en fait un routeur, va prendre les paquets que tu envoerras verrs l’internet et les transmettre avec ses petites mains vers leur destinataire internet…

je suis pas deja sur le net vu que je peux pas faire les maj securités

as tu, modem branché, machine allumée, essayé un
ping yahoo.fr
ou un
ping 217.12.3.11 ?
comme je te l’ai conseillé il y a qques tps ?

je dois faire ca en console ? commnt dois proceder ?

dsl d’etre aussi lourdingue mùais quand on sais pas on sais pas :blush:
sinon ia64 c pour les poss 64 bits ? merci


#22

exactement, tu va commencer par travailler en console.
tu te logues, et tu tapes les ping (ctrl+c, pour arrèter de pinger).
sinon, il faudrait savoir si, même détectées, tes cartes réseau sont bien configurées. pareil tu lances la commande ‘ifconfig’. et tu notes le résultat.
pour l’instant, il va falloir faire tout en mode console.
enfin, si tu as un pote qui peut passer…


#23

sinon pour ia64 c bien pour les amd64 ?
car y a une sarge ia64


#24

non, c’est pour les architecture intel.
quels que soit ton architecture, voici la page de ports debian:
debian.org/ports/index.fr.html
pour toi, c’est
debian.org/ports/amd64/


#25

ok

mais le pb c’est que j’ai dl les cd sur : ftp.acc.umu.se/pub/cd-images/debian-weekly/i386/

mais apres les 15 cds j’ai meme pas d’interface graphique ( comme dit precedement ) et quand je veux l’install apt( je sais pu trop koi ) install kde y me dit que les paquetages ne peuvent etre installés ou ne sont pas installables

les images sont bonnes ou pas ???


#26

oui et non, je crois. J’ai regardé: ce que tu as tèl, c’est l’integrale pour intel386, pas pour amd64. C’est à dire que les binaires principaux comme le noyau, et quelques autres trucs doivent fonctionner parcequ’il sont génériques, mais à un moment, ca devient trop spécifique, et ca ne passe plus… donc oublies ton install actuelle.
par contre, en suivant les liens que je t’avais donnés, j’ai trouvé sur

alioth.debian.org/docman/view.p … stallation

l’adresse des >bonnes< isos (puisque tu insistes pour passer par du gravage):

debian-amd64.alioth.debian.org/d … r/current/

je te conseilles la version netinst: tu graves UNE iso, qui sert à booter sur le net, et ensuite tout s’installe en ligne. tu commences la config, et une fois que tu vois que les downloads sont lances, tu va te coucher. le lendemain, ta machine est prète.


#27

donc je vais la debian-amd64.alioth.debian.org/d … t/netboot/

et je prend mini iso ?

mais de tt facon ca va pas encore aller vu que mon modem deconne sous debian ( enfin veut pas etre reconnu , comme precedemment ,non ?)


#28

encore une fois, si comme tu le dis, tu n’as eu AUCUNE configuration à faire, il DOIT en etre de même sous linux.
de toutes les manieres essayes: ca coute quoi ? un CD …


#29

un modem ethernet? je supose donc que tu es en adsl

pour configurer le modem il faut lancer la commande pppoeconf
( assure toi que le module pour la carte reseau soit bien lancé, dans le cas contraire utilise modconf pour le faire)

avec un editeur de texte edite ton fichier /etc/apt/source.lists et ajoute
deb ftp://ftp.fr.debian.org/debian testing main contrib non-free

ensuite un petit apt-get update et apt-get install nom du paquet


#30

petite precision certain modem peuvent etre utilisé comme routeur
ce qui a deja ete dit plus haut
pour ma part un dlink DSL300G+ peut etre utilisé en pppoe
ou configurer via un interface web en tant que routeur

si ton modem et regle en tant que routeur
tu doit metre ta carte ethernet en dhcp
ajoute sa a /etc/network/interfaces
auto eth0
iface eth0 inet dhcp

Note Perso:
personellment je ne te conseil pas d’installer les 15 cd comme tu a visiblement fait mais uniquement le 1er sans installer de paquet suplementaire
cela te donnera au final un linux minimal en mode console
a pres reste juste a installer les paquet dont tu as besoin avec apt-get
apres avois solutionner ton probleme de modem bien sur!


#31

yo keneda2k, c ce ke j’essayais de transmettre, mais comme Genux888 n’a pas l’air tres à l’aise avec le technique, je tenteis d’y aller mollo sur le jargon.
D’aprés ce qu’il dit, ca sent le cas “modem en config routeur” (même pas de config pppoe à faire sous win, d’aprés ce qu’il dit).
Partant du principe que sa config eth est deja en dhcp, et présumant que ses problemes d’interface X ne sont pas liés à l’absence des paquets (15 CD il doit y avoir ce qu’il faut la dessus), il y a je pense un pb plus général qu’une mauvaise config.
Un pb de compatibilité des binaires ? je me proposais d’accompagner Genux888 vers une netinst d’une version alioth/amd64 …
Mais je ne connais pas le niveau de compatibilité des paquetages. La dessus, si quelqu’un a des conseils…


#32

moi je suis en 32b donc les 64 je ne connais pas trop
mais en fait y’a un truc qui me parait bizard dans cette histoire

Genux888 a écrit:

cela ne me parait pas tres logique, lors de l’instalation debian il scan tous les paquet present sur le cd et demande si il y a d’autre cd a scanner
ni plus ni moin que apt-cdrom add en fait
dans ce cas un apt-get install paquet devrai demander un truc du genre insert binary 4 ou 1 ou 3

ce qui me donne quelques doute sur l’installation de depart
pas d’interface graphique?
pour commencer Xfree est il bien configurer ?
quand tu fait X xfree se lance t’il correctement ?

Ce que je te conseil:

A- reinstaller un linux minimal comme dit dans mon precedant message

B- apres 2 solution:
Solution1: solutionner le problemme internet et installer les paquet via internet (recommander)
Solution2: utiliser la commande apt-cdrom add pour rentre les 15 cd de la distrib dans le sources.liste et installer les paquet via les cdrom

C- installer X

apt-get install x-window-system-corelancer la commande X pour vois si Xfree fonctionne

D installer l’environement graphique apt-get install kdm kde

Bon courage !


#33

sincerement ?
s’il y a un truc qui à failli me faire passer à coté de debian, à l’époque, c’etait l’impossibilité d’obtenir une install aussi fluide que tu dis avec une install sur cd.
Peut etre que maintenant, je réussirais à configurer un peu mieux mon apt-cdrom pour que ca marche comme tu le dis, mais je dois dire que depuis que j’ai découvert debootstrap, l’install sur CD rom me parait une technologie de l’age de pierre.


#34

ggrrrrr j’enrage j’ai dl la slackware 10.0, j’install normal et au moment de l’install du kernel les donnés sont erronées ou je c pu trop quoi, est ce pour cela que j’ai encore pas d’interface graphique :imp:

sinon y a quoi comme distrib gratuite qui gere le 64 bits car y a la mandrake mais 450€ faut pas pousser !!!

la woody gere les 64 bits non ? la slakware 10.0 aussi non ?

quand vous parlez de net install, faut 2 pcs en fait ( partage connection ) ?


#35

bon, genux888, je me résume:
tu as un modem/routeur adsl “DHCP” qui prend tout en charge sous windows, donc concernant ta connection ADSL, il suffit que ta carte réseau fonctionne en client dhcp sur ton routeur, et tu es sur l’internet.
Ca ca simplifie un peu les choses…
Tu es en amd64, et même s’il existe un mode de compatibilité avec le 486, les programmes “486” n’ont pas l’air d’etre ideaux pour toi. Pas de réseau, pas de X-windows :frowning: .
Ca complique un peu les choses.
C’est pour ca que je t’ai indiqué plus haut un lien vers une iso de 4 Mo pour faire une installation d’une distrib dédiée à ton processeur, en chopant tous les éléments directement sur internet.
As tu au moins essayé de démarrer comme ca ?
La slack, c’est une bonne distrib, mais pour hardcore hackers, dc comme tu n’as pas l’air trés “calé”, si tu veux installer une distrib en 64 bits, la debian alioth me semble plus indiquée (compromis technique pointu/user friendly).
Il faut que tu te mettes en tete que quelle que soit la distrib que tu teste, la strategie a suivre, c’est d’installer le minimum pour démarrer (donc pas une suite de 15 CD) et d’installer tout le reste en ligne dès que tu as l’internet: tu auras les derniers paquets, à jour et tout…
sinon, si tu as un livecd (genre gentoo ou knoppix) qui marche bien avec ton processeur et l’adsl, il y a moyen d’installer une debian totalement en ligne. C’est comme ca que j’installe mes machines, et ca marche bien.
Je repose la question: as tu telechargé, gravé, et testé, le cd d’install réseau de la debian alioth sur
debian-amd64.alioth.debian.org/d … t/mini.iso


#36

non pas encore et la en + je me barre durant 4j pour un demenagement super non :imp: !!!
sinon y aura une version 64 de la sarge ?

j’essayerais le miniso des que je reviendrais

franchement je suis deg, car au debut j’ai dl la mdk pour initier un pote ( layant deja eu sur un ancien pc ) et lui je l’install nickel et moi marche pas.
en plus je crois il l’utilise meme pas, grrr la vie est injuste.

sinon la slack fonctionne sur des 64 bits ?


#37

la slack ? certainement, mais si tu avais un peu lu ce que je t’ai écrit, le mini iso que je t’ai indiqué est SPECIFIQUE amd64 :slightly_smiling:
je te conseilles de faire une installe mini, et de revenir pour des infos sur apt-build, parceque le 64 bits, c’est jeune, tout de même :laughing:


#38

Genux888, il faut que tu comprenne que ton probleme ne vien pas de la distrib que tu utilise mais de ton architecture (amd64) qui est specific
tu poura changer de distribution autant que tu voudra si celle ci n’est pas adapté a ton achitecture tu rencontrera des problemes certainment similaire!

comme te la dit MattOTop il existe visiblement un port debian pour l’architecure amd64, elle semble donc etre un bon choix

et derniere chose, lit et suis ce que l’on te dit
si tu ne suis pas nos conseils pour voirs si sa resout ton problem
sa sert a rien de poster sur le forum


#39

voila j’ai acheté un nouveau modem qui fonctionne normalment avec deiban, j’ai donc fait la mise a jour des paquets
cependant serverX n’arrive pas a demarrer

il y a un pb avec xfree

je voulais mettre des photos avec la webcam mais trop vilain
debian dl des nouveaux paquetages
si vous avez une solution malgré le peu d’information

merci

je repasse apres


#40

(EE) No devies detecter

Fatal server error :
no screens found

When reporting a problem related to a server crash, please send the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log"
Please report problems to submit@bugs.debian.org.

XIO: fatal IO 104 (Connection reset bu peer ) on X server " 0.0’" after 0 requests (0 know processed ) with 0 events remaining.

voila ce que j’ai :blush: :blush: