(Débutant perdu) Installateur firefox


#1

Bonjour

Je suis sur linux depuis 15 jours et je nage vraiment beaucoup.

J’ai installé la dernière version stable de Debian (la sarge de début juin), puis Fluxbox qui fonctionne bien (enfin je crois, puisque le mode graphique apparait).

Je voudrais installer la dernière version de Firefox grace à l’installateur.

J’ai téléchagé firefox-1.0.6.installer.tar.gz sur /tmp et je l’ai décompressé par “tar xvjf”, ce qui a créé un répertoire firefox-installer.

Je lance ./firefox-installer (ou ./firefox-installe-bin), et j’ai le message suivant :
(firefox-installer-bin:1611): Gtk-WARNING **: cannot open display:

Quelqu’un peut-il m’aider ? Désolé si la question est peut-être stupide ou évidente…

Merci de votre aide


#2

bonjour,
tu as decompréssé ton tar, il ta créé ton repertoire firefox-installer, ensuite tu lances la commande ./firefox-installer. Mais t’es tu “mis” dans le fichier firefox-installer avant de lancer la derniere commande? A savoir cd /le/fichier/ou/setrouve/firefox-installer. je dis cela car la commande cd n’apparait pas dans ton post.
bon courage


#3

Après le tar, je me suis positionné dans firefox-installer avec cd.

En faisant des recherches, il m’a semblé comprendre qu’il ne faut pas lancer l’installeur avec root, mais avec un autre utilisateur.

Donc j’ai fait “su utilisateur”, et lancé l’install, et même message.


#4

tu peux etre en utilisateur pour tar, cd, …,mais il te faut etre en root pour installer. heu," su utilisateur", tu veux dire “su mot de passe”, je pense?
mais si tu n’y arrive pas en tarball, on peux toujours le faire via les sources-list et tu aura firefox en version 1.0.6


#5

J’ai suivi les indications présentes sur la liste de diffusion Debian :

en root (dans le répertoire d’install de firefox):
export DISPLAY=’:0.0’
./firefox-installer-bin

et toujours le même message.

Si j’ai bien compris, c’est un problème avec le serveur X.

L’erreur peut-elle venir de l’install de X-window, car j’ai installé X-window-system-core et non X-window-system ?


#6

je ne pense pas que x-window soit responsable, mais j’avoue ne pas être suffisement calé (personnellement j’ai installé x-windox-system-core).
moi j’avais installé firefox 1.0.4 par apt, puis j’ai édité mon fichier sources-list en y ajoutant ceci: deb debian.stdout.at/ ./
ensuite apt-get update, puis apt-get upgrade, et hop firefox version 1.0.6


#7

Merci pour ta réponse.

Je crois que je vais faire comme toi, mais j’aimerai bien comprendre pourquoi ca ne marche pas… J’suis têtu…


#8

je te comprend et je pense que tu as tout fait raison.
Pour insister sur les tarball je te conseille de lire fichier readme qui se trouve dans ton dossier firefox-installer. Je n’ai pas installé de tarball sous debian mais auparavant sur mandrake, et de mémoire l’installation en root se faisait par: firefox-installer/firefox/installer
Sa ne coute rien d’essayer
bonne soirée, et à ta disposition si tu veux un coup de main pour editer ton sources-list.


#9

Ouaip ca c’est bon

normal :0.0 c’est ton localhost :unamused:
alors a moins ke tu installes firefox sur un hote distant tu n’as pas a changer cette valeur

effectivement…
donc rien a voir avec l’install de firefox, de droits, de root, tout ca tout ca

test et tu auras la reponse a ta question!