Debutante erreur XI0


#1

bonjour à tous,

j’ai un petit soucis je démarre sous linux, j’ai installé debian etch version2.6.15-8
et lorsque je tape startx j’ai un message d’erreur :

fatal server error : no screens found
XI0 fatal error 104 (connection server reset by peer) on X server "0.0"
after 0request (0known processed) with 0 events remainning

j’ai retaper la commande
dpkg-reconfigure xserver-xorg
mais j’ai toujours le même message :blush:

quelqu’un peut-il me venir en aide dans ma première installe merci beaucouq


#2

regarde le fichier de log Xorg:

cat /var/log/Xorg.0.log

et colle le ici,

A+,


#3

merci de m avoir répondu :smiley:

je suis en mode root
je tape la commande cat/var/log/Xorg.0.log
-bash: cat/var/log/Xorg.0.log : aucun fichier ou répertoire de ce type
et si je tape cat (seul) le curseur clignote mais rien ne se passe

:question:


#4

il faut mettre un espace entre cat (la commande) et le fichier /var/log/Xorg.0.log.

La commande cat ne rend pas la main avant EOF (End of File) qui peut être provoqué au clavier par la combinaison de touches Contol D.

(Ou Control C provoquera un SIG KILL)


#5

ABI class : X.org Video driver, version 0.8
(II)loadmodule: “keyboard”
(II) loading /usr/X11R6/lib/modules/imput/keyboard_drv.so
(II)module keyboard: vendor="X.Org Foundation"
compiled for 6.9.0, module version = 1.0.0
module class: X.Org XImput Driver
ABI class: X.Org XImput driver, version 0.5
(II)loadModule:“mouse”
(II)loading /usr/X11R6/lib/modules/imput/mouse_drv.so
(II)Module mouse: vendor="X.Org Foundation"
compiled for 6.9.0 module version = 1.0.3
module class: XOrg XImput Driver
ABI class: X.Org XImput friver, version 0.5
(EE) No drivers available

Fatal server error:
no screens found
please consult the the X.Org Foundation support
at wiki.X.Org
for help.
please also check the log file at "/var/log/Xorg.0.log

voila ce qu’il m’indique lorsque je tape :
cat /var/log/Xorg.0.log
il me ramène au message d erreur du départ

apparamment je ne peux accèder au fichier /var/log/Xorg.0.log

je suis allez sur http// wiki.X.Irg mais c’est en anglais je comprends rien je ne vois pas de ligne de commande :question:


#6

quote=“poussy92” No drivers available

Fatal server error:
no screens found
[/quote]

Il semble qu’il y ait peut-être un problème de pilote. Le “no screens found” se rencontre aussi à chaque fois que la carte graphique n’est pas bien reconnue.

Essayer d’éditer le fichier /etc/X11/xorg.conf puisque c’est du etch en root

nano /etc/X11/xorg.conf

et dans la section device remplacer le driver par vesa

[quote]Section "Device"
Identifier "le_nom_de_la_carte_vidéo"
Driver “vesa”
(-> il peut ici y avoir encore autre chose)
EndSection[/quote]
Toutes les cartes sont compatibles vesa : l’affichage ne sera pas optimisé, mais le pilote de la carte ne pose pas problème.
Restera à trouver ensuite un pilote plus adapté :
radeon pour les ati radeon
nv pour les nvidia geforce (qui ne fonctionne pas avec ma 6200)
ou autre suivant la puce de la carte vidéo

Bon courage


#7

merci ginkgo biloba de m’avoir répondu

bon j’ai essayé cela ne fonctionne pas lorsque le pc redémarre j’ai les voyants de mon écran qui clignotent et ecran noir

c’est bizarre tout de même on m’a prêter 2 dvd debian sarge3.1 j’arrive à installer car il me demande de confiugurer pleins de paramètre mais sur debian etch j’ai pas le mode graphique ??


#8

Fais voir ton fichier /etc/X11/xorg.conf

Je pense que ça peut venir d’un mauvais paramètre de la fréquence de rafraichissement horizontale, essaye de l’augmenter.


#9

Quand on installe directement en etch, on a comme environnement graphique gnome. C’était le cas lorque j’ai fait ce type d’install. Comme on passe directement en etch, les développeiurs debian doivent considérer qu’on peut ensuite installer tout seul les paquets dont on a besoin.

Si c’est ta première installation de debian, je me permets de conseiller le tuto de trucs et astuce qui parle de l’installation d’une debian “Installer Debian 3.1”:
forum.debian-fr.org/viewtopic.php?t=1684
Des conseils sont donnés pour installer directement etch et les environnement graphique kde et gnome

pour le paramétrage de mon moniteur lcd c’est

[quote]Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection
[/quote]
en 1024x768 par exemple
C’est à adapter à ton moniteur


#10

je suis dans nano /etc/X11/xorg.conf

la ligne de commande à l’écran cp /etc/X11/xorg.conf
/etc/X11/xorg.conf .custom
md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.confmd5sum
dpkg-reconfigutr xserver-xorg

je sais pas si c’est ce que tu me demande :blush:
sinon dans device j’ai

monitor : ecran générique
option : "DPMS"
HorizSync 30-90
vertrefresh 50-70

dans “screen” :
identifier : "default screen"
device "Nvidia corporation NV18 (geforce4 mx 440 agp 8x)
monitor : ecran generique
defaultDepth : 24
subsection "display"
Depth 1
Modes “1920x1440” “1600x1200” “1280x768” “1024x768” "$

dans endsubsection
Depth 4 et le mode c’est la même config que depth 1

et ensuite Depth 8

je viens de l augmenter j’ai mis 50-90et il m indique toujours la meme erreur

voilà si cela peut t aider merci encore :


#11

je viens de mettre en rafraichissement la même config que toi ginkgo mais ça ne fonctionne pas j’ai toujours no screens found
j’ai un écran crt 15" je vais allez faire un tour sur le site que tu m’as communiqué merci

je suis allée allez voir mais c’est bien ce que j’ai fait au niveau de la procédure d’install :cry:

alors y a du nouveau :stuck_out_tongue:

j’ai refait un apt-get reconfigure
j’ai désactiver quelques trucs

maintenant j’ai enfin le mode grahique mais dans une petite fenêtre et j’ai un message d’erreur :

erreur-artsmessage

sound serverfatal error- (ce message revient constamment

cpu overload.aborting

je vais dans les paramètres d’affichage mais je suis en 1280 et lorque je change la fenêtre est très grosse –


#12

[quote=“poussy92”]je suis dans nano /etc/X11/xorg.conf

la ligne de commande à l’écran cp /etc/X11/xorg.conf
/etc/X11/xorg.conf .custom
md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.confmd5sum
dpkg-reconfigutr xserver-xorg

je sais pas si c’est ce que tu me demande[/quote]

nano est un éditeur de texte qui fonctinne en console et qui est installé par défaut au départ.
A l’écran il doit y avoir le contenu du ficjer de configuration de xorg
Pour pouvoir l’éditer et le modifier il faut avoir les droits root. Comme sudo n’est pas configuré au départ, il faut utiliser su (les $ et # ne sont pas à taper, ils indiquent que l’on est utilisateur ou avec des froits root) :
$ su
le_mot_de_passe_root

nano /etc/X11/xorg.conf

faire des modifications
sauvegarderles commandes sont indiquées en bas de l’écran, ^ voulant dire qu’il faut taper la touche Ctrl simultanément

[quote]sinon dans device j’ai

monitor : ecran générique
option : "DPMS"
HorizSync 30-90
vertrefresh 50-70
[/quote]

J’ai revonfiguré mon affichage pour 800x600 avec dpkg-reconfigure et cela a donné dans mon xorg.conf

Le nv devrait être valable pour une geforce4 mx
Pour ce qui est du paramétrage des résolutions de l’écran, essayer ceux-là : ils sont loin d’être le top mais devraient fonctionner sur un 14" et à fortiori sur un 15". Il faudra essayer des paramètres un peu plus étendus plus tard.
Si on met des paramètres qui dépassent les capacité de l’écran, soit le système ne l’accepte pas soit l’écran n’a pas un affichage correct.

Bon courage


#13

on a posté les messages en même temps ca y est :stuck_out_tongue:
j’ai le mode graphique par contre j’ai un message qui s’affuche constamment sound server fatal error
cpu overload aborting
je suisallez voir les parmètres d affichage je suis en 1280 et lorsque je passe en 800 j’ai une grosse fenêtre qui s affiche mais je ne l’ai pas sur tout mon écran


#14

C’st normal : tout ne rentre pas à l’écran en 800x600

Je mets mes paramètres écran quand je suis en 1024x768

[quote]Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nvidia geforce 6200"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1024x768” “800x600” "640x480"
EndSubSection[/quote]
Il est possible de reparamétrer en 1024x728 avec ces paramètres là.

pour les erreurs de son (sound server), il faut charger alsa-base et alsa-utils
puis taper alsaconf. Donc en console :
$ su
mo_de_passe_root

apt-get install alsa-base alsa-utils

alsaconf

Cela devrait résoudre les problèmes de son.


#15

c’est trop génial merci à tous de ma voir aider je vais essayer de résoudre mon problème de sound par contre ma souris est en ps2 et elle est très lente à se déplacer je suis allez voir dans les paramètres mais j’ai rien trouvé


#16

Pour un écran en 1280x1024 dpkg-reconfigure donne chez moi :
Horizsync 30-65
VertRefrech 50-75

Comme mon écran ne supporte pas cette résolution, je ne peux affirmer que c’est correct.
Pour configurer la carte vidéo avec le pilote 3D, voir le tutu dans "trucs et astuces"
forum.debian-fr.org/viewtopic.php?t=1682

Pour la souris, cela peut commencer par un

dpkg-reconfigure xserver-xorg

et aller voir dans le fichier /etc/W11/xorg.conf (comme pour la vidéo)

Dans le mien cela donne :

[quote]Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection[/quote]

avec une souris optique branchée sur la prise PS2


#17

merci infiniment ginkgo la souris c’est ok le son ça à l’air d être ok le reste je verrais plustard là je sature l affichage ça y est j’ai résolu le problème je me suis mise en 1024 mais je vais augmenter le rafraichissement à l’occasion
merci merci merci :smiley: c’est super sympa heureusement qu’il y a des forums pour nous aidez bravo à tous merci encore bonne soirée


#18

pas de quoi :slightly_smiling:


#19

héhé content :]

poussy92 tu édite ton message pour mettre [Résolu] dans le titre si c’est résolu s’il te plait?

Merci, A+


#20

Je n’ai pas bien suivi tout ce fil mais il y a des trucs que je ne comprends pas ds ton xorg.conf
si tu as maintenant la possiblilité graphique, voudrais-tu afficher en entier ton fichier
/etc/X11/xorg.conf
merci