Déconnexion intermittente du wifi (wicd)


#1

Bonjour,
Sur une nouvelle machine (lenovo T430) et un système tout frais (Debian Stable Stretch 9.5 LXDE), la connexion wifi par wicd se déconnecte régulièrement et je manque de repères pour savoir par quel bout prendre le problème. Une petite boussole me serait d’un grand secours!

Voila ce que donne dmesg quand ça s’arrête de fonctionner

    [56194.457677] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56194.464351] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56194.464465] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56194.743946] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56194.750532] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56194.750633] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56194.835970] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [56195.043228] e1000e: enp0s25 NIC Link is Down
    [56195.288932] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready

et quand ça redémarre

    [56348.737977] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56348.739419] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56348.739520] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56349.020588] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.027219] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.027325] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56349.112026] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [56349.131096] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.137696] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.137798] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56349.420434] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.427046] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56349.427149] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56349.512174] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [56349.737917] e1000e: enp0s25 NIC Link is Down
    [56349.985151] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
    [56350.147601] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56350.153410] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56350.153512] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56350.437025] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56350.443618] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
    [56350.443724] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [56350.528049] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [56355.920045] wlp3s0: authenticate with 30:91:8f:9e:5d:5d
    [56355.923372] wlp3s0: send auth to 30:91:8f:9e:5d:5d (try 1/3)
    [56355.926198] wlp3s0: authenticated
    [56355.929322] wlp3s0: associate with 30:91:8f:9e:5d:5d (try 1/3)
    [56355.937367] wlp3s0: RX AssocResp from 30:91:8f:9e:5d:5d (capab=0x411 status=0 aid=4)
    [56355.966616] wlp3s0: associated
    [56355.983815] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready

Et le log de wicd

    2018/10/31 12:19:20 :: Connecting to wireless network TNCAP9E5D5D
    2018/10/31 12:19:21 :: Putting interface down
    2018/10/31 12:19:21 :: Releasing DHCP leases...
    2018/10/31 12:19:21 :: Setting false IP...
    2018/10/31 12:19:21 :: Stopping wpa_supplicant
    2018/10/31 12:19:21 :: Flushing the routing table...
    2018/10/31 12:19:21 :: Putting interface up...
    2018/10/31 12:19:23 :: Generating psk...
    2018/10/31 12:19:24 :: Attempting to authenticate...
    2018/10/31 12:19:28 :: Running DHCP with NO hostname
    2018/10/31 12:19:28 :: Internet Systems Consortium DHCP Client 4.3.5
    2018/10/31 12:19:28 :: Copyright 2004-2016 Internet Systems Consortium.
    2018/10/31 12:19:28 :: All rights reserved.
    2018/10/31 12:19:28 :: For info, please visit https://www.isc.org/software/dhcp/
    2018/10/31 12:19:28 :: 
    2018/10/31 12:19:28 :: Listening on LPF/wlp3s0/a4:4e:31:3f:d7:54
    2018/10/31 12:19:28 :: Sending on   LPF/wlp3s0/a4:4e:31:3f:d7:54
    2018/10/31 12:19:28 :: Sending on   Socket/fallback
    2018/10/31 12:19:28 :: DHCPDISCOVER on wlp3s0 to 255.255.255.255 port 67 interval 8
    2018/10/31 12:19:28 :: DHCPREQUEST of 192.168.1.102 on wlp3s0 to 255.255.255.255 port 67
    2018/10/31 12:19:28 :: DHCPOFFER of 192.168.1.102 from 192.168.1.254
    2018/10/31 12:19:28 :: DHCPACK of 192.168.1.102 from 192.168.1.254
    2018/10/31 12:19:28 :: bound to 192.168.1.102 -- renewal in 37712 seconds.
    2018/10/31 12:19:28 :: DHCP connection successful
    2018/10/31 12:19:28 :: not verifying
    2018/10/31 12:19:28 :: Connecting thread exiting.

Merci pour vos conseils éventuels


#2

Salut
soit de mauvaises conditions radio, compare en étant plus près de l’émetteur wifi ( la box généralement)
c’est plus probablement une défaillance du pilote iwlwifi
Il traine plein de vieilles rustines sur Internet ,
Exemple
http://zeroset.mnim.org/2014/04/22/unstable-wifi-connection-on-ubuntu-14-04-trusty-tahr-ctrl-event-disconnected-reason4-locally_generated1/

à voir

sinon tu peux aussi utiliser Network-Manager https://wiki.debian.org/fr/NetworkManager à la place wicd


#3

Merci pour les conseils, je vais tenter de conserver wicd pour le moment et essayer cette première rustine qui désactive le mode n du wifi, si ça marche ce sera le dernier message de cette discussion :slight_smile:

sudo modprobe -rv iwlmvm
sudo modprobe -rv iwldvm
sudo modprobe -rv iwlwifi
sudo sh -c 'echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf'

#4

J’ai testé 3 “rustines” différentes : désactiver le mode n, désactiver l’ipv6 et désactiver une forme de chiffrement. Rien n’a fonctionné, wicd est toujours resté aussi instable. Finalement, j’ai enlevé wicd et installé network-manager et depuis tout fonctionne bien depuis plusieurs jours!