dépendance non satisfaite (une de + )


#1

Debian Sid : pour installer des paquets avec apt-get, il me faut apt-utils.
Réponse :impossible car manque dépendance : libapt-pkg-libc6.3-6-3.11
or, cette dépendance est un paquet virtuel, comment je fais ?
http://packages.debian.org/unstable/virtual/libapt-pkg-libc6.3-6-3.11


#2

as tu réinstallé apt ?


#3

J’ai tenté de réinstaller = niet, tjrs m^réponse :
apt-utils : dépendances non satisfaites :
libapt-pkg-libc6.3-6-3.11
J’ai retenté un update . Voici ma liste (les lignes commentées sont sensées faire dble emploi ) :

[code]### DEBIAN STABLE [SARGE] ###########################
deb http://ftp.fr.debian.org/debian stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian stable main contrib non-free

deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free

DEBIAN TESTING [ETCH]

deb http://ftp.fr.debian.org/debian/ testing main
deb-src http://ftp.fr.debian.org/debian/ testing main

deb http://ftp2.fr.debian.org/debian/ testing main

deb-src http://ftp2.fr.debian.org/debian/ testing main

deb http://ftp.fr.debian.org/debian testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian testing main contrib non-free

deb http://ftp2.fr.debian.org/debian testing main contrib non-free

deb-src http://ftp2.fr.debian.org/debian testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

DEBIAN UNSTABLE [SID]

deb http://ftp.fr.debian.org/debian/ unstable main
deb-src http://ftp.fr.debian.org/debian/ unstable main

deb http://ftp2.fr.debian.org/debian/ unstable main

deb-src http://ftp2.fr.debian.org/debian/ unstable main

deb http://ftp.fr.debian.org/debian unstable main contrib non-free

deb-src http://ftp.fr.debian.org/debian unstable main contrib non-free

deb http://ftp2.fr.debian.org/debian/ unstable main contrib non-free

deb-src http://ftp2.fr.debian.org/debian/ unstable main contrib non-free [/code]

J’ai refait un dist-upgrade = rslt :

[quote]ricardo3@debian-sid:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
apt-utils: Dépend: libapt-pkg-libc6.3-6-3.11
E: Dépendances manquantes. Essayez d’utiliser l’option -f.
ricardo3@debian-sid:~$ [/quote]


#4

a comme audition
p comme perception
t comme lire (je sais ca va pas, mais bon). :laughing:


#5

Ben , ch’ai pas mais en ts cas, j’ai tapé
apt-get install apt
alors faut ptet que je désinstalle avant ?
Faut ptet que je passe par dpkg ?
faut ptet que j’me mette à genoux et que … ?


#6

tu as essayé une réinstall plutot qu’une install


#7

Ash a raison pour ce qui est de reinstaller, etant evident que si tu le desinstalles tu te retrouves bien en peine pour le reinstaller puisque c’est lui qui installe…
Mais tu peux aussi en dl une version particulière, et l’installer avec dpkg -i…


#8

Y’a du mieux et j’ai pu installer synaptic, c’est déjà ça car j’y vois plus clair avec ce gui. De plus, installé direct en french :slightly_smiling:
Je vais voir pour le reste.
a+

[code]ricardo3@debian-sid:~$ sudo apt-get --reinstall install apt
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Paquets suggérés :
aptitude synaptic gnome-apt wajig apt-doc bzip2
Les paquets suivants seront mis à jour :
apt
1 mis à jour, 0 nouvellement installés, 0 à enlever et 118 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/1194ko dans les archives.
Après dépaquetage, 57,3ko d’espace disque seront libérés.
apt-extracttemplates: error while loading shared libraries: libapt-pkg-libc6.3-6.so.3.11: cannot open shared object file: No such file or directory
debconf: Échec d’apt-extracttemplates : Mauvais descripteur de fichier(Lecture de la base de données… 70153 fichiers et répertoires déjà installés.)
Préparation du remplacement de apt 0.6.42.1 (en utilisant …/archives/apt_0.6.43_i386.deb) …
Dépaquetage de la mise à jour de apt …
Paramétrage de apt (0.6.43) …

Paramétrage de apt-utils (0.6.43) …

ricardo3@debian-sid:~$[/code]