Dépendance non satisfaite

Tags: #<Tag:0x00007f78b96a6ce0> #<Tag:0x00007f78b96a6740>

Hello,

Je suis en Debian Buster et plus moyen d’installer des paquets.
En cause, un conflit avec MariaDB que je n’arrive à résoudre.

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mariadb-server-core
10.3_1%3a10.3.34-0+deb10u1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/bin/my_print_defaults », qui appartient aussi au paquet mariadb-server-10.3 1:10.3.28+maria~stretch
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
dpkg: concernant .../mariadb-server-10.3_1%3a10.3.34-0+deb10u1_amd64.deb contenant mariadb-server-10.3 :
 mariadb-server-10.3 entre en conflit avec mysql-server-core-5.5
  « mariadb-server-core-10.3 » fournit « mysql-server-core-5.5 » et est présent ainsi de  « installé ».

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mariadb-server-10.3_1%3a10.3.34-0+deb10u1_amd64.deb (--unpack) :
 paquets en conflit - mariadb-server-10.3 non installé
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/mariadb-server-core-10.3_1%3a10.3.34-0+deb10u1_amd64.deb
 /var/cache/apt/archives/mariadb-server-10.3_1%3a10.3.34-0+deb10u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

J’ai testé pas mal de commandes :
apt --fix-broken install
purge autoremove…

Bref tout le temps cette même erreur malgré les forums consultés.
Une idée ?

Merci de votre aide

Cette version ne colle pas avec du Debian Buster …

Postes nous pour voir ce que tu as comme sources pour APT tous y compris les dépôts rajouté à l main).

tu pourrais essayer un

apt-get remove mysql-server-core-5.5