Depuis le passage sous buster, thunderbird n'ouvre plus les liens dans firefox-esr

firefox
thunderbird
Tags: #<Tag:0x00007fa93004a818> #<Tag:0x00007fa93004a5c0>

#1

Bonjour,
Comme indiqué dans le titre lorsque je clique sur un lien http dans un message thunderbird, il ne s’ouvre plus dans firefox-esr
En console, j’ai le message suivant:

Could not launch default application for URI: L’exécution du processus fils « /usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop » a échoué (Permission non accordée)

J’ai essayé de modifier network.protocol-handler.app.http dans thunderbird en remplaçant iceweasel par firefox-esr sans succès.
De toute manière au redémarrage de thunderbird, il repasse automatiquement à iceweasel, ce qui n’est pas forcément grave, puisque iceweasel est un lien qui pointe sur firefox-esr:

ls -l /usr/bin/iceweasel
lrwxrwxrwx 1 root root 30 juil. 10 00:13 /usr/bin/iceweasel -> ../lib/firefox-esr/firefox-esr

Aprés des recherches sur internet, il semblerait que ce bug est ancien et devrait avoir disparu dans la version 60.8.0 (64 bits)

Merci de votre aide


#2

Je pense que le problème est ici, et donc pas lié directement à Thunderbird ou Firefox.

Que te renvoient les commandes suivantes ?

apt-cache policy libglib2.0-0
stat --format=%a /usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop

Si la seconde commande renvoie autre chose que 755, ton souci sera peut-être corrigé par la commande suivante, à lancer avec le compte root :

chmod 755 /usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop

#3

Salut
il faut aussi que le navigateur soit bien defini dans les alternatives

ls -l /etc/alternatives | grep browser

Exemple, chez moi c’est chromium

update-alternatives --display x-www-browser
x-www-browser - mode manuel
  link best version is /usr/bin/chromium
 le lien pointe actuellement sur /usr/bin/chromium
  link x-www-browser is /usr/bin/x-www-browser
/usr/bin/chromium - priorité 40

#4
apt-cache policy libglib2.0-0
libglib2.0-0:
  Installé : 2.58.3-2
  Candidat : 2.58.3-2
 Table de version :
 *** 2.58.3-2 500
        500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
        500 http://http.debian.net/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
stat --format=%a /usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop
755

Malheureusement!


#5
ls -l /etc/alternatives | grep browser

#6

pour ce qui me concerne , j’ai ça, cohérent avec l’alternative

Capture%20d%E2%80%99%C3%A9cran%20du%202019-08-11%2016-16-05

Et tu peux modifier l’alternative pour mettre firefox-esr directement
https://manpages.debian.org/stretch/dpkg/update-alternatives.1.fr.html

quelque chose comme

sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/firefox-esr 100

puis pour selectionner

 sudo update-alternatives --config x-www-browser

#7

Merci.
Mais, toujours le même comportement, avec le même message d’erreur lors de la tentative d’ouvrir un lien après avoir lancé thunderbird en console.
De plus après redémarrage de thunderbird,
x-www-browser redevient /usr/bin/iceweasel


#8

update-alternatives --display x-www-browser


#9
update-alternatives --display x-www-browser
x-www-browser - mode automatique
  link best version is /usr/bin/firefox-esr
 le lien pointe actuellement sur /usr/bin/firefox-esr
  link x-www-browser is /usr/bin/x-www-browser
  slave x-www-browser.1.gz is /usr/share/man/man1/x-www-browser.1.gz
/usr/bin/firefox-esr - priorité 100
/usr/bin/iceweasel - priorité 70
 lien secondaire x-www-browser.1.gz : /usr/share/man/man1/iceweasel.1.gz
/usr/bin/xlinks2 - priorité 69
 lien secondaire x-www-browser.1.gz : /usr/share/man/man1/xlinks2.1.gz

Pas d’amélioration.
Je précise que ce défaut est présent sur tous les comptes utilisant thunderbird, depuis la mise à jour vers à buster.


#10

que se passe t-ilen lançant la commande

/usr/bin/firefox-esr

il n’y a aucune difficulté pour que les liens s’ouvrent depuis Thunderbird
https://support.mozilla.org/fr/kb/les-liens-hypertextes-dans-les-messages-ne-fonctio

une autre source de problèmes: une extension ajoutée dans Thunderbird
https://support.mozilla.org/fr/kb/les-liens-hypertextes-dans-les-messages-ne-fonctio#w_vaerifiez-les-interfaerences-dues-aa-une-extension-module-complaementaire


#11
/usr/bin/firefox-esr
(firefox-esr:4911): Gtk-WARNING **: 13:01:29.014: Theme parsing error: <data>:1:34: Expected ')' in color definition

(firefox-esr:4911): Gtk-WARNING **: 13:01:29.014: Theme parsing error: <data>:1:77: Expected ')' in color definition

Firefox fonctionne parfaitement.

Après avoir testé toutes les possibilités des deux liens fournis, aucune mauvaise configuration détectée.
Même avec thunderbird en mode sans échec, les liens ne s’ouvrent pas.
En attendant, on va continuer à recopier les liens dans le navigateur…


#12

que se passe t-il si tu lances la commande

thunderbird https://www.debian-fr.org/

Chez moi ça fini par ouvrir le navigateur avec la page du forum


#13
thunderbird  https://www.debian-fr.org/

(thunderbird:3900): Gtk-WARNING **: 15:08:40.972: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:3900): Gtk-WARNING **: 15:08:40.972: Theme parsing error: <data>:1:77: Expected ')' in color definition

** (thunderbird:3900): WARNING **: 15:08:41.739: Could not launch default application for URI: L’exécution du processus fils « /usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop » a échoué (Permission non accordée)

Et bien sur, il n’ouvre pas le navigateur!


#14

très curieux ça.
que dit

/usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop /usr/bin/firefox-esr

il semble y avoir un soucis avec le profile apparmor de Thunderbird

tu peux aussi essayer en le desactivant

sudo aa-disable usr.bin.thunderbird

Le changement étant qu’apparmor est maintenant activé par défaut dans Buster:
https://www.debian.org/releases/buster/amd64/release-notes/ch-whats-new.fr.html#apparmor


#15
/usr/lib/x86_64-linux-gnu/glib-2.0/gio-launch-desktop /usr/bin/firefox-esr

Pas de message d’erreur, le navigateur se lance.

aa-disable usr.bin.thunderbird

résout le problème (après installation de apparmor-utils).

Un grand Merci à toi!


#16

Je suis en Debian 11 Bullseye (testing) et il n’y a pas ce problème

apt list --installed | grep apparmor

apparmor-easyprof/testing,testing,unstable,unstable,now 2.13.3-4 all  [installé]
apparmor-profiles-extra/testing,testing,unstable,unstable,now 1.27 all  [installé]
apparmor-profiles/testing,testing,unstable,unstable,now 2.13.3-4 all  [installé]
apparmor-utils/testing,unstable,now 2.13.3-4 amd64  [installé]
apparmor/testing,unstable,now 2.13.3-4 amd64  [installé]
libapparmor1/testing,unstable,now 2.13.3-4 amd64  [installé]
python3-apparmor/testing,unstable,now 2.13.3-4 amd64  [installé, automatique]
python3-libapparmor/testing,unstable,now 2.13.3-4 amd64  [installé, automatique]

Probable qu’il y aura une maj d’apparmor dans Buster


#17

une mise à jour de Buster m’a permis de régler le problème