Désactiver bluetooth au démarrage

Tags: #<Tag:0x00007f58cf41d118> #<Tag:0x00007f58cf41cd08>

Bonjour,

Après des milliers d’essais infructueux, je n’arrive toujours pas à désactiver le bluetooth au démarrage de debian sans désactiver complètement le service bluetooth, ce qui oblige à passer systématiquement par le terminal pour réactiver le service bluetooth.

J’aimerais que le bluetooth soit désactivé au démarrage mais activable en passant par le bouton on/off dans les paramètres bluetooth de gnome…

Quelqu’un.e aurait-il une solution ? Je désespère…

Merci :slight_smile: (je tourne sur un thinkpad, debian stretch, gnome)

Salut,
le bluetooth est donné par la carte wireless (wifi + bluetooth).
Je suis aussi sur des thinkpad et n’ai pas eu trop de pb la dessus, mon wifi est off de base avec l’interrupteur du portable.
Ensuite quand je passe en On mon wifi garde l’état précédent (état au moment de Off) soit activé soit inactivé.
Donc pour le bluetooth, il ne peut-être activé que si le matériel wireless est On (interrupteur), donc s’il est Off alors de base pas de bluetooth ensuite si matériellement On alors mon bluetooth est désactivé par défaut et je l’active ensuite via paramètre bluetooth gnome.
Mais j’avais peut-être bidouillé un truc à un moment et pour la doc bluetooth tout est là sur thinkwiki. :thinking:
A+

Salut,
De quel(s) interrupteur(s) parles-tu ?
Quand j’allume mon ordinateur, le wi-fi et le bluetooth s’activent systématiquement, quel que soit leur état avant que j’éteigne l’ordi. Que le bluetooth soit on et le wifi off ou inversement, ou même en mode avion avant la mise hors tension de la machine, quand je la rallume tout revient sur on. Mais effectivement j’aimerais bien à arriver à avoir mon bluetooth désactivé par défaut et pouvoir l’activer via le bouton on off dans les paramètres bluetooth de gnome. Mais je n’ai toujours pas la solution.

J’ai effectivement le module thinkpad_acpi dans mon kernel, les echo 1 et echo 0 fonctionnent bien mais encore une fois ce n’est que à l’instant t, ça ne modifie pas le comportement au démarrage qui revient toujours à la valeur 1, donc activée après le boot. la touche Fn+F5 ne peut pas me concerner, sur le T450 le F5 est affecté à la baisse de luminosité de l’écran. Du coup, pareil pour le script utilisé et affecté à la touche Fn+F5, j’ai du mal à voir comment je pourrais l’adapter sur ma machine.
Par contre j’ai bien ma ligne GRUB_CMDLINE_LINUX=“bluetooth.blacklist=yes rfkill.default_state=0” dans mon /etc/default/grub mais le bluetooth est toujours on au redémarrage. J’ai essayé de passer ces paramètres sur la ligne GRUB_CMDLINE_LINUX_DEFAULT mais le résultat est le même. Peut-être je ne comprends pas bien ce que veut dire le “when builtin” dans l’article quand il dit d’ajouter le paramètre au kernel mais je ne crois pas que ce soit ça le problème ? Ou peut-être que ce paramètre ne peut fonctionner qu’avec le script du dessus et dans ce cas ça expliquerait pourquoi ça ne change rien mais pareil je ne suis pas certain du tout du lien entre les deux, c’est pas vraiment bien expliqué dans l’article si tout est lié ou séparé.

Voilà, je suis toujours autant desepéré, mais je crois comprendre qu’il y a un souci entre rfkill et le thinkpad_acpi, seulement plusieurs personnes semblent avoir réussi quand même, après avoir tout essayé moi toujours pas !

Avis aux conseils utiles…

Merci :slight_smile:

Cela t’es-t-il utile ?

http://www.thinkwiki.org/wiki/How_to_setup_Bluetooth
https://askubuntu.com/questions/180744/how-to-enable-hard-blocked-bluetooth-in-thinkpad-edge-320

Le fonctionnement de bluetooth est assez “poétique”. Pour ma part (T430 debian/mate) j’ai laissé tomber l’interface graphique, les rares fois où j’utilise bluetooth je passe les commandes dans un terminal. Pour te rassurer, avec un portable hp/compaq c’était pire.

Salut
Ne me servant pas de bluetooth

 cat /lib/systemd/system/bluetooth.service
[Unit]
Description=Bluetooth service
Documentation=man:bluetoothd(8)
ConditionPathIsDirectory=/sys/class/bluetooth

[Service]
Type=dbus
BusName=org.bluez
ExecStart=/usr/lib/bluetooth/bluetoothd
NotifyAccess=main
#WatchdogSec=10
#Restart=on-failure
CapabilityBoundingSet=CAP_NET_ADMIN CAP_NET_BIND_SERVICE
LimitNPROC=1
ProtectHome=true
ProtectSystem=full

[Install]
WantedBy=bluetooth.target
Alias=dbus-org.bluez.service

je l’ai désactivé

 systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)

Dans cet état le daemon bluetoothd n’est pas créé et le bouton n’a plus aucun effet.

Il faut peut être adopter la logique inverse, laisser bluetooth s’activer au démarrage et le passer off par le bouton
je ne sais pas si ce parametre dans dconf correspond à l’état du bouton

Salut,
Je propose de lancer ton echo dans le fichier script /etc/rc.local (en root cad ouvre un terminal et tape “su” (sans guillemets) puis ton mot de passe administrateur-ice et [entrée])
puis dans le terminal donc à l’invite de commande “root” comme ceci

root@[ton_ordi]:/home/[ton_utilisateur de base]#

tape (là c’est avec l’éditeur nano, mais cela peut ce faire via un autre):

nano /etc/rc.local

Puis en fin de fichier avant “exit 0” ajoute une ligne avec “echo…” comme ceci (là c’est mon rc.local vide sous debian strech):

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# désactive le bluetooth au démarrage
echo 0 > /sys/devices/platform/thinkpad_acpi/bluetooth_enable

exit 0

Enregistre sous nano avec Ctrl+X puis tape “o” sans les guillemets pour “oui” puis [entrée].
Redémarre le système.
Et ce devrait être bon ! :sunglasses:
A+.

Quand je remets bluetooth en démarrage automatique, l’icone bluetooth apparait
Il s’agit de blueman-applet

https://packages.debian.org/stretch/blueman

apt install blueman

et il suffit d’1 clic pour désactiver

Visiblement tu n’en as pas sur le T450, sur les anciens y en a et c’est pratique; moi qui ne suis pas un plat à réchauffer au micro-onde :wink: surtout dans une cage de Faraday type caravane ou camion hé !
Ton on/off clavier semble être Fn+F7 isn’t it ?

… et pour ta touche fonction f7 d’activation/désactivation wifi modifie sur la page du thinkwiki citée plus haut:

You might also be able to toggle bluetooth using Fn+F7.
… réaliser les étapes du tuto …
Create /etc/acpi/events/radio.conf:
là remplacer
text event=ibm/hotkey HKEY 00000080 00001005
par
text event=ibm/hotkey HKEY 00000080 00001007

… réaliser les étapes du tuto …

enjoy !

C’est le F8 l’interrupteur sans fil, F7 c’est vidéoprojecteur :wink: Et il fonctionne bien le bouton, quand j’appuie dessus il passe en mode avion, mais si je reboot il va tout remettre en ON, aucune mémorisation. M’enfin je vais essayer, rien à perdre !!

@snotons J’avais déjà essayé le script rc.local sans succès, mais là ça fonctionne merci !!
C’est pas super propre et ça ralentit le démarrage mais pour l’instant je me contenterai de ça…
Si jamais quelqu’un a une solution plus propre à la source plutôt que de l’éteindre après qu’il se soit activé dans le boot je suis toujours preneur, en attendant je ferai avec le rc.local !

Peut-être que c’est plus propre avec ce qu’ils racontent sur thinkwiki, mais je crois que tout ce qu’ils disent ne s’appliquent que si la touche ne fonctionne pas, en l’occurence mon F8 fonctionne très bien mais n’est pas mémorisé au redémarrage.