détection souris kde


#1

J’ai une souris ps2 logitech toute bete
j’ai installé kde sur debian sarge.
j’ai sélectionné ps/aux puis ps2 et la souris ne fonctionne pas sous kde.
je ne sais pas trop comment résoudre ce problème. ( la souris fonctionne sous windows)

si quelqu’un a une idée…
merci

:unamused:


#2

lances déjà: apt-get install mdetect

Et ensuite mdetect de dira sur quel device se trouve ta souris


#3

Je n’ai jamais eu de problème de souris sous Débian et pourtant je suis le roi des emmerdes :open_mouth:
Comme sélection à l’install, j’ai mis /dev/psaux et choisi ensuite ‘Im PS/2’ (le 'Im devant fait ptet la différence ?)
Je ne te dirai pas où il faut aller pour changer mais d’autres von s’en charger


#4

mdetect me dit :
ps/aux
intellimouse

Mais il n’y pas de intellimouse dans le menu ps/aux… ( ds la config de xserver-xfree86) :confused:


#5

[quote]mdetect me dit :
ps/aux
intellimouse[/quote]

tu veux dire

/dev/psaux ??

Oula, c’est que je suis pas très doué pour la config. de X moi … :blush:

Chez moi ca donne ça:

root@luciole:/etc/X11 # mdetect
/dev/psaux
intellimouse
root@luciole:/etc/X11 #

Donc apparement, on a à peux près le même matos…

Dans mon /etc/X11/XF86Config-4
j’ai la section “InputDevice” comme ça:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

fait une copie de sauvegarde de ton fichier et essayes de le modifier comme ça puis relance ton serveur X, pour voir ce que ça donne

As-tu le device:
root@luciole:/etc/X11 # ls -l /dev/input/mice
crw------- 1 root root 13, 63 Dec 13 13:53 /dev/input/mice
root@luciole:/etc/X11 #


#6

oui pardon, c’est bien /dev/psaux…

donc j’ai essayé aves tes paramètres dans le fichier de config mais c’est toujours pareil, pas de souris.
sinon la commande ls -l /dev/input/mice me donne crw- rw- — mais je crois que mice c pour les souris usb.
à part ca j’ai essayé le paquet gpm pour voir si la souris fonctionne en mode console mais c’est pareil.
Sinon j’ai cherché sur le net, normalement il faut séléctionner ImPS2 pour Intellimouse et compatibles dans la config de X, ca ne marche pas non plus

Merci pour votre aide…
:bulb:


#7

essaye de reconfiguré en faisant
dkpg-reconfigure xserver-xfree86

la tu pourra changer tes options, sinon moi j’ai un pote qui a un pb avec sa wacom ( les trucs qui font souris et palette graphique ( vrai merde en clair) ) mais il peut la deplacer quand meme, mais elle scintille et on ne peut pas aller ou on veut mais bon )

si vous avez une solution , sinon pas grave car je l’ai converti au trackball 8)


#8

ouais j’ai déjà reconfiguré avec dpkg-reconfigure, j’ai essayé toutes les configs y en a aucune qui fonctionne…

please help :cry:


#9

:confused: dsl ca depasse mes competences


#10

2 questions qui peuvent etre betes mais on ne sait jamais c’est des fois les questions toutes connes qui aident bon

Est tu sur que ta souris fonctionne sur un autre OS et l’as tu bien branché sur le bon port

Oui!!! Je sais !!!

Ok je sors :arrow_right:


#11

Une idée ptet : installer gdm et tester si sous Gnome ça fonctionne.


#12

Est-ce que le module psmouse est bien chargé au démarrage?
Fais nous voir ton XF86Config-4 et le résultat d’un lsmod pour vérifier.


#13

oui #nemes1s#, la souris fonctionne sous windows et est bien branchée 8)

J’ai fais un lsmod. il n’y a pas de module psmouse chargé. ( j’ai vu un mousedev) Ce module est il nécessaire BobX?

A part ca voilà mon fichier XF86Config-4:

[color=red]

XF86Config-4 (XFree86 X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the XF86Config-4 manual page.

(Type “man XF86Config-4” at the shell prompt.)

This file is automatically updated on xserver-xfree86 package upgrades only

if it has not been modified since the last upgrade of the xserver-xfree86

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom

md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum

dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “ZAxisMapping” "4 5"
EndSection
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “ZAxisMapping” "4 5"
EndSection

Section "Device"
Identifier "ATI Radeon 9200 SE"
Driver "ati"
EndSection

Section "Monitor"
Identifier "IIyama Vision Master 1404"
HorizSync 30-70
VertRefresh 50-160
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Radeon 9200 SE"
Monitor "IIyama Vision Master 1404"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1152x864” “1024x768” “800x600” "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

[/color]

A part ca j’ai remarqué que j’ai beau changer les options dans le dpkg-reconfigure xserver-xfree86, j’ai l’impression que les paramètres ne sont pas modifiés.

J’ai mis n’importe quoi pour voir : vmware en driver graphique option ISA:1, un écran 14 pouces ( j’ai un 17) et une résolution de fou en 1600*1200…
et bien kdm se lance sans broncher comme avant. y a que la souris qui ne fonctionne pas…!

voilàvoilà…
:unamused:


#14

il me semble bien que psmouse est nécessaire (en tout cas il est chargé chez moi)
essaye un modprobe psmouse et redémarre ton serveur X, pour voir ce que ça donne


#15

Meme souris meme pb sur ps2
Parcontre moi je l’ai mise sur usb, et maintenant aucun pb: detectée du premier coup.

Bon ca résoud pas le pb je sais… Mais en attendant t’auras une souris fonctionnelle!


#16

essayez d’installer gpm, gpm gere enormement de souris différentes.
aprés avoir installé le paquet, et lu un peu la doc, vous passez en session de console (ctrl+alt+f1) pour le configurer (dpkg-reconfigure gpm), et le tester (normalement, la souris se materialise dans votre ecran de console).
Ensuite, quand ca marche, vous mettez les lignes suivantes dans votre XF86config pour lui dire qu’il prend sa souris au travers de gpm:

Section "InputDevice"
[b]        Identifier      "GPM"[/b]
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/gpmdata"
        Option          "Protocol"              "IntelliMouse"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection
# et plus loin qqchose du genre:
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
[b]        InputDevice     "GPM"[/b]
EndSection

une fois modifié et accepté votre fichier, n’oubliez pas de le déverrouiller pour apt avec
md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum


#17

j’ai chargé le module psmouse et ca fonctionne!
Merci de m’avoir aidé!
:stuck_out_tongue:


#18

De rien. Pense à le rajouter dans /etc/modules pour qu’il soit bien chargé au démarrage :wink: