Disques SATA


#1

Bonjour à vous tous,

Ces derniers jours, je deviens complètement fou… Après plus ou moins 15 reconfiguration, je suis toujours au même point. j’essaye de recompiler mon noyaux afin qu’il accepte le S-ATA en natif.

Pour reprendre la genèse de mon installation, j’ai commencé par essayer d’installer Debian avec mon bios configuré pour SATA Controller / AHCI. Debian ne me trouve aucun disque si je veux éditer manuellement ma table de partition, puisque je n’ai pas envie de paumer mes données. Je passe donc mon bios en mode combiné (SATA/PATA) et là, Debian s’installe sans soucis…

Mais j’ai une ancien kernel et surtout, je n’ai pas le support du SATA en natif (je pourrais le laisser en PATA mais en tant que bon Geek et surtout pour le débit de donnée, je veux le SATA). Je lance donc la configuration de mon nouveau noyaux (menuconfig) et là, j’ai beau activer plein de paramètre, j’ai toujours la même kernel panic (note au passage, je démarre avec Grub) à savoir “hda7 not found”…

Si quelqu’un avait une idée géniale, ce serait sympa… genre les configurations à activer en dur et en module

Ps :
Chipset : Intel 955X
Processeur : Intel 531
Controller SATA : ICH7-R (compatible AHCI)
Je veux installer un kernel 2.6.13


#2

bjr,
indépendament de comment tu as configuré ton noyau, l’as tu compilé avec un initrd ?


#3

Non, je vais essayer derechef. Je vous tiens au courant :wink:


#4

Toujours le même problème…

unable to mount root fs on unknow …

D’autre ideés ?


#5

comme le dit ioda, notre maitre à tous:
“idiot je suis de ne pas avoir vu ça !”

dis moi donc, un disque qui s’appelle hda en PATA, il s’appelle coment en SATA ?
tu as modifié ton fstab en conséquence ?
:laughing:


#6

Oui malheureusement mais toujours la même chose…


#7

et sinon, bien sur, les sources de ton 2.6.13 sont bien des sources noyau obtenue par debian, et pas des sources venant de kernel.org ?
et tu l’as bien compilé avec make-kpkg, comme il faut le faire sous debian, pas avec make bzImage comme on le fait ailleurs ?
et ton initrd, tu l’as bien génèré avec l’option --initrd de make-kpkg ?


#8

non, ce ne sont pas les sources de l’apt-get (? debian je suppose que c’est ça que tu veux entendre :confused:) mais bien des sources prises sur kernel.org

Le tout compilé avec make-kpkg et --initrd…

Je désespère mais persévere :smiley:


#9

bon, alors essayes un make-kpkg debian avec tes sources vierges, et recommences ta compil noyau.
Mais à mon avis, tu devrais être moins ambitieux et prendre des sources debian (il y a du 2.6.12 qui traine qqpart, si c’est pas dans ta release, telecharges le .deb dans les rep debian).
Autre conseil : trouves déjà un 2.6 quelconque qui marche en PATA (voire SATA), et utilises son .config (le /boot/config-???) comme base de config pour le noyau que tu veux compiler.


#10

J’en ai un qui marche en PATA mais je veux qu’il marche en SATA…

Je vais regarder du coté des .deb :wink:

Merci


#11

si c’est un 2.6, c good.


#12

yep, 2.6.8… je vais réutiliser le .config sans le SATA… voir si ça marche et refaire des compilations pour activer le sata…


#13

Je reviens à la charge puisque je ne suis toujours pas sous mon nouveau noyaux.

Bonne nouvelle il détecte correctement mon SATA sans prob et tout mais,
Lors de l’installation j’ai :

[quote]Setting up kernel-image-2.6.13.051004 (2.6.13) …
/usr/sbin/mkinitrd: /lib/modules/2.6.13.051004: Not a directory
/usr/sbin/mkinitrd: MODULES needs to be set to none?
Failed to create initrd image.
dpkg: error processing kernel-image-2.6.13.051004 (–install):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
kernel-image-2.6.13.051004
[/quote]

Pourtant, j’ai bien un dossier modules mais qui porte le nom de /lib/modules/2.6.13.051004y (me demandez pas pourquoi…) ce qui fait qu’il ne trouve pas les modules…

Si je copies les modules dans 2.6.13.051004 il “compile” l’initrd correctement mais au démarage :
Unable to found /lib/modules/2.6.13.051004y/modules.dep
Pourtant ce fichier s’y trouve… Je perds la tête :slightly_smiling:


#14

tu as dû te mélanger les pinceaux, ou bien il y a un bug, avec les options “revision” ou “append-to-version”…
C’est ca quand on veut faire propre… :slightly_smiling:)
Au lieu de recopier, essayes de faire un lien symbolique:
ln -s /lib/modules/2.6.13.051004 /lib/modules/2.6.13.051004y
sinon, essayes de recompiler, mais sans dater ton noyau ni avec une option de make-kpkg, ni avec l’option de noyau qui permet de le faire.


#15

Sans option sauf le --initrd j’ai toujours le même problème…

Qu’entends-tu par option du noyaux ? fichier .config ?

Merci des vos idées :confused:


#16

je voulais dire “sans option de nommage”, c’est a dire que tu supprimmes le “051004”, la ou c’est configuré.
Et le lien symbolique, ca ne marche pas ?


#17

non :frowning:

Toujours le unable to found : /lib/modules/2-6-13y/…


#18

Et le lien symbolique, ca ne marche pas ?


#19

non :frowning:


#20

au fait, ce sont bien des sources debian, comme je t’ai dit, pas des génériques ?