Driver ATI et XrandR


#1

Slt,

je viens d’installer les drivers proprio en suivant bien le tuto. J’ai tout fait comme indiqué, mais une fois l’installation terminée et le PC rebooté, je n’ai plus XrandR… Pourtant, je le charge bien dans la section modules…

Je joint mon XF86Config-4…

[code]Section "ServerLayout"
Identifier "Default Layout"
Screen “Default Screen” 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section “Files”
# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "GLcore"
Load "glx"
Load "dri"
Load “RandR”
# Load “extmod” but omit DGA extension
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Monitor"
Identifier "Écran générique"
HorizSync 30.0 - 70.0
VertRefresh 53.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI"
Driver “fglrx”
# Si X refuse d’utiliser la résolution que vous avez choisie,
# décommentez ce qui suit.
#Option “NoDDC”

    # === Video Overlay for the Xv extension ===
    Option "VideoOverlay" "on"
    # === OpenGL Overlay ===
    Option "OpenGLOverlay" "off"
    # === Use internal AGP GART support? ===
    Option "UseInternalAGPGART" "no"

EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection[/code]

Et pour info… ElroCorp:/home/nico# xrandr Xlib: extension "RANDR" missing on display ":0.0".

Voilà, si vous avez une idée, merci parce que moi je sèche… :confused:

++

PS : j’ai une Radeon 9600XT sous XFree 4.3