Droits d'accès /dev


#1

bonjour,
j’'utilise kwikdisk pour gerer mes peripheriques, donc tout est monter mais je ne peux plus les démonter, par ex le dvd, il n’y a que root qui peut mais il faudrait changer les droits de /dev je pense et là je ne sais pas si je peux et si je dois par ailleurs lorsque j’ouvre une partition par exemple, toujours avec kwikdisk, konqueror est en anglais une fois sur deux et je ne comprend pas tout :blush:


#2

slt,

Regarde du coté du fichier /etc/fstab…(man fstab mdr)


#3

/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda4 / ext3 defaults,errors=remount-ro 0 1
/dev/hda2 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda3 /mnt/stock vfat defaults,umask=000 0 0
/dev/sda1 /mnt/usb vfat user 0 0
et qu’est ce qui ne va pas ? :frowning:


#4
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0 

Le ‘ro’ serait mieux en ‘rw’ mais pas sur…


#5

non. c’est juste que l’option “user” autorise tous les utilisateurs à monter le périphèrique, mais seul celui qui l’a monté peut ensuite le manipuler.
Il faut mettre une option “users” à la place, et tous les utilisateurs pourront faire tout ce qu’ils veulent.
Bon, mais attention: ca peut être cause de problêmes, si par exemple un utilisateur distant demonte une disquette pendant qu’on y ecrit.
Et coté sécurité, c’est zéro.
Il vaut mieux rester en user, et savoir l’utiliser.
C’est un choix…


#6

bon pour le cdrom, lorsque je le monte et que je l’ouvre il faut refermer la fenêtre avant de le démonter :blush:
il reste hda3 qui ne veut pas demonter car droit root, j’ai du mal renseigner les options fstab
bon j’ai un peu la flemme ce soir donc si il y a un mec sympas dans le coin, sinon pas grave
et merci :wink:


#7

C’est normal si tu doit ferme la fenetre du cdrom pour le démonter tu ne peux pas demonter quelque chose qui fonctionne :slightly_smiling:

Sinon pour ton fstab il m’a l’air pas trop mal voici le mien si ca peut aider

[code]# /etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda4 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdb /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,umask=0 0 0
/dev/fd0 /mnt/floppy vfat rw,user,noauto,umask=0 0 0
/dev/hda1 /mnt/winnt ntfs ro,user,noauto,umask=0 0 0
/dev/hda5 /mnt/hdd1 vfat rw,user,noauto,umask=0 0 0
/dev/hda6 /mnt/hdd2 ntfs ro,user,noauto,umask=0 0 0
/dev/hda7 /mnt/hdd3 vfat rw,user,noauto,umask=0 0 0
/dev/hdd1 /mnt/hdd4 auto ro,user,noauto,umask=0 0 0
/dev/sda1 /mnt/usbkey auto rw,user,noauto,umask=0 0 0
/dev/sda5 /mnt/usbdrive auto rw,user,noauto,umask=0 0 0
/dev/sdb1 /mnt/usbkey256 auto rw,user,noauto,umask=0 0 0

[/code]


#8

bah ouais, on peut pas être bon tout les jours :smiley:
je vois que tu as 2 vfat je vais modifier mon hda3 en consequence, en fait c’est un fstab que j’ai du recopier sur une mdk pour memo et j’ai du remettre ça par defaut dans l’urgence car j’ai viré kubuntu ce matin.
ok ça roule, merci


#9

bon ça marche pô, y demande toujou les droits root mais bon je fait avec.


#10

regarde si le répertoire dans lequel tu le monte est la propriété de root


#11

Ben ouais, c’est normal, surtout en hiver, il faut économiser sur le chauffage :laughing:
A part celà, pour comprendre pourquoi, essayes de faire ton umount depuis un terminal et tu verras qu’il te signal que le “device is busy…”


#12

bah oui, les rep usb et stock sont la propriété de root.


#13

Et lorsque tu les montes normalement ils devraient changer de propriétaire c’est ce qu’il se passe chez moi :slightly_smiling:


#14

bah non, hda3 est monté et il est toujours root.
j’ai changé les droits de /mnt mais je ne peux pas avec /stock ou /usb ???


#15

pour hda3 c’est normal, si tu n’as pas mis user ou users, ce n’est montable que par root, donc ca a forcément été monté par root.
pour sda1, si ca se monte automatiquement quand tu le branche, c’est pareil: c’est le root qui le monte, et comme c’est configuré en user, ca appartient immédiatement à root.


#16

/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda4 / ext3 defaults,errors=remount-ro 0 1
/dev/hda2 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda3 /mnt/stock vfat rw,user,umask=000 0 0
/dev/sda1 /mnt/usb vfat user 0 0
non poutant je l’ai deja modifié :question:


#17

et je t’ai expliqué pourquoi dans le cas de ton hda3 qui est monté par root au boot et ton sda1 hotplug, pour obtenir ce que tu voulais, il fallait mettre users et pas user, mais ca n’a pas eu l’air de percuter visiblement… :wink:


#18

bon ja tout relu et ja tout compris, le matin ça va mieux :laughing:
tu penses qu’il faut mieux laisser comme ça pou la securité ?


#19

ca crée des failles, mais faut pas exagèrer la menace…
Va z y sans crainte à mon avis. D’ici à ce qu’on essaye de pirater des données sur ta clé usb ou sur ton hda3…


#20

c’set aussi ce que je me disait, donc jai modifié usb car c’est plus rapide et hda3 restera monté car c’est une part qu j’utilise constament.
merci