Ds quel fichier les tables de routage ?


#1

J’ai un problème de connexion sous ‘Sarge’ avec le Sagem fast 800 free non dégroupé.
J’ai 2 installations sur 2 DD différents. Elles sont ttes 2 faites à partir des m^ DD et le m^ pilote eagle-usb.
chez une, tout fonctionne parfaitement, chez l’autre, il me faut ajouter, pour être connecté :
route add default ppp0
sinon, la connexion n’est pas valide.
Tout le reste est OK donc je voudrais savoir si on peut changer manuellement un fichier de routage ou autre .
Merci de l’aide.
C’est le dernier truc qui ne va pas :wink:


#2

verifie dans les options de /etc/ppp correspondant à ta liaison adsl, s’il y a bien une directive ‘defaultroute’ la ou il faut (au besoin en comparant avec celle qui marche toute seule).
Sinon, pour modifier durablement la table de routage de noyau, je crois qu’il y a des options avec les commande ‘route’ ou ‘ip route’ (si cette dernière est installée).
Il y a d’autres solutions , mais ce n’est pas ce que tu veux: la route doit etre associée à ta connexion, elle a la même durée de validité qu’elle. C’est donc dans l’init ppp qu’elle doit etre installée.


#3

Oui, c’est bien ça et j’arrive en entrant
route add default ppp0
mais il faut que je le fasse à chaque fois et j’aimerais soit que ça soit automatique, soit réparer l’erreur.
Une chose qui va p e te donner l’idée :
au chargement, de ma ‘debian défectueuse’, ça s’arrête un tps assez long après la ligne
[eagle-usb] ethernet device eth1 created
on a l’impression qu’il cherche la suite et qu’il ne trouve pas.
Avec la debian ‘bonne’, pas d’interruption à ce niveau.
Comment refaire une connexion avec un eth différent ?
Il me semble que ça aviat été préconnisé ds un topic.?