Dungle WIFI REALTEK 8192SU non reconnu

Tags: #<Tag:0x00007efedb6caee0> #<Tag:0x00007efedb6cacd8> #<Tag:0x00007efedb6c9338>

Bonjour
J’ai installé Debian 10.3 mais impossible d’accéder à internet.
Le système ne reconnais pas le Dungle wifi de ma tour (Realtek 8192 Su) J’ai tenté d’installer le pilote via le DVD d’installation sans succès.
Quelqu’un peut-il me dire si une solution existe pour ce matériel ?
Avec mes remerciements

Il faut que tu télécharge le driver dans les depots non-free

apt-get update && apt-get install firmware-realtek

mais pour cela, il faut que tu es deja internet.
peut tu avoir une connection filaire le temps de la manipulation ?

1 J'aime

Merci de vous intéresser à mon petit problème.
Je vais déplacer la tour pour la connecter en filaire.
Je vous tiendrai au courant du suivi.
Salutations

Bonjour

J’essaie depuis hier mais maintenant c’est le terminal qui bloque : " Permission non accordée"

Capture d’écran du 2020-05-07 07-58-00

macri@macri-hp-z200-workstation:~$ sudo apt-get update && apt-get install firmware-realtek
[sudo] Mot de passe de macri : 
Atteint :1 http://security.debian.org/debian-security buster/updates InRelease
Atteint :2 http://deb.debian.org/debian buster InRelease        
Atteint :3 http://deb.debian.org/debian buster-updates InRelease
Lecture des listes de paquets... Fait
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock-frontend - open (13: Permission non accordée)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Avez-vous les droits du superutilisateur ?
macri@macri-hp-z200-workstation:~$ 

J’ai pourtant mis mon compte en « administrateur » depuis hier.

Merci - Salutations

Salut @MACRI bonjour :slight_smile:

C’est pourtant explicite sur le message.
Es tu sûr de faire partie du groupe sudoers ?
Tu as du faire l’installation en mode sudo (donc root désactivé )c’est pour ça que tu es emmerdé comme ça. Donc la c’est sudo qui est prioritaire. Vérifie aussi que tu n’a pas synaptic qui tourne derrière.

Bonjour

Dans :

sudo apt-get update

la commande apt a bien été exécuté avec les privilèges nécessaires,
mais pas la commande apt-get install qui renvoie donc ce message d’erreur.

Il aurait fallu entrer :

sudo apt-get update && sudo apt-get install firmware-realtek

ou mieux (car beaucoup plus parlant dans le retour de commande) :

sudo apt update && sudo apt install firmware-realtek

Salut @MicP bonjour à toi. :slight_smile:

À oui c’est vrai , je n’y avait pas pensé à ça.C’est pour çe genre de conneries que je fuis sudo :). Avec su - ,tu as tout les droits avec l’environnement root (je ne sais plus comment on appelle ça) , tu fais ce qu’il y a à faire et ça ne bronche pas . :slight_smile:

Bonjour Iblis

Oui, c’est bien comme ça que l’on dit.

En plus long, ça donnerait :
On ouvre un login shell sous le compte root et le shell obtenu
utilisera les variables d’environnement indispensables au compte root
pour qu’il puisse accéder aux commandes d’administration.

Ceux qui ont fait une installation sans donner de mot de passe au compte root
ne pourront pas obtenir un login shell en utilisant la commande su
mais ils obtiendront un shell équivalent (avec les variables d’environnement du compte root)
en utilisant l’option i de la commande sudo :

sudo -i

[HS)En bien tiens, en parlant des options de sudo. Hier dans mon sujet virtualisation tu as parlé de sudo -c , j’ai regardé dans le man , je n’ai trouvé que -C à moins d’être passé à coté , est-ce pareil? À quoi sert cette option -c ? [/HS]

Vous me semblez sortir du sujet
Aussi je reviens à mon problème :
Voilà la réponse à la commande passée :

Capture d’écran du 2020-05-07 08-50-57

Salutations

Sorry pour le HS :slight_smile: Les dépôts contrib et non-free sont ils activés ?

Oui, comme le fait remarquer Iblis
dans le fichier /etc/apt/sources.list de ton système debian
il doit manquer les dépôts contrib et non-free

Pour les ajouter, il te faudrait lancer ces deux lignes de commande :

sudo apt add repository contrib
sudo apt add repository non-free

ensuite, il te faudra mettre à jour la liste des paquetages
en lançant la ligne de commande suivante :

sudo apt update

et tu pourras finalement installer le paquetage firmware-realtek
en lançant la ligne de commande suivante :

sudo apt install firmware-realtek 

[HS]
@anon74666808 :

Effectivement, il n’existe pas d’option c pour la commande sudo
mais dans le fil de discussion concernant la virtualisation,
j’ai utilisé l’option c de la commande su
[/HS]

Ok merci, vraiment j’avais cru lire sudo -c hier… Soit tu as corrigé ou soit je n’avais pas les yeux en face des trous :smiley:
Si c’est le deuxième cas désolé :slight_smile: @++ Sinon on va se faire lyncher par @MACRI pour le HS :slight_smile:

Suite et fin .
La commande est passée. Le wifi fonctionne !!
Merci pour tout.
Salutations

Merci beaucoup pour le retour, :grinning:
et désolé d’avoir un peu perturbé ton fil par ces messages hors sujet.