Ecran de la console


#1

bonjour,

je viens de terminer l’ installation de ma debian…non sans mal et j’ ai un petit soucis : l’ écran noir de la console prend tout l’ écran à tel point que je ne vois plus ce que je tapes car le curseur est dans le bas de l’ écran, invisible. Y a t il un moyen de réduire la fenêtre de la console ?

Merci pour votre aide


#2

slt,

Est-ce que tu es sous l’interface graphique ou es tu dans le shell du demarrage ?


#3

salut stonfi,

je suis sous xp !!! je fais cohabiter les deux systèmes. Donc là je suis sur xp.


#4

Desoler, je connait pas windows ^_^…


#5

non je voulais dire que je suis actuellement sous xp car je ne peux pas te parler sur le net par linux vu que j’ ai pas tout terminé !

Donc quand je suis sur la debian ma console est trop grande (console shell) je pense. c’ est enervant parce que je ne vois pas ce que je tape !

as-tu une astuce pour réduire la taille de l’ écran ?


#6

slt,

Donc tu es sous xfree,xorg et tu n’arrive pas avoir ce que tu tape ? si oui tu peut editer le ficher /etc/X11/xorg.cfg ou /etc/xfree86.cfg, dans la section Section “Screen” tu peut changer la résolution au niveau de cette variable “DefaultDepth 24” tu choisie le depmod le plus petit pour commencer…


#7

dupont, j’ai déplacé le sujet: quand on a basoin d’aide, c’est GNU/Linux en général…


#8

il ne veut pas de tes deux lignes de commandes.

je ne sais pas si je suis spus xfree ou sorg.
lorsque linux se lance j’ atteris directement sur la console !


#9

slt,

Donc tu n’ai pas encore sous X, ca doit surement venir de ton chargeur de boot lequel utilise tu ? (lilo, grub)


#10

il utilise le chargeur de boot par défaut de l’install … grub.


#11

Tu n’as pas essayé de jouer sur les réglages du moniteur???


#12

sinon, je pense qu’en editant /boot/grub/menu.lst
en rajoutant l’option vga=792 dans la ligne root=/dev/hda

J’avais le problème inverse : un shell trop petit, ceci à résolu mon pb (la valeur 792 correspond à une résolution de 1024x768)


#13

salut Anti-T, et tous les autres

voici le fichier dont tu parles. Je trouves plusieurs lignes avec root=dev/hda ! je ne sais pas dans laquelle faire la modification.

menu.lst - See: grub(8), info grub, update-grub(8)

grub-install(8), grub-floppy(8),

grub-md5-crypt, /usr/share/doc/grub

and /usr/share/doc/grub-doc/.

default num

Set the default entry to the entry number NUM. Numbering starts from 0, and

the entry number 0 is the default if the command is not used.

You can specify ‘saved’ instead of a number. In this case, the default entry

is the entry saved with the command ‘savedefault’.

default 0

timeout sec

Set a timeout, in SEC seconds, before automatically booting the default entry

(normally the first entry defined).

timeout 5

Pretty colours

color cyan/blue white/blue

password [’–md5’] passwd

If used in the first section of a menu file, disable all interactive editing

control (menu entry editor and command-line) and entries protected by the

command ‘lock’

e.g. password topsecret

password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

password topsecret

examples

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

title Linux

root (hd0,1)

kernel /vmlinuz root=/dev/hda2 ro

Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specifiv kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt=root=/dev/hda3 ro

default grub root device

e.g. groot=(hd0,0)

groot=(hd0,2)

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

lockalternative=false

altoption boot targets option

multiple altoptions lines are allowed

e.g. altoptions=(extra menu suffix) extra boot options

altoptions=(recovery mode) single

altoptions=(recovery mode) single

controls how many kernels should be put into the menu.lst

only counts the first occurence of a kernel, not the

alternative kernel options

e.g. howmany=all

howmany=7

howmany=all

should update-grub create memtest86 boot option

e.g. memtest86=true

memtest86=false

memtest86=true

## End Default Options

title Debian GNU/Linux, kernel 2.6.8-2-386
root (hd0,2)
kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hda3 ro
initrd /boot/initrd.img-2.6.8-2-386
savedefault
boot

title Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.8-2-386
savedefault
boot

END DEBIAN AUTOMAGIC KERNELS LIST

This is a divider, added to separate the menu items below from the Debian

ones.

title Other operating systems:
root

This entry automatically added by the Debian installer for a non-linux OS

on /dev/hda1

title Windows NT/2000/XP
root (hd0,0)
savedefault
makeactive
chainloader +1


#14

Toute les lignes précédés du caratere # sont des commentaires.

la ligne a modifiée est la suivante (dans le dernier tiers entre ## ## End Default Options ## et ### END DEBIAN AUTOMAGIC KERNELS LIST )
Tu remplaces kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hda3 ro
par :

Je répete que 792 correspond à du 1024x768… à adapter en fonction des ecrans.
Pour d’autres configurations :

[quote] Résolution en pixels
Profondeur
de couleurs | 640x480 800x600 1024x768 1280x1024
256 (8bit)| 769 771 773 775
32000 (15bit)| 784 787 790 793
65000 (16bit)| 785 788 791 794
16.7 Mill.(24bit)| 786 789 792 795[/quote]

En esperant que ca t’aide…sinon, je seche…


#15

Chez moi, je n’ai pas ça et le fonctionnement est parfait.


#16

chez moi je l’avais pas et je me retrouvais avec une console en 600x480 :laughing:


#17

[CTRL] + [+]
[CTRL] + [-]


#18

[quote=“dupont”]bonjour,

je viens de terminer l’ installation de ma debian…non sans mal et j’ ai un petit soucis : l’ écran noir de la console prend tout l’ écran à tel point que je ne vois plus ce que je tapes car le curseur est dans le bas de l’ écran, invisible. Y a t il un moyen de réduire la fenêtre de la console ?

Merci pour votre aide[/quote]


#19

[quote=“ghostintheshell”][CTRL] + [+]
[CTRL] + [-][/quote]

c’est censé faire quoi?

Et le coup du clear, ca lui permettra seulement de se “replacer” en haut à gauche…


#20

c’est mieux que rien…